summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/README.skeleton4
-rw-r--r--meta-skeleton/conf/layer.conf2
-rw-r--r--meta-skeleton/conf/multilib-example.conf2
-rw-r--r--meta-skeleton/conf/multilib-example2.conf2
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb50
-rw-r--r--meta-skeleton/recipes-core/busybox/busybox_%.bbappend5
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/files/hello.c23
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb5
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb6
-rw-r--r--meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb5
-rw-r--r--meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb9
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c8
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb17
-rw-r--r--meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb13
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb9
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb17
16 files changed, 86 insertions, 91 deletions
diff --git a/meta-skeleton/README.skeleton b/meta-skeleton/README.skeleton
new file mode 100644
index 0000000000..35503c1f7d
--- /dev/null
+++ b/meta-skeleton/README.skeleton
@@ -0,0 +1,4 @@
1meta-skeleton
2=============
3
4The meta-skeleton layer contains example recipes and configuration files.
diff --git a/meta-skeleton/conf/layer.conf b/meta-skeleton/conf/layer.conf
index cea5c74f8b..963d2d5ce9 100644
--- a/meta-skeleton/conf/layer.conf
+++ b/meta-skeleton/conf/layer.conf
@@ -14,4 +14,4 @@ LAYERVERSION_skeleton = "1"
14 14
15LAYERDEPENDS_skeleton = "core" 15LAYERDEPENDS_skeleton = "core"
16 16
17LAYERSERIES_COMPAT_skeleton = "gatesgarth" 17LAYERSERIES_COMPAT_skeleton = "styhead"
diff --git a/meta-skeleton/conf/multilib-example.conf b/meta-skeleton/conf/multilib-example.conf
index da6da7f1f6..07fd7b6ce4 100644
--- a/meta-skeleton/conf/multilib-example.conf
+++ b/meta-skeleton/conf/multilib-example.conf
@@ -10,4 +10,4 @@
10MACHINE = "qemux86-64" 10MACHINE = "qemux86-64"
11require conf/multilib.conf 11require conf/multilib.conf
12MULTILIBS = "multilib:lib32" 12MULTILIBS = "multilib:lib32"
13DEFAULTTUNE_virtclass-multilib-lib32 = "x86" 13DEFAULTTUNE:virtclass-multilib-lib32 = "x86"
diff --git a/meta-skeleton/conf/multilib-example2.conf b/meta-skeleton/conf/multilib-example2.conf
index 2596f61d9f..39f385fcca 100644
--- a/meta-skeleton/conf/multilib-example2.conf
+++ b/meta-skeleton/conf/multilib-example2.conf
@@ -10,4 +10,4 @@
10MACHINE = "qemux86-64" 10MACHINE = "qemux86-64"
11require conf/multilib.conf 11require conf/multilib.conf
12MULTILIBS = "multilib:libx32" 12MULTILIBS = "multilib:libx32"
13DEFAULTTUNE_virtclass-multilib-libx32 = "x86-64-x32" 13DEFAULTTUNE:virtclass-multilib-libx32 = "x86-64-x32"
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
deleted file mode 100644
index 946a12d0a5..0000000000
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1SUMMARY = "Baremetal examples to work with the several QEMU architectures supported on OpenEmbedded"
2HOMEPAGE = "https://github.com/aehs29/baremetal-helloqemu"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
5
6SRCREV = "99f4fa4a3b266b42b52af302610b0f4f429ba5e3"
7PV = "0.1+git${SRCPV}"
8
9SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
10
11S = "${WORKDIR}/git"
12
13# The following variables should be set to accomodate each application
14BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}"
15IMAGE_LINK_NAME ?= "baremetal-helloworld-image-${MACHINE}"
16IMAGE_NAME_SUFFIX ?= ""
17
18# Baremetal-Image creates the proper wiring, assumes the output is provided in
19# binary and ELF format, installed on ${base_libdir}/firmware/ , we want a
20# package to be created since we might have some way of updating the baremetal
21# firmware from Linux
22inherit baremetal-image
23
24
25# These parameters are app specific for this example
26# This will be translated automatically to the architecture and
27# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57
28# but the examples can also be run on other architectures/machines
29# such as vexpress-a15 by overriding the setting on the machine.conf
30COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64"
31
32BAREMETAL_QEMUARCH ?= ""
33BAREMETAL_QEMUARCH_qemuarmv5 = "versatile"
34BAREMETAL_QEMUARCH_qemuarm = "arm"
35BAREMETAL_QEMUARCH_qemuarm64 = "aarch64"
36
37EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
38
39
40# Install binaries on the proper location for baremetal-image to fetch and deploy
41do_install(){
42 install -d ${D}/${base_libdir}/firmware
43 install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin
44 install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf
45}
46
47FILES_${PN} += " \
48 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \
49 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \
50"
diff --git a/meta-skeleton/recipes-core/busybox/busybox_%.bbappend b/meta-skeleton/recipes-core/busybox/busybox_%.bbappend
index 64cdefc76d..3c936eb713 100644
--- a/meta-skeleton/recipes-core/busybox/busybox_%.bbappend
+++ b/meta-skeleton/recipes-core/busybox/busybox_%.bbappend
@@ -2,11 +2,12 @@
2# mechanism as the linux-yocto kernel recipe. 2# mechanism as the linux-yocto kernel recipe.
3# 3#
4# The entries here will override any entries in the base busybox recipe 4# The entries here will override any entries in the base busybox recipe
5# when DISTRO = "mydistro" is defined in your conf/local.conf file.
5# 6#
6# More details can be found in the Kernel Dev Manual 7# More details can be found in the Kernel Dev Manual
7# http://www.yoctoproject.org/docs/current/kernel-dev/kernel-dev.html#changing-the-configuration 8# http://www.yoctoproject.org/docs/current/kernel-dev/kernel-dev.html#changing-the-configuration
8FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
9 10
10SRC_URI += " \ 11SRC_URI:append:mydistro = " \
11 file://no_rfkill.cfg \ 12 file://no_rfkill.cfg \
12 " 13 "
diff --git a/meta-skeleton/recipes-kernel/hello-mod/files/hello.c b/meta-skeleton/recipes-kernel/hello-mod/files/hello.c
index f3c0d372eb..4f73455d20 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/files/hello.c
+++ b/meta-skeleton/recipes-kernel/hello-mod/files/hello.c
@@ -2,32 +2,23 @@
2 * 2 *
3 * Copyright (C) 2011 Intel Corporation. All rights reserved. 3 * Copyright (C) 2011 Intel Corporation. All rights reserved.
4 * 4 *
5 * This program is free software; you can redistribute it and/or modify 5 * SPDX-License-Identifier: GPL-2.0-only
6 * it under the terms of the GNU General Public License as published by
7 * the Free Software Foundation; version 2 of the License.
8 *
9 * This program is distributed in the hope that it will be useful,
10 * but WITHOUT ANY WARRANTY; without even the implied warranty of
11 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
12 * the GNU General Public License for more details.
13 *
14 * You should have received a copy of the GNU General Public License
15 * along with this program; if not, write to the Free Software
16 * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
17 * 6 *
18 *****************************************************************************/ 7 *****************************************************************************/
19 8
20#include <linux/module.h> 9#include <linux/module.h>
21 10
22int init_module(void) 11static int __init hello_init(void)
23{ 12{
24 printk("Hello World!\n"); 13 pr_info("Hello World!\n");
25 return 0; 14 return 0;
26} 15}
27 16
28void cleanup_module(void) 17static void __exit hello_exit(void)
29{ 18{
30 printk("Goodbye Cruel World!\n"); 19 pr_info("Goodbye Cruel World!\n");
31} 20}
32 21
22module_init(hello_init);
23module_exit(hello_exit);
33MODULE_LICENSE("GPL"); 24MODULE_LICENSE("GPL");
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index 3d33446500..a2fb212a68 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -1,5 +1,6 @@
1SUMMARY = "Example of how to build an external Linux kernel module" 1SUMMARY = "Example of how to build an external Linux kernel module"
2LICENSE = "GPLv2" 2DESCRIPTION = "${SUMMARY}"
3LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" 4LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4 5
5inherit module 6inherit module
@@ -14,4 +15,4 @@ S = "${WORKDIR}"
14# The inherit of module.bbclass will automatically name module packages with 15# The inherit of module.bbclass will automatically name module packages with
15# "kernel-module-" prefix as required by the oe-core build environment. 16# "kernel-module-" prefix as required by the oe-core build environment.
16 17
17RPROVIDES_${PN} += "kernel-module-hello" 18RPROVIDES:${PN} += "kernel-module-hello"
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
index 6194d4f8da..9437240fcf 100644
--- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -1,6 +1,6 @@
1SUMMARY = "An example kernel recipe that uses the linux-yocto and oe-core"
1# linux-yocto-custom.bb: 2# linux-yocto-custom.bb:
2# 3#
3# An example kernel recipe that uses the linux-yocto and oe-core
4# kernel classes to apply a subset of yocto kernel management to git 4# kernel classes to apply a subset of yocto kernel management to git
5# managed kernel repositories. 5# managed kernel repositories.
6# 6#
@@ -57,14 +57,14 @@ require recipes-kernel/linux/linux-yocto.inc
57SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" 57SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine"
58 58
59LINUX_VERSION ?= "4.2" 59LINUX_VERSION ?= "4.2"
60LINUX_VERSION_EXTENSION_append = "-custom" 60LINUX_VERSION_EXTENSION:append = "-custom"
61 61
62# Modify SRCREV to a different commit hash in a copy of this recipe to 62# Modify SRCREV to a different commit hash in a copy of this recipe to
63# build a different release of the Linux kernel. 63# build a different release of the Linux kernel.
64# tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2 64# tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2
65SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2" 65SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2"
66 66
67PV = "${LINUX_VERSION}+git${SRCPV}" 67PV = "${LINUX_VERSION}+git"
68 68
69# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe 69# Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe
70# file. Leaving it empty here ensures an early explicit build failure. 70# file. Leaving it empty here ensures an early explicit build failure.
diff --git a/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb b/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb
index f13186f933..1290968b9d 100644
--- a/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb
+++ b/meta-skeleton/recipes-multilib/images/core-image-multilib-example.bb
@@ -1,5 +1,4 @@
1# 1SUMMARY = "An example of a multilib image"
2# An example of a multilib image
3# 2#
4# This example includes a lib32 version of bash into an otherwise standard 3# This example includes a lib32 version of bash into an otherwise standard
5# sato image. It assumes a "lib32" multilib has been enabled in the user's 4# sato image. It assumes a "lib32" multilib has been enabled in the user's
@@ -7,7 +6,7 @@
7# 6#
8 7
9# First include a base image to base things off 8# First include a base image to base things off
10require recipes-sato/images/core-image-sato.bb 9require recipes-graphics/images/core-image-weston.bb
11 10
12# Now add the multilib packages we want to install 11# Now add the multilib packages we want to install
13IMAGE_INSTALL += "lib32-bash" 12IMAGE_INSTALL += "lib32-bash"
diff --git a/meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb b/meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb
new file mode 100644
index 0000000000..a64088fbaa
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "GNU Helloworld application"
2SECTION = "examples"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6SRC_URI = "${GNU_MIRROR}/hello/hello-${PV}.tar.gz"
7SRC_URI[sha256sum] = "31e066137a962676e89f69d1b65382de95a7ef7d914b8cb956f41ea72e0f516b"
8
9inherit autotools-brokensep gettext
diff --git a/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c b/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
new file mode 100644
index 0000000000..fc7169b7b8
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
@@ -0,0 +1,8 @@
1#include <stdio.h>
2
3int main(void)
4{
5 printf("Hello world!\n");
6
7 return 0;
8}
diff --git a/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
new file mode 100644
index 0000000000..90d3aefd86
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Simple helloworld application"
2SECTION = "examples"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRC_URI = "file://helloworld.c"
7
8S = "${WORKDIR}"
9
10do_compile() {
11 ${CC} ${LDFLAGS} helloworld.c -o helloworld
12}
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 helloworld ${D}${bindir}
17}
diff --git a/meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb b/meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb
new file mode 100644
index 0000000000..1fcbbdd65e
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb
@@ -0,0 +1,13 @@
1require recipes-graphics/xorg-lib/xorg-lib-common.inc
2
3DESCRIPTION = "X11 Pixmap library"
4LICENSE = "X-BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3e07763d16963c3af12db271a31abaa5"
6DEPENDS += "libxext"
7PE = "1"
8
9XORG_PN = "libXpm"
10
11PACKAGES =+ "sxpm cxpm"
12FILES:cxpm = "${bindir}/cxpm"
13FILES:sxpm = "${bindir}/sxpm"
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index 6416618dcb..912f6b0f61 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -1,6 +1,7 @@
1SUMMARY = "The canonical example of init scripts" 1SUMMARY = "The canonical example of init scripts"
2SECTION = "base" 2SECTION = "base"
3LICENSE = "GPLv2" 3DESCRIPTION = "This recipe is a canonical example of init scripts"
4LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4" 5LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
5 6
6SRC_URI = "file://skeleton \ 7SRC_URI = "file://skeleton \
@@ -8,6 +9,8 @@ SRC_URI = "file://skeleton \
8 file://COPYRIGHT \ 9 file://COPYRIGHT \
9 " 10 "
10 11
12S = "${WORKDIR}"
13
11do_compile () { 14do_compile () {
12 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test 15 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
13} 16}
@@ -26,6 +29,6 @@ do_install () {
26 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ 29 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
27} 30}
28 31
29RDEPENDS_${PN} = "initscripts" 32RDEPENDS:${PN} = "initscripts"
30 33
31CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton" 34CONFFILES:${PN} += "${sysconfdir}/init.d/skeleton"
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 7c5b9d0503..8437a5a774 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -1,7 +1,6 @@
1SUMMARY = "Example recipe for using inherit useradd" 1SUMMARY = "Example recipe for using inherit useradd"
2DESCRIPTION = "This recipe serves as an example for using features from useradd.bbclass" 2DESCRIPTION = "This recipe serves as an example for using features from useradd.bbclass"
3SECTION = "examples" 3SECTION = "examples"
4PR = "r1"
5LICENSE = "MIT" 4LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7 6
@@ -30,19 +29,19 @@ USERADD_PACKAGES = "${PN} ${PN}-user3"
30# useradd command. Multiple users can be created by separating 29# useradd command. Multiple users can be created by separating
31# the commands with a semicolon. Here we'll create two users, 30# the commands with a semicolon. Here we'll create two users,
32# user1 and user2: 31# user1 and user2:
33USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" 32USERADD_PARAM:${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2"
34 33
35# user3 will be managed in the useradd-example-user3 pacakge: 34# user3 will be managed in the useradd-example-user3 package:
36# As an example, we use the -P option to set clear text password for user3 35# As an example, we use the -p option to set password ('user3') for user3
37USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3" 36USERADD_PARAM:${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -p '\$6\$XAWr.8nc\$bUE4pYYaVb8n6BbnBitU0zeJMtfhTpFpiOBLL9zRl4e4YQo88UU4r/1kjRzmTimCy.BvDh4xoFwVqcO.pihLa1' user3"
38 37
39# GROUPADD_PARAM works the same way, which you set to the options 38# GROUPADD_PARAM works the same way, which you set to the options
40# you'd normally pass to the groupadd command. This will create 39# you'd normally pass to the groupadd command. This will create
41# groups group1 and group2: 40# groups group1 and group2:
42GROUPADD_PARAM_${PN} = "-g 880 group1; -g 890 group2" 41GROUPADD_PARAM:${PN} = "-g 880 group1; -g 890 group2"
43 42
44# Likewise, we'll manage group3 in the useradd-example-user3 package: 43# Likewise, we'll manage group3 in the useradd-example-user3 package:
45GROUPADD_PARAM_${PN}-user3 = "-g 900 group3" 44GROUPADD_PARAM:${PN}-user3 = "-g 900 group3"
46 45
47do_install () { 46do_install () {
48 install -d -m 755 ${D}${datadir}/user1 47 install -d -m 755 ${D}${datadir}/user1
@@ -69,8 +68,8 @@ do_install () {
69 chgrp -R group3 ${D}${datadir}/user3 68 chgrp -R group3 ${D}${datadir}/user3
70} 69}
71 70
72FILES_${PN} = "${datadir}/user1/* ${datadir}/user2/*" 71FILES:${PN} = "${datadir}/user1/* ${datadir}/user2/*"
73FILES_${PN}-user3 = "${datadir}/user3/*" 72FILES:${PN}-user3 = "${datadir}/user3/*"
74 73
75# Prevents do_package failures with: 74# Prevents do_package failures with:
76# debugsources.list: No such file or directory: 75# debugsources.list: No such file or directory: