summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb')
-rw-r--r--meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb50
1 files changed, 0 insertions, 50 deletions
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
deleted file mode 100644
index 946a12d0a5..0000000000
--- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb
+++ /dev/null
@@ -1,50 +0,0 @@
1SUMMARY = "Baremetal examples to work with the several QEMU architectures supported on OpenEmbedded"
2HOMEPAGE = "https://github.com/aehs29/baremetal-helloqemu"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
5
6SRCREV = "99f4fa4a3b266b42b52af302610b0f4f429ba5e3"
7PV = "0.1+git${SRCPV}"
8
9SRC_URI = "git://github.com/aehs29/baremetal-helloqemu.git;protocol=https;branch=master"
10
11S = "${WORKDIR}/git"
12
13# The following variables should be set to accomodate each application
14BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}"
15IMAGE_LINK_NAME ?= "baremetal-helloworld-image-${MACHINE}"
16IMAGE_NAME_SUFFIX ?= ""
17
18# Baremetal-Image creates the proper wiring, assumes the output is provided in
19# binary and ELF format, installed on ${base_libdir}/firmware/ , we want a
20# package to be created since we might have some way of updating the baremetal
21# firmware from Linux
22inherit baremetal-image
23
24
25# These parameters are app specific for this example
26# This will be translated automatically to the architecture and
27# machine that QEMU uses on OE, e.g. -machine virt -cpu cortex-a57
28# but the examples can also be run on other architectures/machines
29# such as vexpress-a15 by overriding the setting on the machine.conf
30COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64"
31
32BAREMETAL_QEMUARCH ?= ""
33BAREMETAL_QEMUARCH_qemuarmv5 = "versatile"
34BAREMETAL_QEMUARCH_qemuarm = "arm"
35BAREMETAL_QEMUARCH_qemuarm64 = "aarch64"
36
37EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1"
38
39
40# Install binaries on the proper location for baremetal-image to fetch and deploy
41do_install(){
42 install -d ${D}/${base_libdir}/firmware
43 install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.bin ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin
44 install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf
45}
46
47FILES_${PN} += " \
48 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \
49 ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \
50"