summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-01-25 18:20:53 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-01-25 18:20:53 +0000
commitee56997e85a68575bc7bb8a8ee6945d77cf5fe02 (patch)
tree6900bb068e61ff3d1df54f53041f41c177f73a49
parentd02fe61c35a7c5dcec5f4e7e6b9f89eae0da8440 (diff)
downloadmeta-cloud-services-ee56997e85a68575bc7bb8a8ee6945d77cf5fe02.tar.gz
glusterfs: update to 11.1
Updating to 11.1, which requires the following changes: - patch context refreshes - SSL certification patch to configure.ac - drop obselete packageconfigs - package new outputs of the build - drop backported patches Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/glusterfs/files/0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch28
-rw-r--r--recipes-extended/glusterfs/files/0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch30
-rw-r--r--recipes-extended/glusterfs/files/CVE-2023-26253.patch76
-rw-r--r--recipes-extended/glusterfs/files/glusterfs-disable-default-startup-scripts.patch17
-rw-r--r--recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch37
-rw-r--r--recipes-extended/glusterfs/glusterfs.inc31
-rw-r--r--recipes-extended/glusterfs/glusterfs_11.1.bb6
-rw-r--r--recipes-extended/glusterfs/glusterfs_6.1.bb6
8 files changed, 85 insertions, 146 deletions
diff --git a/recipes-extended/glusterfs/files/0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch b/recipes-extended/glusterfs/files/0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch
index 79a55b3..1cdccf9 100644
--- a/recipes-extended/glusterfs/files/0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch
+++ b/recipes-extended/glusterfs/files/0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch
@@ -72,11 +72,11 @@ Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
72 cli/src/cli.h | 4 ++-- 72 cli/src/cli.h | 4 ++--
73 2 files changed, 5 insertions(+), 2 deletions(-) 73 2 files changed, 5 insertions(+), 2 deletions(-)
74 74
75diff --git a/cli/src/cli.c b/cli/src/cli.c 75Index: glusterfs-11.1/cli/src/cli.c
76index cb425c84b..2c96b7ae6 100644 76===================================================================
77--- a/cli/src/cli.c 77--- glusterfs-11.1.orig/cli/src/cli.c
78+++ b/cli/src/cli.c 78+++ glusterfs-11.1/cli/src/cli.c
79@@ -84,6 +84,9 @@ rpc_clnt_prog_t *cli_rpc_prog; 79@@ -65,6 +65,9 @@
80 80
81 extern struct rpc_clnt_program cli_prog; 81 extern struct rpc_clnt_program cli_prog;
82 82
@@ -86,21 +86,3 @@ index cb425c84b..2c96b7ae6 100644
86 static int 86 static int
87 glusterfs_ctx_defaults_init(glusterfs_ctx_t *ctx) 87 glusterfs_ctx_defaults_init(glusterfs_ctx_t *ctx)
88 { 88 {
89diff --git a/cli/src/cli.h b/cli/src/cli.h
90index 81f75a0b4..cd4db3dac 100644
91--- a/cli/src/cli.h
92+++ b/cli/src/cli.h
93@@ -40,8 +40,8 @@ enum argp_option_keys {
94 ARGP_PORT_KEY = 'p',
95 };
96
97-int cli_default_conn_timeout;
98-int cli_ten_minutes_timeout;
99+extern int cli_default_conn_timeout;
100+extern int cli_ten_minutes_timeout;
101
102 typedef enum {
103 COLD_BRICK_COUNT,
104--
1052.21.0
106
diff --git a/recipes-extended/glusterfs/files/0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch b/recipes-extended/glusterfs/files/0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch
new file mode 100644
index 0000000..d139ea2
--- /dev/null
+++ b/recipes-extended/glusterfs/files/0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch
@@ -0,0 +1,30 @@
1From 526b64958b8aabcbad48ffb61f6855b374a68da6 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Thu, 25 Jan 2024 18:08:01 +0000
4Subject: [PATCH] configure: pass SSL_CERTS. Don't discover it
5
6Executing the ssl binary to locate the certificates doesn't work
7in our environment. Pass it to the build instead.
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
12---
13 configure.ac | 1 +
14 1 file changed, 1 insertion(+)
15
16diff --git a/configure.ac b/configure.ac
17index 1cda220..fe14134 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -814,6 +814,7 @@ AS_IF([test "x$enable_fuse_notifications" != "xno"], [
21 dnl Find out OpenSSL trusted certificates path
22 AC_MSG_CHECKING([for OpenSSL trusted certificates path])
23 SSL_CERT_PATH=$(openssl version -d | sed -e 's|OPENSSLDIR: "\(.*\)".*|\1|')
24+SSL_CERT_PATH="${SSL_CERTS_DIR}"
25 if test -d "${SSL_CERT_PATH}" 1>/dev/null 2>&1; then
26 AC_MSG_RESULT([$SSL_CERT_PATH])
27 AC_DEFINE_UNQUOTED(SSL_CERT_PATH, ["$SSL_CERT_PATH"], [Path to OpenSSL trusted certificates.])
28--
292.39.2
30
diff --git a/recipes-extended/glusterfs/files/CVE-2023-26253.patch b/recipes-extended/glusterfs/files/CVE-2023-26253.patch
deleted file mode 100644
index 828c162..0000000
--- a/recipes-extended/glusterfs/files/CVE-2023-26253.patch
+++ /dev/null
@@ -1,76 +0,0 @@
1commit 0cbf51a9827af0e3a35f5cfa823bfa39740bbc58
2Author: mohit84 <moagrawa@redhat.com>
3Date: Thu Mar 30 13:02:19 2023 +0530
4Subject: [PATCH] fuse: Resolve asan bug in during receive event notification
5 (#4024)
6
7 The fuse xlator notify function tries to assign data object to graph
8 object without checking an event. In case of upcall event data object
9 represents upcall object so during access of graph object the process
10 crashed for asan build.
11
12 Solution: Access the graph->id only while an event is associated
13 specifically to fuse xlator
14
15 > Fixes: #3954
16 > Change-Id: I6b2869256b26d22163879737dcf163510d1cd8bf
17 > Signed-off-by: Mohit Agrawal moagrawa@redhat.com
18 > (Reviewed on upstream link #4019)
19
20 Fixes: #3954
21 Change-Id: I6b2869256b26d22163879737dcf163510d1cd8bf
22
23CVE: CVE-2023-26253
24
25Upstream-Status: Backport [https://github.com/gluster/glusterfs/commit/0cbf51a9827af0e3a35f5cfa823bfa39740bbc58]
26
27Signed-off-by: Soumya <soumya.sambu@windriver.com>
28---
29 xlators/mount/fuse/src/fuse-bridge.c | 14 +++++++++++---
30 1 file changed, 11 insertions(+), 3 deletions(-)
31
32diff --git a/xlators/mount/fuse/src/fuse-bridge.c b/xlators/mount/fuse/src/fuse-bridge.c
33index c3945d7..0c01a43 100644
34--- a/xlators/mount/fuse/src/fuse-bridge.c
35+++ b/xlators/mount/fuse/src/fuse-bridge.c
36@@ -6198,6 +6198,7 @@ notify(xlator_t *this, int32_t event, void *data, ...)
37 int32_t ret = 0;
38 fuse_private_t *private = NULL;
39 gf_boolean_t start_thread = _gf_false;
40+ gf_boolean_t event_graph = _gf_true;
41 glusterfs_graph_t *graph = NULL;
42
43 private
44@@ -6205,9 +6206,6 @@ notify(xlator_t *this, int32_t event, void *data, ...)
45
46 graph = data;
47
48- gf_log("fuse", GF_LOG_DEBUG, "got event %d on graph %d", event,
49- ((graph) ? graph->id : 0));
50-
51 switch (event) {
52 case GF_EVENT_GRAPH_NEW:
53 break;
54@@ -6271,9 +6269,19 @@ notify(xlator_t *this, int32_t event, void *data, ...)
55 }
56
57 default:
58+ /* Set the event_graph to false so that event
59+ debug msg would not try to access invalid graph->id
60+ while data object is not matched to graph object
61+ for ex in case of upcall event data object represents
62+ gf_upcall object
63+ */
64+ event_graph = _gf_false;
65 break;
66 }
67
68+ gf_log("fuse", GF_LOG_DEBUG, "got event %d on graph %d", event,
69+ ((graph && event_graph) ? graph->id : -1));
70+
71 return ret;
72 }
73
74--
752.35.5
76
diff --git a/recipes-extended/glusterfs/files/glusterfs-disable-default-startup-scripts.patch b/recipes-extended/glusterfs/files/glusterfs-disable-default-startup-scripts.patch
index c8e0e7d..7a72e9c 100644
--- a/recipes-extended/glusterfs/files/glusterfs-disable-default-startup-scripts.patch
+++ b/recipes-extended/glusterfs/files/glusterfs-disable-default-startup-scripts.patch
@@ -24,19 +24,16 @@ Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
24 extras/Makefile.am | 2 +- 24 extras/Makefile.am | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-) 25 1 file changed, 1 insertion(+), 1 deletion(-)
26 26
27diff --git a/extras/Makefile.am b/extras/Makefile.am 27Index: glusterfs-11.1/extras/Makefile.am
28index ff5ca9b..1f59746 100644 28===================================================================
29--- a/extras/Makefile.am 29--- glusterfs-11.1.orig/extras/Makefile.am
30+++ b/extras/Makefile.am 30+++ glusterfs-11.1/extras/Makefile.am
31@@ -10,7 +10,7 @@ endif 31@@ -10,7 +10,7 @@
32 EditorModedir = $(docdir) 32 EditorModedir = $(docdir)
33 EditorMode_DATA = glusterfs-mode.el glusterfs.vim 33 EditorMode_DATA = glusterfs-mode.el glusterfs.vim
34 34
35-SUBDIRS = init.d systemd benchmarking hook-scripts $(OCF_SUBDIR) LinuxRPM \ 35-SUBDIRS = init.d systemd benchmarking hook-scripts $(OCF_SUBDIR) LinuxRPM \
36+SUBDIRS = benchmarking hook-scripts $(OCF_SUBDIR) LinuxRPM \ 36+SUBDIRS = benchmarking hook-scripts $(OCF_SUBDIR) LinuxRPM \
37 $(GEOREP_EXTRAS_SUBDIR) snap_scheduler firewalld cliutils python 37 $(GEOREP_EXTRAS_SUBDIR) snap_scheduler firewalld cliutils python \
38 ganesha command-completion
38 39
39 confdir = $(sysconfdir)/glusterfs
40--
412.8.1
42
diff --git a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
index e8f99ac..9b807fe 100644
--- a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
+++ b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
@@ -26,24 +26,24 @@ Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
26 geo-replication/src/gsyncd.c | 6 +++--- 26 geo-replication/src/gsyncd.c | 6 +++---
27 3 files changed, 7 insertions(+), 4 deletions(-) 27 3 files changed, 7 insertions(+), 4 deletions(-)
28 28
29diff --git a/configure.ac b/configure.ac 29Index: glusterfs-11.1/configure.ac
30index bc4cf93..d55a7b2 100644 30===================================================================
31--- a/configure.ac 31--- glusterfs-11.1.orig/configure.ac
32+++ b/configure.ac 32+++ glusterfs-11.1/configure.ac
33@@ -279,6 +279,8 @@ AC_CANONICAL_HOST 33@@ -261,6 +261,8 @@
34 AC_PROG_CC 34 AC_PROG_CC
35 AC_DISABLE_STATIC 35 AC_DISABLE_STATIC
36 AC_PROG_LIBTOOL 36 LT_INIT
37+AC_SUBST(TARGET_PYTHON) 37+AC_SUBST(TARGET_PYTHON)
38+ 38+
39 AC_SUBST([shrext_cmds]) 39 AC_SUBST([shrext_cmds])
40 40
41 AC_CHECK_PROG([RPCGEN], [rpcgen], [yes], [no]) 41 AC_CHECK_PROG([RPCGEN], [rpcgen], [yes], [no])
42diff --git a/geo-replication/src/Makefile.am b/geo-replication/src/Makefile.am 42Index: glusterfs-11.1/geo-replication/src/Makefile.am
43index 9937a0b..07456fb 100644 43===================================================================
44--- a/geo-replication/src/Makefile.am 44--- glusterfs-11.1.orig/geo-replication/src/Makefile.am
45+++ b/geo-replication/src/Makefile.am 45+++ glusterfs-11.1/geo-replication/src/Makefile.am
46@@ -22,7 +22,8 @@ noinst_HEADERS = procdiggy.h 46@@ -22,7 +22,8 @@
47 AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \ 47 AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
48 -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \ 48 -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
49 -DGSYNCD_PREFIX=\"$(GLUSTERFS_LIBEXECDIR)\" -DUSE_LIBGLUSTERFS \ 49 -DGSYNCD_PREFIX=\"$(GLUSTERFS_LIBEXECDIR)\" -DUSE_LIBGLUSTERFS \
@@ -53,11 +53,11 @@ index 9937a0b..07456fb 100644
53 53
54 AM_CFLAGS = -Wall $(GF_CFLAGS) 54 AM_CFLAGS = -Wall $(GF_CFLAGS)
55 55
56diff --git a/geo-replication/src/gsyncd.c b/geo-replication/src/gsyncd.c 56Index: glusterfs-11.1/geo-replication/src/gsyncd.c
57index 77af662..8cd0551 100644 57===================================================================
58--- a/geo-replication/src/gsyncd.c 58--- glusterfs-11.1.orig/geo-replication/src/gsyncd.c
59+++ b/geo-replication/src/gsyncd.c 59+++ glusterfs-11.1/geo-replication/src/gsyncd.c
60@@ -118,9 +118,9 @@ invoke_gsyncd(int argc, char **argv) 60@@ -115,9 +115,9 @@
61 goto error; 61 goto error;
62 62
63 j = 0; 63 j = 0;
@@ -69,7 +69,7 @@ index 77af662..8cd0551 100644
69 nargv[j++] = python; 69 nargv[j++] = python;
70 nargv[j++] = GSYNCD_PREFIX "/python/syncdaemon/" GSYNCD_PY; 70 nargv[j++] = GSYNCD_PREFIX "/python/syncdaemon/" GSYNCD_PY;
71 for (i = 1; i < argc; i++) 71 for (i = 1; i < argc; i++)
72@@ -170,7 +170,7 @@ find_gsyncd(pid_t pid, pid_t ppid, char *name, void *data) 72@@ -167,7 +167,7 @@
73 ret = 0; 73 ret = 0;
74 switch (zeros) { 74 switch (zeros) {
75 case 2: 75 case 2:
@@ -78,6 +78,3 @@ index 77af662..8cd0551 100644
78 strcmp(basename(buf + strlen(buf) + 1), GSYNCD_PY)) == 0) { 78 strcmp(basename(buf + strlen(buf) + 1), GSYNCD_PY)) == 0) {
79 ret = 1; 79 ret = 1;
80 break; 80 break;
81--
822.17.1
83
diff --git a/recipes-extended/glusterfs/glusterfs.inc b/recipes-extended/glusterfs/glusterfs.inc
index e5bedca..c5f21c7 100644
--- a/recipes-extended/glusterfs/glusterfs.inc
+++ b/recipes-extended/glusterfs/glusterfs.inc
@@ -20,7 +20,7 @@ SRC_URI += "file://glusterd.init \
20 file://glusterd-change-port-range.patch \ 20 file://glusterd-change-port-range.patch \
21 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \ 21 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
22 file://0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch \ 22 file://0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch \
23 file://CVE-2023-26253.patch \ 23 file://0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch \
24 " 24 "
25 25
26LICENSE = "(LGPL-3.0-or-later | GPL-2.0-only) & GPL-3.0-or-later & LGPL-3.0-or-later & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & Apache-2.0" 26LICENSE = "(LGPL-3.0-or-later | GPL-2.0-only) & GPL-3.0-or-later & LGPL-3.0-or-later & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & Apache-2.0"
@@ -30,9 +30,10 @@ LIC_FILES_CHKSUM = "file://COPYING-GPLV2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
30 30
31inherit autotools pkgconfig setuptools3-base update-rc.d systemd 31inherit autotools pkgconfig setuptools3-base update-rc.d systemd
32inherit python3-dir 32inherit python3-dir
33inherit bash-completion
33 34
34DEPENDS += "bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \ 35DEPENDS += "openssl-native bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \
35 openssl python3 readline zlib liburcu util-linux glib-2.0 acl" 36 openssl python3 readline zlib liburcu util-linux glib-2.0 acl ca-certificates ca-certificates-native liburing"
36 37
37# rpc now comes from libtirpc instead of glibc 38# rpc now comes from libtirpc instead of glibc
38# 39#
@@ -42,25 +43,29 @@ LDFLAGS += " -ltirpc"
42EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \ 43EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \
43 ac_cv_file__etc_SuSE_release=no \ 44 ac_cv_file__etc_SuSE_release=no \
44 ac_cv_file__etc_redhat_release=no \ 45 ac_cv_file__etc_redhat_release=no \
45 ac_cv_file__etc_centos_release=no \ 46 ac_cv_file__etc_centos_release=no \
47 ac_cv_file__etc_os_release=no \
46 --with-mountutildir=${sbindir} \ 48 --with-mountutildir=${sbindir} \
47 --disable-fusermount \ 49 --disable-fusermount \
48 TARGET_PYTHON=${bindir}/python3 \ 50 TARGET_PYTHON=${bindir}/python3 \
49 PYTHON=${PYTHON} \ 51 PYTHON=${PYTHON} \
52 SSL_CERTS_DIR="${sysconfdir_native}/ssl/certs" \
50 BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ 53 BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
51 BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \ 54 BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \
52 BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \ 55 BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \
53 " 56 "
54 57
55PACKAGECONFIG ??= "georeplication libibverbs" 58PACKAGECONFIG ??= "georeplication"
56PACKAGECONFIG:remove:mipsarch = "libibverbs"
57PACKAGECONFIG:remove:arm = "libibverbs"
58 59
59PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,," 60PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
60PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync" 61PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync"
61PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm," 62# PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm,"
62PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,," 63PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,,"
63PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind," 64PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
65PACKAGECONFIG[tcmalloc] = ",--without-tcmalloc,,"
66
67# TODO: packageconfig for:
68# --disable-linux-io_uring
64 69
65do_install:append() { 70do_install:append() {
66 install -d ${D}${sysconfdir}/init.d 71 install -d ${D}${sysconfdir}/init.d
@@ -141,7 +146,7 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
141 ${libdir}/glusterfs/${PV}/xlator/protocol/client* \ 146 ${libdir}/glusterfs/${PV}/xlator/protocol/client* \
142 ${libdir}/glusterfs/${PV}/xlator/system \ 147 ${libdir}/glusterfs/${PV}/xlator/system \
143 ${libdir}/glusterfs/${PV}/xlator/testing \ 148 ${libdir}/glusterfs/${PV}/xlator/testing \
144 ${libdir}/glusterfs/${PV}/xlator/playground \ 149 ${libdir}/glusterfs/${PV}/xlator/playground \
145 ${libdir}/glusterfs/${PV}/xlator/meta.so \ 150 ${libdir}/glusterfs/${PV}/xlator/meta.so \
146 ${libdir}/glusterfs/ganesha \ 151 ${libdir}/glusterfs/ganesha \
147 ${libdir}/glusterfs/glusterfs/glusterfind \ 152 ${libdir}/glusterfs/glusterfs/glusterfind \
@@ -154,7 +159,7 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
154 ${libdir}/libgfdb.so.* \ 159 ${libdir}/libgfdb.so.* \
155 ${libdir}/libgfxdr.so.* \ 160 ${libdir}/libgfxdr.so.* \
156 ${libdir}/python*/site-packages \ 161 ${libdir}/python*/site-packages \
157 ${libexecdir}/glusterfs/gfevents \ 162 ${libexecdir}/glusterfs/gfevents \
158 ${libexecdir}/glusterfs/events \ 163 ${libexecdir}/glusterfs/events \
159 ${libexecdir}/glusterfs/glusterfind \ 164 ${libexecdir}/glusterfs/glusterfind \
160 ${libexecdir}/glusterfs/gfind_missing_files \ 165 ${libexecdir}/glusterfs/gfind_missing_files \
@@ -164,7 +169,10 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
164 ${libexecdir}/glusterfs/peer_mountbroker \ 169 ${libexecdir}/glusterfs/peer_mountbroker \
165 ${libexecdir}/glusterfs/peer_gsec_create \ 170 ${libexecdir}/glusterfs/peer_gsec_create \
166 ${libexecdir}/glusterfs/gverify.sh \ 171 ${libexecdir}/glusterfs/gverify.sh \
172 ${libexecdir}/glusterfs/glfsheal \
173 ${libexecdir}/glusterfs/scripts/ \
167 ${libexecdir}/glusterfs/peer_add_secret_pub \ 174 ${libexecdir}/glusterfs/peer_add_secret_pub \
175 ${libexecdir}/ganesha/ \
168 ${localstatedir} \ 176 ${localstatedir} \
169 ${sysconfdir}/default/volatiles \ 177 ${sysconfdir}/default/volatiles \
170 ${sbindir}/glusterfs \ 178 ${sbindir}/glusterfs \
@@ -176,7 +184,7 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
176 ${sbindir}/glustereventsd \ 184 ${sbindir}/glustereventsd \
177 ${sbindir}/gf_attach \ 185 ${sbindir}/gf_attach \
178 ${sbindir}/*.py \ 186 ${sbindir}/*.py \
179 ${sbindir}/gluster-setgfid2path \ 187 ${sbindir}/gluster-setgfid2path \
180 ${bindir}/ \ 188 ${bindir}/ \
181 ${sysconfdir}/glusterfs \ 189 ${sysconfdir}/glusterfs \
182 ${sysconfdir}/ganesha \ 190 ${sysconfdir}/ganesha \
@@ -200,6 +208,7 @@ FILES:${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
200 ${libdir}/glusterfs/${PV}/xlator/nfs \ 208 ${libdir}/glusterfs/${PV}/xlator/nfs \
201 ${libdir}/glusterfs/${PV}/xlator/protocol/server* \ 209 ${libdir}/glusterfs/${PV}/xlator/protocol/server* \
202 ${libdir}/glusterfs/${PV}/xlator/storage \ 210 ${libdir}/glusterfs/${PV}/xlator/storage \
211 ${libdir}/glusterfs/${PV}/cloudsync-plugins/ \
203 ${sbindir}/gluster \ 212 ${sbindir}/gluster \
204 ${sbindir}/glusterd \ 213 ${sbindir}/glusterd \
205 ${sysconfdir}/glusterfs/glusterd.vol \ 214 ${sysconfdir}/glusterfs/glusterd.vol \
diff --git a/recipes-extended/glusterfs/glusterfs_11.1.bb b/recipes-extended/glusterfs/glusterfs_11.1.bb
new file mode 100644
index 0000000..224fe18
--- /dev/null
+++ b/recipes-extended/glusterfs/glusterfs_11.1.bb
@@ -0,0 +1,6 @@
1SRC_URI = "https://bits.gluster.org/pub/gluster/glusterfs/src/${BPN}-${PV}.tar.gz"
2
3SRC_URI[md5sum] = "7e290a50026752f435f694651687e0f2"
4SRC_URI[sha256sum] = "6a31b8450d02cd12f47f4571c031e9d6b8705279a0e8970ae9a05e1c87dffb76"
5
6require glusterfs.inc
diff --git a/recipes-extended/glusterfs/glusterfs_6.1.bb b/recipes-extended/glusterfs/glusterfs_6.1.bb
deleted file mode 100644
index e109c08..0000000
--- a/recipes-extended/glusterfs/glusterfs_6.1.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1SRC_URI = "https://bits.gluster.org/pub/gluster/glusterfs/src/${BPN}-${PV}.tar.gz"
2
3SRC_URI[md5sum] = "18967c357204d4cbdd9c1731508862c6"
4SRC_URI[sha256sum] = "32ac75c883cdf18e081893ce5210b2331f1ee9ba25e3f3f56136d9878b194dc7"
5
6require glusterfs.inc