summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHitendra Prajapati <hprajapati@mvista.com>2024-01-12 11:20:43 +0530
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-01-15 21:50:19 +0000
commitd02fe61c35a7c5dcec5f4e7e6b9f89eae0da8440 (patch)
treef9699a78c39b74519c15adf8dfe59b96cae3be68
parent28fcb27fbbab03a412f2126da3bec79acda6d9b0 (diff)
downloadmeta-cloud-services-d02fe61c35a7c5dcec5f4e7e6b9f89eae0da8440.tar.gz
Remove tag values from SRC_URI to build recipe
To build the fluentd recipe, facing the Bitbake Fetcher Error: FetchError("Recipe uses a floating tag/branch 'v1.9.2' for repo 'github.com/fluent/fluentd.git' without a fixed SRCREV yet doesn't call bb.fetch2.get_srcrev() (use SRCPV in PV for OE).", None) To fix this issue, Remove tag values from SRC_URI for recipe and its dependent recipe file. Upgrade "cool.io", "http-parser.rb" and "strptime" recipe to resolve the runtime dependency issue. Signed-off-by: Hitendra Prajapati <hprajapati@mvista.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/ruby/cool.io_1.7.0.bb (renamed from meta-openstack/recipes-devtools/ruby/cool.io_1.6.0.bb)5
-rw-r--r--meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb4
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb (renamed from meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb)6
-rw-r--r--meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb5
-rw-r--r--meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/strptime_0.2.5.bb (renamed from meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb)6
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb6
-rw-r--r--meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb6
10 files changed, 46 insertions, 10 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/cool.io_1.6.0.bb b/meta-openstack/recipes-devtools/ruby/cool.io_1.7.0.bb
index baa6340..10e9a49 100644
--- a/meta-openstack/recipes-devtools/ruby/cool.io_1.6.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/cool.io_1.7.0.bb
@@ -4,9 +4,12 @@ HOMEPAGE = 'http://coolio.github.com'
4LICENSE = 'MIT' 4LICENSE = 'MIT'
5LIC_FILES_CHKSUM = 'file://LICENSE;md5=a5e7701a63eb0a961f98cd10475129b9' 5LIC_FILES_CHKSUM = 'file://LICENSE;md5=a5e7701a63eb0a961f98cd10475129b9'
6 6
7SRC_URI = 'git://github.com/tarcieri/cool.io.git;protocol=https;tag=v1.6.0' 7SRCREV = 'd7ab8518c11d8fe1b9a679a1686f01a295690fa9'
8
9SRC_URI = 'git://github.com/tarcieri/cool.io.git;protocol=https;branch=master'
8 10
9S = '${WORKDIR}/git' 11S = '${WORKDIR}/git'
10 12
11inherit ruby 13inherit ruby
12 14
15FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
index 94d1ec8..dc984d3 100644
--- a/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
+++ b/meta-openstack/recipes-devtools/ruby/fluentd_1.9.2.bb
@@ -3,7 +3,9 @@ HOMEPAGE = "https://www.fluentd.org/"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1ffc336af228834e68e0a4d38da165f7" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=1ffc336af228834e68e0a4d38da165f7"
5 5
6SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;tag=v${PV};branch=master" 6SRCREV = "9d113029d4550ce576d8825bfa9612aa3e55bff0"
7
8SRC_URI = "git://github.com/fluent/fluentd.git;protocol=https;branch=master"
7 9
8S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
9 11
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
index 296b8dd..5452c12 100644
--- a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
@@ -4,7 +4,9 @@ HOMEPAGE = "https://rubygems.org/gems/http_parser.rb"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=157efc3766c6d07d3d857ebbab43351a" 5LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=157efc3766c6d07d3d857ebbab43351a"
6 6
7SRC_URI = "git://github.com/tmm1/http_parser.rb.git;protocol=https;tag=v0.6.0;branch=master" 7SRCREV = "c8dae7c6c2c78a5016d082a7fbda7e362292c14a"
8
9SRC_URI = "gitsm://github.com/tmm1/http_parser.rb.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
@@ -20,3 +22,5 @@ do_configure:prepend() {
20 cd ${WORKDIR}/git 22 cd ${WORKDIR}/git
21 git submodule update --init --recursive 23 git submodule update --init --recursive
22} 24}
25
26FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb b/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb
index f40d6cf..5382676 100644
--- a/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/msgpack_1.3.3.bb
@@ -4,9 +4,12 @@ HOMEPAGE = "http://msgpack.org/"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
6 6
7SRC_URI = "git://github.com/msgpack/msgpack-ruby.git;protocol=https;tag=v${PV};branch=master" 7SRCREV = "64db1bac56359c9257d22f3ffb7506b578d76741"
8
9SRC_URI = "git://github.com/msgpack/msgpack-ruby.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
11inherit ruby 13inherit ruby
12 14
15FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
index 516a72e..553c567 100644
--- a/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/serverengine_2.2.1.bb
@@ -4,10 +4,14 @@ HOMEPAGE = 'https://rubygems.org/gems/serverengine'
4LICENSE = 'Apache-2.0' 4LICENSE = 'Apache-2.0'
5LIC_FILES_CHKSUM = 'file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57' 5LIC_FILES_CHKSUM = 'file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57'
6 6
7SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;tag=v2.2.1' 7SRCREV = '99d44a0989ab3e64e14ac0367aadf76aa13b3583'
8
9SRC_URI = 'git://github.com/treasure-data/serverengine.git;protocol=https;branch=master'
8 10
9S = '${WORKDIR}/git' 11S = '${WORKDIR}/git'
10 12
11RDEPENDS:${PN} = "sigdump" 13RDEPENDS:${PN} = "sigdump"
12 14
13inherit ruby 15inherit ruby
16
17FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb b/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
index 2f6b8d5..fc5152e 100644
--- a/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
+++ b/meta-openstack/recipes-devtools/ruby/sigdump_0.2.4.bb
@@ -4,8 +4,12 @@ HOMEPAGE = "https://github.com/frsyuki/sigdump"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07d6218b18fb6826f04fd32b4918f085" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=07d6218b18fb6826f04fd32b4918f085"
6 6
7SRC_URI = "git://github.com/frsyuki/sigdump.git;protocol=https;tag=v0.2.4;branch=master" 7SRCREV = "57570f04456560512e4efc1c6fa695b76c17dc0d"
8
9SRC_URI = "git://github.com/frsyuki/sigdump.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
11inherit ruby 13inherit ruby
14
15FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb b/meta-openstack/recipes-devtools/ruby/strptime_0.2.5.bb
index 7167d9a..d568272 100644
--- a/meta-openstack/recipes-devtools/ruby/strptime_0.2.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/strptime_0.2.5.bb
@@ -4,10 +4,14 @@ HOMEPAGE = "https://github.com/nurse/strptime"
4LICENSE = "BSD-2-Clause" 4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f19575067ffc5f1ddc02c74eeef9904f" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f19575067ffc5f1ddc02c74eeef9904f"
6 6
7SRC_URI = "git://github.com/nurse/strptime.git;protocol=https;tag=v0.2.3;branch=master" 7SRCREV = "1583aaa510cae4660907b22c8262ab31b1eb1864"
8
9SRC_URI = "git://github.com/nurse/strptime.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
11RDEPENDS:${PN} = "bash" 13RDEPENDS:${PN} = "bash"
12 14
13inherit ruby 15inherit ruby
16
17FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb b/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
index 6b1d01c..4640755 100644
--- a/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
@@ -4,8 +4,12 @@ HOMEPAGE = "https://tzinfo.github.io/"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f"
6 6
7SRC_URI = "git://github.com/tzinfo/tzinfo-data.git;protocol=https;tag=v1.2019.3;branch=master" 7SRCREV = "74d5a2529d585e1d1ab47b6bbb2449cba29f6907"
8
9SRC_URI = "git://github.com/tzinfo/tzinfo-data.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
11inherit ruby 13inherit ruby
14
15FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
index 07680d7..504e3a8 100644
--- a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
@@ -4,10 +4,14 @@ HOMEPAGE = "https://tzinfo.github.io/"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f"
6 6
7SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;tag=v2.0.1;branch=master" 7SRCREV = "16b0ff837923401da52325312c51baf9bec700e1"
8
9SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
11RDEPENDS:${PN} = "concurrent-ruby" 13RDEPENDS:${PN} = "concurrent-ruby"
12 14
13inherit ruby 15inherit ruby
16
17FILES:${PN} += "${libdir}/*"
diff --git a/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb b/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb
index a0635e3..f91d414 100644
--- a/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb
+++ b/meta-openstack/recipes-devtools/ruby/yajl-ruby_1.4.0.bb
@@ -4,8 +4,12 @@ HOMEPAGE = "http://rdoc.info/projects/brianmario/yajl-ruby"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7dbd3a9f471247a243db5b62fe091587" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=7dbd3a9f471247a243db5b62fe091587"
6 6
7SRC_URI = "git://github.com/brianmario/yajl-ruby.git;protocol=https;tag=1.4.0;branch=master" 7SRCREV = "8830754ac1ca04a0c14f71f6e7c1d240934366fe"
8
9SRC_URI = "git://github.com/brianmario/yajl-ruby.git;protocol=https;branch=master"
8 10
9S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
10 12
11inherit ruby 13inherit ruby
14
15FILES:${PN} += "${libdir}/*"