summaryrefslogtreecommitdiffstats
path: root/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch')
-rw-r--r--recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch37
1 files changed, 17 insertions, 20 deletions
diff --git a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
index e8f99ac..9b807fe 100644
--- a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
+++ b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch
@@ -26,24 +26,24 @@ Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
26 geo-replication/src/gsyncd.c | 6 +++--- 26 geo-replication/src/gsyncd.c | 6 +++---
27 3 files changed, 7 insertions(+), 4 deletions(-) 27 3 files changed, 7 insertions(+), 4 deletions(-)
28 28
29diff --git a/configure.ac b/configure.ac 29Index: glusterfs-11.1/configure.ac
30index bc4cf93..d55a7b2 100644 30===================================================================
31--- a/configure.ac 31--- glusterfs-11.1.orig/configure.ac
32+++ b/configure.ac 32+++ glusterfs-11.1/configure.ac
33@@ -279,6 +279,8 @@ AC_CANONICAL_HOST 33@@ -261,6 +261,8 @@
34 AC_PROG_CC 34 AC_PROG_CC
35 AC_DISABLE_STATIC 35 AC_DISABLE_STATIC
36 AC_PROG_LIBTOOL 36 LT_INIT
37+AC_SUBST(TARGET_PYTHON) 37+AC_SUBST(TARGET_PYTHON)
38+ 38+
39 AC_SUBST([shrext_cmds]) 39 AC_SUBST([shrext_cmds])
40 40
41 AC_CHECK_PROG([RPCGEN], [rpcgen], [yes], [no]) 41 AC_CHECK_PROG([RPCGEN], [rpcgen], [yes], [no])
42diff --git a/geo-replication/src/Makefile.am b/geo-replication/src/Makefile.am 42Index: glusterfs-11.1/geo-replication/src/Makefile.am
43index 9937a0b..07456fb 100644 43===================================================================
44--- a/geo-replication/src/Makefile.am 44--- glusterfs-11.1.orig/geo-replication/src/Makefile.am
45+++ b/geo-replication/src/Makefile.am 45+++ glusterfs-11.1/geo-replication/src/Makefile.am
46@@ -22,7 +22,8 @@ noinst_HEADERS = procdiggy.h 46@@ -22,7 +22,8 @@
47 AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \ 47 AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
48 -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \ 48 -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
49 -DGSYNCD_PREFIX=\"$(GLUSTERFS_LIBEXECDIR)\" -DUSE_LIBGLUSTERFS \ 49 -DGSYNCD_PREFIX=\"$(GLUSTERFS_LIBEXECDIR)\" -DUSE_LIBGLUSTERFS \
@@ -53,11 +53,11 @@ index 9937a0b..07456fb 100644
53 53
54 AM_CFLAGS = -Wall $(GF_CFLAGS) 54 AM_CFLAGS = -Wall $(GF_CFLAGS)
55 55
56diff --git a/geo-replication/src/gsyncd.c b/geo-replication/src/gsyncd.c 56Index: glusterfs-11.1/geo-replication/src/gsyncd.c
57index 77af662..8cd0551 100644 57===================================================================
58--- a/geo-replication/src/gsyncd.c 58--- glusterfs-11.1.orig/geo-replication/src/gsyncd.c
59+++ b/geo-replication/src/gsyncd.c 59+++ glusterfs-11.1/geo-replication/src/gsyncd.c
60@@ -118,9 +118,9 @@ invoke_gsyncd(int argc, char **argv) 60@@ -115,9 +115,9 @@
61 goto error; 61 goto error;
62 62
63 j = 0; 63 j = 0;
@@ -69,7 +69,7 @@ index 77af662..8cd0551 100644
69 nargv[j++] = python; 69 nargv[j++] = python;
70 nargv[j++] = GSYNCD_PREFIX "/python/syncdaemon/" GSYNCD_PY; 70 nargv[j++] = GSYNCD_PREFIX "/python/syncdaemon/" GSYNCD_PY;
71 for (i = 1; i < argc; i++) 71 for (i = 1; i < argc; i++)
72@@ -170,7 +170,7 @@ find_gsyncd(pid_t pid, pid_t ppid, char *name, void *data) 72@@ -167,7 +167,7 @@
73 ret = 0; 73 ret = 0;
74 switch (zeros) { 74 switch (zeros) {
75 case 2: 75 case 2:
@@ -78,6 +78,3 @@ index 77af662..8cd0551 100644
78 strcmp(basename(buf + strlen(buf) + 1), GSYNCD_PY)) == 0) { 78 strcmp(basename(buf + strlen(buf) + 1), GSYNCD_PY)) == 0) {
79 ret = 1; 79 ret = 1;
80 break; 80 break;
81--
822.17.1
83