summaryrefslogtreecommitdiffstats
path: root/recipes-extended/glusterfs/glusterfs.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/glusterfs/glusterfs.inc')
-rw-r--r--recipes-extended/glusterfs/glusterfs.inc31
1 files changed, 20 insertions, 11 deletions
diff --git a/recipes-extended/glusterfs/glusterfs.inc b/recipes-extended/glusterfs/glusterfs.inc
index e5bedca..c5f21c7 100644
--- a/recipes-extended/glusterfs/glusterfs.inc
+++ b/recipes-extended/glusterfs/glusterfs.inc
@@ -20,7 +20,7 @@ SRC_URI += "file://glusterd.init \
20 file://glusterd-change-port-range.patch \ 20 file://glusterd-change-port-range.patch \
21 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \ 21 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
22 file://0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch \ 22 file://0001-cli-duplicate-defns-of-cli_default_conn_timeout-and-.patch \
23 file://CVE-2023-26253.patch \ 23 file://0001-configure-pass-SSL_CERTS.-Don-t-discover-it.patch \
24 " 24 "
25 25
26LICENSE = "(LGPL-3.0-or-later | GPL-2.0-only) & GPL-3.0-or-later & LGPL-3.0-or-later & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & Apache-2.0" 26LICENSE = "(LGPL-3.0-or-later | GPL-2.0-only) & GPL-3.0-or-later & LGPL-3.0-or-later & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & Apache-2.0"
@@ -30,9 +30,10 @@ LIC_FILES_CHKSUM = "file://COPYING-GPLV2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
30 30
31inherit autotools pkgconfig setuptools3-base update-rc.d systemd 31inherit autotools pkgconfig setuptools3-base update-rc.d systemd
32inherit python3-dir 32inherit python3-dir
33inherit bash-completion
33 34
34DEPENDS += "bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \ 35DEPENDS += "openssl-native bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \
35 openssl python3 readline zlib liburcu util-linux glib-2.0 acl" 36 openssl python3 readline zlib liburcu util-linux glib-2.0 acl ca-certificates ca-certificates-native liburing"
36 37
37# rpc now comes from libtirpc instead of glibc 38# rpc now comes from libtirpc instead of glibc
38# 39#
@@ -42,25 +43,29 @@ LDFLAGS += " -ltirpc"
42EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \ 43EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \
43 ac_cv_file__etc_SuSE_release=no \ 44 ac_cv_file__etc_SuSE_release=no \
44 ac_cv_file__etc_redhat_release=no \ 45 ac_cv_file__etc_redhat_release=no \
45 ac_cv_file__etc_centos_release=no \ 46 ac_cv_file__etc_centos_release=no \
47 ac_cv_file__etc_os_release=no \
46 --with-mountutildir=${sbindir} \ 48 --with-mountutildir=${sbindir} \
47 --disable-fusermount \ 49 --disable-fusermount \
48 TARGET_PYTHON=${bindir}/python3 \ 50 TARGET_PYTHON=${bindir}/python3 \
49 PYTHON=${PYTHON} \ 51 PYTHON=${PYTHON} \
52 SSL_CERTS_DIR="${sysconfdir_native}/ssl/certs" \
50 BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ 53 BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
51 BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \ 54 BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \
52 BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \ 55 BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \
53 " 56 "
54 57
55PACKAGECONFIG ??= "georeplication libibverbs" 58PACKAGECONFIG ??= "georeplication"
56PACKAGECONFIG:remove:mipsarch = "libibverbs"
57PACKAGECONFIG:remove:arm = "libibverbs"
58 59
59PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,," 60PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
60PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync" 61PACKAGECONFIG[georeplication] = "--enable-georeplication,--disable-georeplication,,rsync"
61PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm," 62# PACKAGECONFIG[libibverbs] = "--enable-ibverbs,--disable-ibverbs,virtual/libibverbs librdmacm,"
62PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,," 63PACKAGECONFIG[ocf] = "--with-ocf,--without-ocf,,"
63PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind," 64PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
65PACKAGECONFIG[tcmalloc] = ",--without-tcmalloc,,"
66
67# TODO: packageconfig for:
68# --disable-linux-io_uring
64 69
65do_install:append() { 70do_install:append() {
66 install -d ${D}${sysconfdir}/init.d 71 install -d ${D}${sysconfdir}/init.d
@@ -141,7 +146,7 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
141 ${libdir}/glusterfs/${PV}/xlator/protocol/client* \ 146 ${libdir}/glusterfs/${PV}/xlator/protocol/client* \
142 ${libdir}/glusterfs/${PV}/xlator/system \ 147 ${libdir}/glusterfs/${PV}/xlator/system \
143 ${libdir}/glusterfs/${PV}/xlator/testing \ 148 ${libdir}/glusterfs/${PV}/xlator/testing \
144 ${libdir}/glusterfs/${PV}/xlator/playground \ 149 ${libdir}/glusterfs/${PV}/xlator/playground \
145 ${libdir}/glusterfs/${PV}/xlator/meta.so \ 150 ${libdir}/glusterfs/${PV}/xlator/meta.so \
146 ${libdir}/glusterfs/ganesha \ 151 ${libdir}/glusterfs/ganesha \
147 ${libdir}/glusterfs/glusterfs/glusterfind \ 152 ${libdir}/glusterfs/glusterfs/glusterfind \
@@ -154,7 +159,7 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
154 ${libdir}/libgfdb.so.* \ 159 ${libdir}/libgfdb.so.* \
155 ${libdir}/libgfxdr.so.* \ 160 ${libdir}/libgfxdr.so.* \
156 ${libdir}/python*/site-packages \ 161 ${libdir}/python*/site-packages \
157 ${libexecdir}/glusterfs/gfevents \ 162 ${libexecdir}/glusterfs/gfevents \
158 ${libexecdir}/glusterfs/events \ 163 ${libexecdir}/glusterfs/events \
159 ${libexecdir}/glusterfs/glusterfind \ 164 ${libexecdir}/glusterfs/glusterfind \
160 ${libexecdir}/glusterfs/gfind_missing_files \ 165 ${libexecdir}/glusterfs/gfind_missing_files \
@@ -164,7 +169,10 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
164 ${libexecdir}/glusterfs/peer_mountbroker \ 169 ${libexecdir}/glusterfs/peer_mountbroker \
165 ${libexecdir}/glusterfs/peer_gsec_create \ 170 ${libexecdir}/glusterfs/peer_gsec_create \
166 ${libexecdir}/glusterfs/gverify.sh \ 171 ${libexecdir}/glusterfs/gverify.sh \
172 ${libexecdir}/glusterfs/glfsheal \
173 ${libexecdir}/glusterfs/scripts/ \
167 ${libexecdir}/glusterfs/peer_add_secret_pub \ 174 ${libexecdir}/glusterfs/peer_add_secret_pub \
175 ${libexecdir}/ganesha/ \
168 ${localstatedir} \ 176 ${localstatedir} \
169 ${sysconfdir}/default/volatiles \ 177 ${sysconfdir}/default/volatiles \
170 ${sbindir}/glusterfs \ 178 ${sbindir}/glusterfs \
@@ -176,7 +184,7 @@ FILES:${PN} = "${libdir}/glusterfs/${PV}/auth \
176 ${sbindir}/glustereventsd \ 184 ${sbindir}/glustereventsd \
177 ${sbindir}/gf_attach \ 185 ${sbindir}/gf_attach \
178 ${sbindir}/*.py \ 186 ${sbindir}/*.py \
179 ${sbindir}/gluster-setgfid2path \ 187 ${sbindir}/gluster-setgfid2path \
180 ${bindir}/ \ 188 ${bindir}/ \
181 ${sysconfdir}/glusterfs \ 189 ${sysconfdir}/glusterfs \
182 ${sysconfdir}/ganesha \ 190 ${sysconfdir}/ganesha \
@@ -200,6 +208,7 @@ FILES:${PN}-server = "${libdir}/glusterfs/${PV}/xlator/mgmt \
200 ${libdir}/glusterfs/${PV}/xlator/nfs \ 208 ${libdir}/glusterfs/${PV}/xlator/nfs \
201 ${libdir}/glusterfs/${PV}/xlator/protocol/server* \ 209 ${libdir}/glusterfs/${PV}/xlator/protocol/server* \
202 ${libdir}/glusterfs/${PV}/xlator/storage \ 210 ${libdir}/glusterfs/${PV}/xlator/storage \
211 ${libdir}/glusterfs/${PV}/cloudsync-plugins/ \
203 ${sbindir}/gluster \ 212 ${sbindir}/gluster \
204 ${sbindir}/glusterd \ 213 ${sbindir}/glusterd \
205 ${sysconfdir}/glusterfs/glusterd.vol \ 214 ${sysconfdir}/glusterfs/glusterd.vol \