summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/qemu/qemu-android-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/qemu/qemu-android-native.bb')
-rw-r--r--meta-extras/packages/qemu/qemu-android-native.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-extras/packages/qemu/qemu-android-native.bb b/meta-extras/packages/qemu/qemu-android-native.bb
new file mode 100644
index 0000000000..169d790864
--- /dev/null
+++ b/meta-extras/packages/qemu/qemu-android-native.bb
@@ -0,0 +1,25 @@
1LICENSE = "GPL"
2DEPENDS = "zlib-native"
3PV = "0.0-rc20"
4PR = "r0"
5
6SRC_URI = "http://android.googlecode.com/files/android-emulator-m3-rc20.tar.bz2 \
7 file://fixes.patch;patch=1"
8
9S = "${WORKDIR}/android-emulator-20071111/qemu"
10
11EXTRA_OECONF = "--disable-gfx-check --target-list=arm-softmmu --enable-nand --enable-skins --enable-trace --enable-shaper --use-sdl-config=${prefix}/hackedsdl/bin/sdl-config --disable-user --disable-kqemu --enable-sdl --static-png --static-sdl"
12
13inherit autotools
14inherit native
15
16do_unfubar () {
17 chmod -R u+w ${WORKDIR}/
18 cd ${WORKDIR}/android-emulator-20071111/sdl
19 configure --prefix=${prefix}/hackedsdl
20 make
21 make install
22}
23
24addtask unfubar after do_unpack before do_patch
25