summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/qemu
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/qemu')
-rw-r--r--meta-extras/packages/qemu/qemu-android-native.bb25
-rw-r--r--meta-extras/packages/qemu/qemu-android-native/fixes.patch45
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-extras/packages/qemu/qemu-android-native.bb b/meta-extras/packages/qemu/qemu-android-native.bb
new file mode 100644
index 0000000000..169d790864
--- /dev/null
+++ b/meta-extras/packages/qemu/qemu-android-native.bb
@@ -0,0 +1,25 @@
1LICENSE = "GPL"
2DEPENDS = "zlib-native"
3PV = "0.0-rc20"
4PR = "r0"
5
6SRC_URI = "http://android.googlecode.com/files/android-emulator-m3-rc20.tar.bz2 \
7 file://fixes.patch;patch=1"
8
9S = "${WORKDIR}/android-emulator-20071111/qemu"
10
11EXTRA_OECONF = "--disable-gfx-check --target-list=arm-softmmu --enable-nand --enable-skins --enable-trace --enable-shaper --use-sdl-config=${prefix}/hackedsdl/bin/sdl-config --disable-user --disable-kqemu --enable-sdl --static-png --static-sdl"
12
13inherit autotools
14inherit native
15
16do_unfubar () {
17 chmod -R u+w ${WORKDIR}/
18 cd ${WORKDIR}/android-emulator-20071111/sdl
19 configure --prefix=${prefix}/hackedsdl
20 make
21 make install
22}
23
24addtask unfubar after do_unpack before do_patch
25
diff --git a/meta-extras/packages/qemu/qemu-android-native/fixes.patch b/meta-extras/packages/qemu/qemu-android-native/fixes.patch
new file mode 100644
index 0000000000..5d16b6061d
--- /dev/null
+++ b/meta-extras/packages/qemu/qemu-android-native/fixes.patch
@@ -0,0 +1,45 @@
1Index: qemu/linux-user/elfload.c
2===================================================================
3--- qemu.orig/linux-user/elfload.c 2007-11-12 06:58:42.000000000 +0000
4+++ qemu/linux-user/elfload.c 2007-11-12 20:41:37.000000000 +0000
5@@ -12,6 +12,10 @@
6 #include "qemu.h"
7 #include "disas.h"
8
9+#ifndef O_BINARY
10+#define O_BINARY 0
11+#endif
12+
13 /* this flag is uneffective under linux too, should be deleted */
14 #ifndef MAP_DENYWRITE
15 #define MAP_DENYWRITE 0
16Index: qemu/linux-user/linuxload.c
17===================================================================
18--- qemu.orig/linux-user/linuxload.c 2007-11-12 06:58:42.000000000 +0000
19+++ qemu/linux-user/linuxload.c 2007-11-12 20:35:16.000000000 +0000
20@@ -12,6 +12,10 @@
21
22 #define NGROUPS 32
23
24+#ifndef O_BINARY
25+#define O_BINARY 0
26+#endif
27+
28 /* ??? This should really be somewhere else. */
29 void memcpy_to_target(target_ulong dest, const void *src,
30 unsigned long len)
31Index: qemu/hw/qfb_fs.c
32===================================================================
33--- qemu.orig/hw/qfb_fs.c 2007-11-12 06:58:41.000000000 +0000
34+++ qemu/hw/qfb_fs.c 2007-11-12 20:59:34.000000000 +0000
35@@ -14,6 +14,10 @@
36 #include <sys/xattr.h>
37 #include <errno.h>
38
39+#ifndef O_BINARY
40+#define O_BINARY 0
41+#endif
42+
43 /* all mount paths */
44 static int next_path_index = 0;
45 static struct mount_path mount_paths[MAX_MOUNT_PATHS];