summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/qemu/qemu-android-native.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-11-13 20:00:21 +0000
committerRichard Purdie <richard@openedhand.com>2007-11-13 20:00:21 +0000
commitfda2bb511e8ddc93cfe84bba740f6af151d37b07 (patch)
treec4d35c8730acb9b406e1e1eed7e6b2d3c7a7197a /meta-extras/packages/qemu/qemu-android-native.bb
parent210caef864c14cf30c224f2ae09253bdf6932d7e (diff)
downloadpoky-fda2bb511e8ddc93cfe84bba740f6af151d37b07.tar.gz
Add android-goldfish metadata to meta-extras
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3143 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/qemu/qemu-android-native.bb')
-rw-r--r--meta-extras/packages/qemu/qemu-android-native.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-extras/packages/qemu/qemu-android-native.bb b/meta-extras/packages/qemu/qemu-android-native.bb
new file mode 100644
index 0000000000..169d790864
--- /dev/null
+++ b/meta-extras/packages/qemu/qemu-android-native.bb
@@ -0,0 +1,25 @@
1LICENSE = "GPL"
2DEPENDS = "zlib-native"
3PV = "0.0-rc20"
4PR = "r0"
5
6SRC_URI = "http://android.googlecode.com/files/android-emulator-m3-rc20.tar.bz2 \
7 file://fixes.patch;patch=1"
8
9S = "${WORKDIR}/android-emulator-20071111/qemu"
10
11EXTRA_OECONF = "--disable-gfx-check --target-list=arm-softmmu --enable-nand --enable-skins --enable-trace --enable-shaper --use-sdl-config=${prefix}/hackedsdl/bin/sdl-config --disable-user --disable-kqemu --enable-sdl --static-png --static-sdl"
12
13inherit autotools
14inherit native
15
16do_unfubar () {
17 chmod -R u+w ${WORKDIR}/
18 cd ${WORKDIR}/android-emulator-20071111/sdl
19 configure --prefix=${prefix}/hackedsdl
20 make
21 make install
22}
23
24addtask unfubar after do_unpack before do_patch
25