summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-11-02 20:33:29 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-11-05 10:20:54 -0500
commit86db36879f50ae0a0e1e3d4a2ee3385d2e6dea1d (patch)
treed9755dc45171c21fe0b6f220bb730b5083c14308
parente53055f5a1e2753fdb08508a97411ca137a19c61 (diff)
downloadmeta-virtualization-86db36879f50ae0a0e1e3d4a2ee3385d2e6dea1d.tar.gz
docker/docker-ce: uprev to 18.09
Infrastructure changes triggered updated to supporting parts of the docker stack, so to make sure that everything stays in sync we update to the 18.09 release. There were some minor build differences in this update, but in the end, things are better since we can use some more of the Make infrastructure versus calling 'go build' directly. Also, docker-ce and docker are now virtually the same, except for the moby based docker pulling in the cli and libnetwork repos independently. There should be virtually no difference between the results, but we still keep the two variants for flexibility. We also drop the unused/legacy 'hi.Dockerfile'. Tested with both kubernetes and docker unit tests. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/docker/docker-ce_git.bb31
-rw-r--r--recipes-containers/docker/docker_git.bb16
-rw-r--r--recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch31
-rw-r--r--recipes-containers/docker/files/hi.Dockerfile7
4 files changed, 34 insertions, 51 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
index 0dfda5f1..7a418508 100644
--- a/recipes-containers/docker/docker-ce_git.bb
+++ b/recipes-containers/docker/docker-ce_git.bb
@@ -18,15 +18,12 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "0520e243029d1361649afb0706a1c5d9a1c012b8" 21SRCREV_docker = "6e632f7fc395d15bce46f426086e91c01598cf59"
22SRCREV_libnetwork = "4cb38c2987c236dce03c868d99b57b1e28a4b81c" 22SRCREV_libnetwork = "6da50d1978302f04c3e2089e29112ea24812f05b"
23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457"
24SRC_URI = "\ 23SRC_URI = "\
25 git://github.com/docker/docker-ce.git;nobranch=1;name=docker \ 24 git://github.com/docker/docker-ce.git;branch=18.09;name=docker \
26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \ 25 git://github.com/docker/libnetwork.git;branch=bump_18.09;name=libnetwork;destsuffix=git/libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \
28 file://docker.init \ 26 file://docker.init \
29 file://hi.Dockerfile \
30 " 27 "
31 28
32# Apache-2.0 for docker 29# Apache-2.0 for docker
@@ -37,7 +34,7 @@ GO_IMPORT = "import"
37 34
38S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
39 36
40DOCKER_VERSION = "18.03.0-ce" 37DOCKER_VERSION = "18.09.0-ce"
41PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 38PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
42 39
43DEPENDS = " \ 40DEPENDS = " \
@@ -92,8 +89,8 @@ do_compile() {
92 ln -sf ../../../../components/engine/ .gopath/src/"${DOCKER_PKG}" 89 ln -sf ../../../../components/engine/ .gopath/src/"${DOCKER_PKG}"
93 90
94 mkdir -p .gopath/src/github.com/docker 91 mkdir -p .gopath/src/github.com/docker
95 ln -sf ${WORKDIR}/libnetwork .gopath/src/github.com/docker/libnetwork 92 ln -sf ${WORKDIR}/git/libnetwork .gopath/src/github.com/docker/libnetwork
96 ln -sf ${WORKDIR}/cli .gopath/src/github.com/docker/cli 93 ln -sf ${S}/src/import/components/cli .gopath/src/github.com/docker/cli
97 94
98 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 95 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
99 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 96 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
@@ -111,17 +108,17 @@ do_compile() {
111 108
112 cd ${S}/src/import/components/engine 109 cd ${S}/src/import/components/engine
113 110
114 # this is the unsupported built structure 111 # this is the unsupported build structure
115 # that doesn't rely on an existing docker 112 # that doesn't rely on an existing docker
116 # to build this: 113 # to build this:
117 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary 114 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary
118 115
119 # build the proxy 116 # build the proxy
120 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy 117 cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork
118 oe_runmake cross-local
121 119
122 # build the cli 120 # build the cli
123 ##go build -o ${S}/src/import/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker 121 cd ${S}/src/import/components/cli
124 cd ${S}/src/import/.gopath/src/github.com/docker/cli
125 export CFLAGS="" 122 export CFLAGS=""
126 export LDFLAGS="" 123 export LDFLAGS=""
127 export DOCKER_VERSION=${DOCKER_VERSION} 124 export DOCKER_VERSION=${DOCKER_VERSION}
@@ -130,7 +127,6 @@ do_compile() {
130 127
131SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 128SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
132SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}" 129SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}"
133
134SYSTEMD_AUTO_ENABLE_${PN} = "enable" 130SYSTEMD_AUTO_ENABLE_${PN} = "enable"
135 131
136INITSCRIPT_PACKAGES += "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','${PN}','',d)}" 132INITSCRIPT_PACKAGES += "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','${PN}','',d)}"
@@ -139,9 +135,9 @@ INITSCRIPT_PARAMS_${PN} = "defaults"
139 135
140do_install() { 136do_install() {
141 mkdir -p ${D}/${bindir} 137 mkdir -p ${D}/${bindir}
142 cp ${WORKDIR}/cli/build/docker ${D}/${bindir}/docker 138 cp ${S}/src/import/components/cli/build/docker ${D}/${bindir}/docker
143 cp ${S}/src/import/components/engine/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 139 cp ${S}/src/import/components/engine/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
144 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy 140 cp ${WORKDIR}/git/libnetwork/bin/docker-proxy* ${D}/${bindir}/docker-proxy
145 141
146 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 142 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
147 install -d ${D}${systemd_unitdir}/system 143 install -d ${D}${systemd_unitdir}/system
@@ -154,7 +150,6 @@ do_install() {
154 fi 150 fi
155 151
156 mkdir -p ${D}${datadir}/docker/ 152 mkdir -p ${D}${datadir}/docker/
157 cp ${WORKDIR}/hi.Dockerfile ${D}${datadir}/docker/
158 install -m 0755 ${S}/src/import/components/engine/contrib/check-config.sh ${D}${datadir}/docker/ 153 install -m 0755 ${S}/src/import/components/engine/contrib/check-config.sh ${D}${datadir}/docker/
159} 154}
160 155
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index b3673d43..f63cee16 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -18,27 +18,26 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "708b068d3095c6a6be939eb2da78c921d2e945e2" 21SRCREV_docker = "489b8eda6674523df8b82a210399b7d2954427d0"
22SRCREV_libnetwork = "4cb38c2987c236dce03c868d99b57b1e28a4b81c" 22SRCREV_libnetwork = "6da50d1978302f04c3e2089e29112ea24812f05b"
23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457" 23SRCREV_cli = "51668a30f26250ccfce31bcc13d9334eaafabe36"
24SRC_URI = "\ 24SRC_URI = "\
25 git://github.com/moby/moby.git;nobranch=1;name=docker \ 25 git://github.com/moby/moby.git;nobranch=1;name=docker \
26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork \ 26 git://github.com/docker/libnetwork.git;branch=bump_18.09;name=libnetwork;destsuffix=git/libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=git/cli \ 27 git://github.com/docker/cli;branch=18.09;name=cli;destsuffix=git/cli \
28 file://docker.init \ 28 file://docker.init \
29 file://hi.Dockerfile \
30 file://0001-libnetwork-use-GO-instead-of-go.patch \ 29 file://0001-libnetwork-use-GO-instead-of-go.patch \
31 " 30 "
32 31
33# Apache-2.0 for docker 32# Apache-2.0 for docker
34LICENSE = "Apache-2.0" 33LICENSE = "Apache-2.0"
35LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=9740d093a080530b5c5c6573df9af45a" 34LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28"
36 35
37GO_IMPORT = "import" 36GO_IMPORT = "import"
38 37
39S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
40 39
41DOCKER_VERSION = "18.03.0" 40DOCKER_VERSION = "18.09.0"
42PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 41PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
43 42
44DEPENDS = " \ 43DEPENDS = " \
@@ -157,7 +156,6 @@ do_install() {
157 fi 156 fi
158 157
159 mkdir -p ${D}${datadir}/docker/ 158 mkdir -p ${D}${datadir}/docker/
160 cp ${WORKDIR}/hi.Dockerfile ${D}${datadir}/docker/
161 install -m 0755 ${S}/src/import/contrib/check-config.sh ${D}${datadir}/docker/ 159 install -m 0755 ${S}/src/import/contrib/check-config.sh ${D}${datadir}/docker/
162} 160}
163 161
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
index 61ddd26d..c623b260 100644
--- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
+++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
@@ -11,24 +11,24 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
11 Makefile | 14 +++++++------- 11 Makefile | 14 +++++++-------
12 1 file changed, 7 insertions(+), 7 deletions(-) 12 1 file changed, 7 insertions(+), 7 deletions(-)
13 13
14diff --git a/libnetwork/Makefile b/libnetwork/Makefile 14Index: git/libnetwork/Makefile
15index 17060bc212c7..90cc7a72ef45 100644 15===================================================================
16--- a/libnetwork/Makefile 16--- git.orig/libnetwork/Makefile
17+++ b/libnetwork/Makefile 17+++ git/libnetwork/Makefile
18@@ -26,9 +26,9 @@ build: ${build_image}.created 18@@ -45,9 +45,9 @@
19 build-local: 19 build-local:
20 @echo "🐳 $@" 20 @echo "🐳 $@"
21 @mkdir -p "bin" 21 @mkdir -p "bin"
22- go build -tags experimental -o "bin/dnet" ./cmd/dnet 22- go build -tags experimental -o "bin/dnet" ./cmd/dnet
23- go build -o "bin/docker-proxy" ./cmd/proxy 23- go build -o "bin/docker-proxy" ./cmd/proxy
24- GOOS=linux go build -o "./cmd/diagnostic/diagnosticClient" ./cmd/diagnostic 24- CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic
25+ $(GO) build -tags experimental -o "bin/dnet" ./cmd/dnet 25+ $(GO) build -tags experimental -o "bin/dnet" ./cmd/dnet
26+ $(GO) build -o "bin/proxy" ./cmd/proxy 26+ $(GO) build -o "bin/proxy" ./cmd/proxy
27+ GOOS=linux $(GO) build -o "./cmd/diagnostic/diagnosticClient" ./cmd/diagnostic 27+ CGO_ENABLED=0 $(GO) build -o "bin/diagnosticClient" ./cmd/diagnostic
28 CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go
28 29
29 clean: 30 build-images:
30 @echo "🐳 $@" 31@@ -82,8 +82,8 @@
31@@ -51,8 +51,8 @@ cross: ${build_image}.created
32 32
33 cross-local: 33 cross-local:
34 @echo "🐳 $@" 34 @echo "🐳 $@"
@@ -37,9 +37,9 @@ index 17060bc212c7..90cc7a72ef45 100644
37+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 37+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
38+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 38+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
39 39
40 check: ${build_image}.created 40 # Rebuild protocol buffers.
41 @${docker} ./wrapmake.sh check-local 41 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt.
42@@ -68,7 +68,7 @@ run-tests: 42@@ -130,7 +130,7 @@
43 if ls $$dir/*.go &> /dev/null; then \ 43 if ls $$dir/*.go &> /dev/null; then \
44 pushd . &> /dev/null ; \ 44 pushd . &> /dev/null ; \
45 cd $$dir ; \ 45 cd $$dir ; \
@@ -48,7 +48,7 @@ index 17060bc212c7..90cc7a72ef45 100644
48 ret=$$? ;\ 48 ret=$$? ;\
49 if [ $$ret -ne 0 ]; then exit $$ret; fi ;\ 49 if [ $$ret -ne 0 ]; then exit $$ret; fi ;\
50 popd &> /dev/null; \ 50 popd &> /dev/null; \
51@@ -94,7 +94,7 @@ coveralls: 51@@ -145,7 +145,7 @@
52 # Depends on binaries because vet will silently fail if it can not load compiled imports 52 # Depends on binaries because vet will silently fail if it can not load compiled imports
53 vet: ## run go vet 53 vet: ## run go vet
54 @echo "🐳 $@" 54 @echo "🐳 $@"
@@ -57,6 +57,3 @@ index 17060bc212c7..90cc7a72ef45 100644
57 57
58 misspell: 58 misspell:
59 @echo "🐳 $@" 59 @echo "🐳 $@"
60--
612.4.0.53.g8440f74
62
diff --git a/recipes-containers/docker/files/hi.Dockerfile b/recipes-containers/docker/files/hi.Dockerfile
deleted file mode 100644
index 9af68058..00000000
--- a/recipes-containers/docker/files/hi.Dockerfile
+++ /dev/null
@@ -1,7 +0,0 @@
1FROM debian
2
3MAINTAINER amy.fong@windriver.com
4
5RUN apt-get update && apt-get install figlet
6
7ENTRYPOINT [ "/usr/bin/figlet", "hi" ]