summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/docker-ce_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/docker-ce_git.bb')
-rw-r--r--recipes-containers/docker/docker-ce_git.bb31
1 files changed, 13 insertions, 18 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
index 0dfda5f1..7a418508 100644
--- a/recipes-containers/docker/docker-ce_git.bb
+++ b/recipes-containers/docker/docker-ce_git.bb
@@ -18,15 +18,12 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "0520e243029d1361649afb0706a1c5d9a1c012b8" 21SRCREV_docker = "6e632f7fc395d15bce46f426086e91c01598cf59"
22SRCREV_libnetwork = "4cb38c2987c236dce03c868d99b57b1e28a4b81c" 22SRCREV_libnetwork = "6da50d1978302f04c3e2089e29112ea24812f05b"
23SRCREV_cli = "0f1bb353423e45e02315e985bd9ddebe6da18457"
24SRC_URI = "\ 23SRC_URI = "\
25 git://github.com/docker/docker-ce.git;nobranch=1;name=docker \ 24 git://github.com/docker/docker-ce.git;branch=18.09;name=docker \
26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \ 25 git://github.com/docker/libnetwork.git;branch=bump_18.09;name=libnetwork;destsuffix=git/libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \
28 file://docker.init \ 26 file://docker.init \
29 file://hi.Dockerfile \
30 " 27 "
31 28
32# Apache-2.0 for docker 29# Apache-2.0 for docker
@@ -37,7 +34,7 @@ GO_IMPORT = "import"
37 34
38S = "${WORKDIR}/git" 35S = "${WORKDIR}/git"
39 36
40DOCKER_VERSION = "18.03.0-ce" 37DOCKER_VERSION = "18.09.0-ce"
41PV = "${DOCKER_VERSION}+git${SRCREV_docker}" 38PV = "${DOCKER_VERSION}+git${SRCREV_docker}"
42 39
43DEPENDS = " \ 40DEPENDS = " \
@@ -92,8 +89,8 @@ do_compile() {
92 ln -sf ../../../../components/engine/ .gopath/src/"${DOCKER_PKG}" 89 ln -sf ../../../../components/engine/ .gopath/src/"${DOCKER_PKG}"
93 90
94 mkdir -p .gopath/src/github.com/docker 91 mkdir -p .gopath/src/github.com/docker
95 ln -sf ${WORKDIR}/libnetwork .gopath/src/github.com/docker/libnetwork 92 ln -sf ${WORKDIR}/git/libnetwork .gopath/src/github.com/docker/libnetwork
96 ln -sf ${WORKDIR}/cli .gopath/src/github.com/docker/cli 93 ln -sf ${S}/src/import/components/cli .gopath/src/github.com/docker/cli
97 94
98 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 95 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
99 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 96 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
@@ -111,17 +108,17 @@ do_compile() {
111 108
112 cd ${S}/src/import/components/engine 109 cd ${S}/src/import/components/engine
113 110
114 # this is the unsupported built structure 111 # this is the unsupported build structure
115 # that doesn't rely on an existing docker 112 # that doesn't rely on an existing docker
116 # to build this: 113 # to build this:
117 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary 114 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_docker}" ./hack/make.sh dynbinary
118 115
119 # build the proxy 116 # build the proxy
120 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy 117 cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork
118 oe_runmake cross-local
121 119
122 # build the cli 120 # build the cli
123 ##go build -o ${S}/src/import/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker 121 cd ${S}/src/import/components/cli
124 cd ${S}/src/import/.gopath/src/github.com/docker/cli
125 export CFLAGS="" 122 export CFLAGS=""
126 export LDFLAGS="" 123 export LDFLAGS=""
127 export DOCKER_VERSION=${DOCKER_VERSION} 124 export DOCKER_VERSION=${DOCKER_VERSION}
@@ -130,7 +127,6 @@ do_compile() {
130 127
131SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 128SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
132SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}" 129SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}"
133
134SYSTEMD_AUTO_ENABLE_${PN} = "enable" 130SYSTEMD_AUTO_ENABLE_${PN} = "enable"
135 131
136INITSCRIPT_PACKAGES += "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','${PN}','',d)}" 132INITSCRIPT_PACKAGES += "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','${PN}','',d)}"
@@ -139,9 +135,9 @@ INITSCRIPT_PARAMS_${PN} = "defaults"
139 135
140do_install() { 136do_install() {
141 mkdir -p ${D}/${bindir} 137 mkdir -p ${D}/${bindir}
142 cp ${WORKDIR}/cli/build/docker ${D}/${bindir}/docker 138 cp ${S}/src/import/components/cli/build/docker ${D}/${bindir}/docker
143 cp ${S}/src/import/components/engine/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 139 cp ${S}/src/import/components/engine/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
144 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy 140 cp ${WORKDIR}/git/libnetwork/bin/docker-proxy* ${D}/${bindir}/docker-proxy
145 141
146 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 142 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
147 install -d ${D}${systemd_unitdir}/system 143 install -d ${D}${systemd_unitdir}/system
@@ -154,7 +150,6 @@ do_install() {
154 fi 150 fi
155 151
156 mkdir -p ${D}${datadir}/docker/ 152 mkdir -p ${D}${datadir}/docker/
157 cp ${WORKDIR}/hi.Dockerfile ${D}${datadir}/docker/
158 install -m 0755 ${S}/src/import/components/engine/contrib/check-config.sh ${D}${datadir}/docker/ 153 install -m 0755 ${S}/src/import/components/engine/contrib/check-config.sh ${D}${datadir}/docker/
159} 154}
160 155