summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch')
-rw-r--r--recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch31
1 files changed, 14 insertions, 17 deletions
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
index 61ddd26d..c623b260 100644
--- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
+++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
@@ -11,24 +11,24 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
11 Makefile | 14 +++++++------- 11 Makefile | 14 +++++++-------
12 1 file changed, 7 insertions(+), 7 deletions(-) 12 1 file changed, 7 insertions(+), 7 deletions(-)
13 13
14diff --git a/libnetwork/Makefile b/libnetwork/Makefile 14Index: git/libnetwork/Makefile
15index 17060bc212c7..90cc7a72ef45 100644 15===================================================================
16--- a/libnetwork/Makefile 16--- git.orig/libnetwork/Makefile
17+++ b/libnetwork/Makefile 17+++ git/libnetwork/Makefile
18@@ -26,9 +26,9 @@ build: ${build_image}.created 18@@ -45,9 +45,9 @@
19 build-local: 19 build-local:
20 @echo "🐳 $@" 20 @echo "🐳 $@"
21 @mkdir -p "bin" 21 @mkdir -p "bin"
22- go build -tags experimental -o "bin/dnet" ./cmd/dnet 22- go build -tags experimental -o "bin/dnet" ./cmd/dnet
23- go build -o "bin/docker-proxy" ./cmd/proxy 23- go build -o "bin/docker-proxy" ./cmd/proxy
24- GOOS=linux go build -o "./cmd/diagnostic/diagnosticClient" ./cmd/diagnostic 24- CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic
25+ $(GO) build -tags experimental -o "bin/dnet" ./cmd/dnet 25+ $(GO) build -tags experimental -o "bin/dnet" ./cmd/dnet
26+ $(GO) build -o "bin/proxy" ./cmd/proxy 26+ $(GO) build -o "bin/proxy" ./cmd/proxy
27+ GOOS=linux $(GO) build -o "./cmd/diagnostic/diagnosticClient" ./cmd/diagnostic 27+ CGO_ENABLED=0 $(GO) build -o "bin/diagnosticClient" ./cmd/diagnostic
28 CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go
28 29
29 clean: 30 build-images:
30 @echo "🐳 $@" 31@@ -82,8 +82,8 @@
31@@ -51,8 +51,8 @@ cross: ${build_image}.created
32 32
33 cross-local: 33 cross-local:
34 @echo "🐳 $@" 34 @echo "🐳 $@"
@@ -37,9 +37,9 @@ index 17060bc212c7..90cc7a72ef45 100644
37+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 37+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
38+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 38+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
39 39
40 check: ${build_image}.created 40 # Rebuild protocol buffers.
41 @${docker} ./wrapmake.sh check-local 41 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt.
42@@ -68,7 +68,7 @@ run-tests: 42@@ -130,7 +130,7 @@
43 if ls $$dir/*.go &> /dev/null; then \ 43 if ls $$dir/*.go &> /dev/null; then \
44 pushd . &> /dev/null ; \ 44 pushd . &> /dev/null ; \
45 cd $$dir ; \ 45 cd $$dir ; \
@@ -48,7 +48,7 @@ index 17060bc212c7..90cc7a72ef45 100644
48 ret=$$? ;\ 48 ret=$$? ;\
49 if [ $$ret -ne 0 ]; then exit $$ret; fi ;\ 49 if [ $$ret -ne 0 ]; then exit $$ret; fi ;\
50 popd &> /dev/null; \ 50 popd &> /dev/null; \
51@@ -94,7 +94,7 @@ coveralls: 51@@ -145,7 +145,7 @@
52 # Depends on binaries because vet will silently fail if it can not load compiled imports 52 # Depends on binaries because vet will silently fail if it can not load compiled imports
53 vet: ## run go vet 53 vet: ## run go vet
54 @echo "🐳 $@" 54 @echo "🐳 $@"
@@ -57,6 +57,3 @@ index 17060bc212c7..90cc7a72ef45 100644
57 57
58 misspell: 58 misspell:
59 @echo "🐳 $@" 59 @echo "🐳 $@"
60--
612.4.0.53.g8440f74
62