summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-kernel
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch33
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb5
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc33
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb22
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc13
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb26
-rw-r--r--meta-oe/recipes-kernel/linux/linux.inc131
7 files changed, 263 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch
new file mode 100644
index 000000000..3a51266d0
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all/0001-ath5k-fix-compilation-without-CONFIG_PCI.patch
@@ -0,0 +1,33 @@
1From fb323acc0b01bcf1ecafb9330c4fbb41cf942139 Mon Sep 17 00:00:00 2001
2From: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
3Date: Wed, 18 Jul 2012 01:01:52 +0200
4Subject: [PATCH] ath5k: fix compilation without CONFIG_PCI
5
6Without that fix we have:
7 [...]/drivers/net/wireless/ath/ath5k/led.c: In function 'ath5k_init_leds':
8 [...]/drivers/net/wireless/ath/ath5k/led.c:179:2: error: implicit declaration of function 'pci_match_id' [-Werror=implicit-function-declaration]
9When CONFIG_PCI is not set.
10
11Upstream-Status: Pending: Not submitted yet.
12
13Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
14---
15 drivers/net/wireless/ath/ath5k/led.c | 2 +-
16 1 files changed, 1 insertions(+), 1 deletions(-)
17
18diff --git a/drivers/net/wireless/ath/ath5k/led.c b/drivers/net/wireless/ath/ath5k/led.c
19index c044476..a4de133 100644
20--- a/drivers/net/wireless/ath/ath5k/led.c
21+++ b/drivers/net/wireless/ath/ath5k/led.c
22@@ -173,7 +173,7 @@ int __devinit ath5k_init_leds(struct ath5k_hw *ah)
23 if (!ah->pdev)
24 return 0;
25
26-#ifdef CONFIG_ATHEROS_AR231X
27+#if defined(CONFIG_ATHEROS_AR231X) || !defined(CONFIG_PCI)
28 match = NULL;
29 #else
30 match = pci_match_id(&ath5k_led_devices[0], pdev);
31--
321.7.4.1
33
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb
new file mode 100644
index 000000000..0c407defc
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless-all_3.6.8.bb
@@ -0,0 +1,5 @@
1include compat-wireless.inc
2PR = "${INC_PR}.0"
3
4SRC_URI[md5sum] = "f02849a795137438238b4d166609eacc"
5SRC_URI[sha256sum] = "9bbbc72bf0adf73012f377caa38147e90f6d77ef0369b52f9a687bc66bbfbcfa"
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
new file mode 100644
index 000000000..398142601
--- /dev/null
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
@@ -0,0 +1,33 @@
1DESCRIPTION = "Latest wireless drivers"
2HOMEPAGE = "http://wireless.kernel.org/en/users/Download"
3SECTION = "kernel/modules"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d7810fab7487fb0aad327b76f1be7cd7"
6RDEPENDS_${PN} = "wireless-tools"
7INC_PR = "r1"
8
9# depends on config options which are not enabled in qemu* MACHINEs by default
10# config.mk:25: *** "ERROR: your kernel has CONFIG_CFG80211=y, you should have it CONFIG_CFG80211=m if you want to use this thing.". Stop.
11EXCLUDE_FROM_WORLD = "1"
12
13COMPAT_WIRELESS_VERSION = "${PV}-1"
14SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
15
16SRC_URI = " \
17 http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v${SHRT_VER}/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \
18 file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \
19"
20
21S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}"
22
23inherit module
24
25EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}"
26
27do_configure_append() {
28 sed -i "s#@./scripts/update-initramfs## " Makefile
29}
30
31do_install() {
32 oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
33}
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
new file mode 100644
index 000000000..62f2a99a2
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
@@ -0,0 +1,22 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6
7inherit module
8
9# Available package configs: ffi (only supported on x86_64)
10PACKAGECONFIG ?= ""
11
12# Only build the module
13MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
14
15# Kernel module packages MUST begin with 'kernel-module-', otherwise
16# multilib image generation can fail.
17#
18# The following line is only necessary if the recipe name does not begin
19# with kernel-module-.
20#
21PKG_${PN} = "kernel-module-${PN}"
22
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
new file mode 100644
index 000000000..93a4e2ca3
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -0,0 +1,13 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3HOMEPAGE = "http://www.ktap.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE-GPL;md5=eb723b61539feef013de476e68b5c50a"
6
7SRCREV = "c8401e07c89cdec9a5f673da4ddb12b7982b522b"
8SRC_URI = "git://github.com/ktap/ktap.git"
9
10S = "${WORKDIR}/git"
11
12# Package config is abused as a general compile time configuration tool.
13PACKAGECONFIG[ffi] = ""
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
new file mode 100644
index 000000000..cbdabf82d
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -0,0 +1,26 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module"
7
8#Available package configs:
9# libelf - needed to resolve symbols in DSO and for sdt
10# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
11PACKAGECONFIG ?= "libelf"
12
13PACKAGECONFIG[libelf] = ",,elfutils"
14
15# Only build the userspace app
16EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
17 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
18 ktap"
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 0755 ${S}/ktap ${D}${bindir}/
23}
24
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26RDEPENDS_${PN} = "kernel-module-ktapvm"
diff --git a/meta-oe/recipes-kernel/linux/linux.inc b/meta-oe/recipes-kernel/linux/linux.inc
new file mode 100644
index 000000000..7b301ae21
--- /dev/null
+++ b/meta-oe/recipes-kernel/linux/linux.inc
@@ -0,0 +1,131 @@
1DESCRIPTION = "Linux Kernel"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5
6INC_PR = "r0"
7
8inherit kernel siteinfo
9
10# Enable OABI compat for people stuck with obsolete userspace
11ARM_KEEP_OABI ?= "0"
12
13# Set the verbosity of kernel messages during runtime
14# You can define CMDLINE_DEBUG in your local.conf or distro.conf to override this behaviour
15CMDLINE_DEBUG ?= "loglevel=3"
16
17# Kernel bootlogo is distro-specific (default is OE logo).
18# Logo resolution (qvga, vga, ...) is machine-specific.
19LOGO_SIZE ?= '${@base_conditional("MACHINE_GUI_CLASS", "bigscreen", "vga", "qvga", d)}'
20# To use this, add file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2 or similar
21# to your kernel recipe, and then structure your logos for each resolution
22# accordingly.
23
24LOCALVERSION ?= ""
25
26#kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
27kernel_conf_variable() {
28 CONF_SED_SCRIPT="$CONF_SED_SCRIPT /CONFIG_$1[ =]/d;"
29 if test "$2" = "n"
30 then
31 echo "# CONFIG_$1 is not set" >> ${S}/.config
32 else
33 echo "CONFIG_$1=$2" >> ${S}/.config
34 fi
35}
36
37do_configure_prepend() {
38 echo "" > ${S}/.config
39 CONF_SED_SCRIPT=""
40
41 #
42 # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used
43 #
44 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
45 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm
46 kernel_conf_variable LOGO y
47 kernel_conf_variable LOGO_LINUX_CLUT224 y
48 fi
49
50 #
51 # oabi / eabi support
52 #
53 kernel_conf_variable AEABI y
54 if [ "${ARM_KEEP_OABI}" = "1" ] ; then
55 kernel_conf_variable OABI_COMPAT y
56 else
57 kernel_conf_variable OABI_COMPAT n
58 fi
59
60 # When enabling thumb for userspace we also need thumb support in the kernel
61 if [ "${ARM_INSTRUCTION_SET}" = "thumb" ] ; then
62 kernel_conf_variable ARM_THUMB y
63 fi
64
65 kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
66
67 kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
68 kernel_conf_variable LOCALVERSION_AUTO n
69
70 kernel_conf_variable SYSFS_DEPRECATED n
71 kernel_conf_variable SYSFS_DEPRECATED_V2 n
72 kernel_conf_variable HOTPLUG y
73 kernel_conf_variable UEVENT_HELPER_PATH \"\"
74 kernel_conf_variable UNIX y
75 kernel_conf_variable SYSFS y
76 kernel_conf_variable PROC_FS y
77 kernel_conf_variable TMPFS y
78 kernel_conf_variable INOTIFY_USER y
79 kernel_conf_variable SIGNALFD y
80 kernel_conf_variable TMPFS_POSIX_ACL y
81 kernel_conf_variable BLK_DEV_BSG y
82 kernel_conf_variable DEVTMPFS y
83 kernel_conf_variable DEVTMPFS_MOUNT y
84
85 # Newer inits like systemd need cgroup support
86 if [ "${KERNEL_ENABLE_CGROUPS}" = "1" ] ; then
87 kernel_conf_variable CGROUP_SCHED y
88 kernel_conf_variable CGROUPS y
89 kernel_conf_variable CGROUP_NS y
90 kernel_conf_variable CGROUP_FREEZER y
91 kernel_conf_variable CGROUP_DEVICE y
92 kernel_conf_variable CPUSETS y
93 kernel_conf_variable PROC_PID_CPUSET y
94 kernel_conf_variable CGROUP_CPUACCT y
95 kernel_conf_variable RESOURCE_COUNTERS y
96 fi
97
98 #
99 # root-over-nfs-over-usb-eth support. Limited, but should cover some cases.
100 # Enable this by setting a proper CMDLINE_NFSROOT_USB.
101 #
102 if [ ! -z "${CMDLINE_NFSROOT_USB}" ]; then
103 bbnote "Configuring the kernel for root-over-nfs-over-usb-eth with CMDLINE ${CMDLINE_NFSROOT_USB}"
104 kernel_conf_variable INET y
105 kernel_conf_variable IP_PNP y
106 kernel_conf_variable USB_GADGET y
107 kernel_conf_variable USB_GADGET_SELECTED y
108 kernel_conf_variable USB_ETH y
109 kernel_conf_variable NFS_FS y
110 kernel_conf_variable ROOT_NFS y
111 kernel_conf_variable CMDLINE \"${CMDLINE_NFSROOT_USB} ${CMDLINE_DEBUG}\"
112 fi
113
114 sed -e "${CONF_SED_SCRIPT}" \
115 < '${WORKDIR}/defconfig' >>'${S}/.config'
116
117 yes '' | oe_runmake oldconfig
118}
119
120do_configure_append() {
121 if test -e scripts/Makefile.fwinst ; then
122 sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
123 fi
124}
125
126do_install_append() {
127 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
128}
129
130PACKAGES =+ "kernel-headers"
131FILES_kernel-headers = "${exec_prefix}/src/linux*"