summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
new file mode 100644
index 000000000..62f2a99a2
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
@@ -0,0 +1,22 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6
7inherit module
8
9# Available package configs: ffi (only supported on x86_64)
10PACKAGECONFIG ?= ""
11
12# Only build the module
13MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
14
15# Kernel module packages MUST begin with 'kernel-module-', otherwise
16# multilib image generation can fail.
17#
18# The following line is only necessary if the recipe name does not begin
19# with kernel-module-.
20#
21PKG_${PN} = "kernel-module-${PN}"
22