summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap_0.4.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
new file mode 100644
index 000000000..cbdabf82d
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -0,0 +1,26 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module"
7
8#Available package configs:
9# libelf - needed to resolve symbols in DSO and for sdt
10# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
11PACKAGECONFIG ?= "libelf"
12
13PACKAGECONFIG[libelf] = ",,elfutils"
14
15# Only build the userspace app
16EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
17 ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
18 ktap"
19
20do_install() {
21 install -d ${D}${bindir}
22 install -m 0755 ${S}/ktap ${D}${bindir}/
23}
24
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26RDEPENDS_${PN} = "kernel-module-ktapvm"