summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-devtools/python
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-futures_2.1.5.bb14
-rw-r--r--meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb24
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb54
-rw-r--r--meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb27
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch32
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado_git.bb16
6 files changed, 167 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-futures_2.1.5.bb b/meta-oe/recipes-devtools/python/python-futures_2.1.5.bb
new file mode 100644
index 000000000..817a9179a
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-futures_2.1.5.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "The concurrent.futures module provides a high-level interface for asynchronously executing callables."
2SECTION = "devel/python"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e96d16356742ac95c07be571717e51a3"
5HOMEPAGE = "http://code.google.com/p/pythonfutures"
6DEPENDS = "python"
7
8SRC_URI = "https://pypi.python.org/packages/source/f/futures/futures-${PV}.tar.gz"
9SRC_URI[md5sum] = "2fc924890ccd30a5fe676fa9bbcf0ab8"
10SRC_URI[sha256sum] = "8f5a627d3aee94cc1859a942965fdebb714be8cdd2366d819cb8fb9b7cc628a6"
11
12S = "${WORKDIR}/futures-${PV}"
13
14inherit setuptools
diff --git a/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb b/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
new file mode 100644
index 000000000..01f43da27
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2SECTION = "devel/python"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRCNAME = "pyOpenSSL"
8
9DEPENDS = "openssl"
10PR = "r1"
11
12SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
13SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929"
14SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19
20PACKAGES =+ "${PN}-tests"
21FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
22
23RDEPENDS_${PN} = "python-threading"
24RDEPENDS_${PN}-tests = "${PN}"
diff --git a/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb b/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb
new file mode 100644
index 000000000..607007ff6
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Python Qt4 Bindings"
2AUTHOR = "Phil Thomson @ riverbank.co.uk"
3HOMEPAGE = "http://riverbankcomputing.co.uk"
4SECTION = "devel/python"
5LICENSE = "GPLv2 & GPLv3 & GPL_EXCEPTION"
6LIC_FILES_CHKSUM = "\
7 file://GPL_EXCEPTION.TXT;md5=b73b0be471db679533dc94781c14af58 \
8 file://GPL_EXCEPTION_ADDENDUM.TXT;md5=c1e04ec2aa0911061005a801abf81e40 \
9 file://OPENSOURCE-NOTICE.TXT;md5=6ad9123620cc04a22c394753ad4767d7 \
10 file://LICENSE.GPL2;md5=577ff65f6653562af318bfc3944b1f20 \
11 file://LICENSE.GPL3;md5=feee51612c3c1191a1d5f41156fa2c75 \
12"
13DEPENDS = "sip sip-native qt4-x11-free python"
14
15SRC_URI = "\
16 ${SOURCEFORGE_MIRROR}/pyqt/PyQt-x11-gpl-${PV}.tar.gz \
17"
18SRC_URI[md5sum] = "997c3e443165a89a559e0d96b061bf70"
19SRC_URI[sha256sum] = "853780dcdbe2e6ba785d703d059b096e1fc49369d3e8d41a060be874b8745686"
20
21S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
22
23PARALLEL_MAKE = ""
24
25inherit qmake2 pythonnative python-dir
26
27DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
28
29DISABLED_FEATURES_append_arm = " PyQt_qreal_double"
30
31do_configure() {
32 echo "py_platform = linux" > pyqt.cfg
33 echo "py_inc_dir = %(sysroot)/$includedir/python%(py_major).%(py_minor)" >> pyqt.cfg
34 echo "py_pylib_dir = %(sysroot)/${libdir}/python%(py_major).%(py_minor)" >> pyqt.cfg
35 echo "py_pylib_lib = python%(py_major).%(py_minor)mu" >> pyqt.cfg
36 echo "pyqt_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> pyqt.cfg
37 echo "pyqt_bin_dir = ${D}/${bindir}" >> pyqt.cfg
38 echo "pyqt_sip_dir = ${D}/${datadir}/sip/PyQt4" >> pyqt.cfg
39 echo "pyuic_interpreter = ${D}/${bindir}/python%(py_major).%(py_minor)" >> pyqt.cfg
40 echo "pyqt_disabled_features = ${DISABLED_FEATURES}" >> pyqt.cfg
41 echo "qt_shared = True" >> pyqt.cfg
42 echo "[Qt 4.8]" >> pyqt.cfg
43 echo "pyqt_modules = QtCore QtGui QtDeclarative QtNetwork QtSvg QtWebKit" >> pyqt.cfg
44 echo yes | python configure-ng.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/qmake2 --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
45}
46do_install() {
47 oe_runmake install
48}
49
50RDEPENDS_${PN} = "python-core python-sip"
51
52FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/sip/PyQt4/"
53FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*/.debug/"
54
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb b/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
new file mode 100644
index 000000000..7e42a7c14
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
3SECTION = "devel/python"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8a9f8dcfcd28c34daa443e5b1d29813b"
7PR = "r1"
8
9SRCNAME = "simplejson"
10
11SRC_URI = "http://cheeseshop.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz"
12SRC_URI[md5sum] = "070c6467462bd63306f1756b01df6d70"
13SRC_URI[sha256sum] = "e85c5ae24dd9827113893c1dd2c799528195057388096f0fc45ad4b32b378c26"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19RDEPENDS_${PN} = "\
20 python-core \
21 python-re \
22 python-io \
23 python-netserver \
24 python-numbers \
25"
26
27
diff --git a/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch b/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
new file mode 100644
index 000000000..0b0d471a4
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-tornado/0001-disable-AI_ADDRCONFIG-flag.patch
@@ -0,0 +1,32 @@
1From d7fb0a6ef3f3cbdfc1f21f5a67d54fa9d2c1e183 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 2 Nov 2011 11:07:24 +0100
4Subject: [PATCH] disable AI_ADDRCONFIG flag
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-Status: unknown
9---
10 tornado/netutil.py | 6 ------
11 1 files changed, 0 insertions(+), 6 deletions(-)
12
13diff --git a/tornado/netutil.py b/tornado/netutil.py
14index cfff0ba..c181f24 100644
15--- a/tornado/netutil.py
16+++ b/tornado/netutil.py
17@@ -238,12 +238,6 @@ def bind_sockets(port, address=None, family=socket.AF_UNSPEC, backlog=128):
18 if address == "":
19 address = None
20 flags = socket.AI_PASSIVE
21- if hasattr(socket, "AI_ADDRCONFIG"):
22- # AI_ADDRCONFIG ensures that we only try to bind on ipv6
23- # if the system is configured for it, but the flag doesn't
24- # exist on some platforms (specifically WinXP, although
25- # newer versions of windows have it)
26- flags |= socket.AI_ADDRCONFIG
27 for res in set(socket.getaddrinfo(address, port, family, socket.SOCK_STREAM,
28 0, flags):
29 af, socktype, proto, canonname, sockaddr = res
30--
311.7.2.5
32
diff --git a/meta-oe/recipes-devtools/python/python-tornado_git.bb b/meta-oe/recipes-devtools/python/python-tornado_git.bb
new file mode 100644
index 000000000..28026b352
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-tornado_git.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://README;md5=e7fb9954003d7cd93322ccf282210d1c"
4
5PV = "2.2.1+git${SRCPV}"
6
7SRCREV = "c501917eba46dec30b1f2ef12497dffc4beec505"
8SRC_URI = "git://github.com/facebook/tornado.git;branch=branch2.2 \
9 file://0001-disable-AI_ADDRCONFIG-flag.patch \
10"
11
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16