summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb b/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
new file mode 100644
index 000000000..01f43da27
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2SECTION = "devel/python"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRCNAME = "pyOpenSSL"
8
9DEPENDS = "openssl"
10PR = "r1"
11
12SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
13SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929"
14SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit distutils
19
20PACKAGES =+ "${PN}-tests"
21FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
22
23RDEPENDS_${PN} = "python-threading"
24RDEPENDS_${PN}-tests = "${PN}"