summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-initramfs/recipes-bsp
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r--meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb22
-rw-r--r--meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb7
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm43
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb62
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb66
5 files changed, 200 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
new file mode 100644
index 000000000..35eb245ce
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Initramfs image for kexecboot kernel"
2DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
7
8# avoid circular dependencies
9EXTRA_IMAGEDEPENDS = ""
10
11# We really need just kexecboot, kexec and ubiattach
12IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
13
14# Do not pollute the initrd image with rootfs features
15IMAGE_FEATURES = ""
16
17IMAGE_LINGUAS = ""
18
19FEED_DEPLOYDIR_BASE_URI = ""
20LDCONFIGDEPEND = ""
21
22inherit image
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
new file mode 100644
index 000000000..df9751189
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-klibc-image.bb
@@ -0,0 +1,7 @@
1require initramfs-kexecboot-image.bb
2
3SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)"
4
5# We really need just kexecboot, kexec and ubiattach
6# statically compiled against klibc
7IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc"
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm
new file mode 100644
index 000000000..6e6fd776d
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg/icon.xpm
@@ -0,0 +1,43 @@
1/* XPM */
2static char * icon_xpm[] = {
3"32 32 8 1",
4" c None",
5". c #D6DBDE",
6"+ c #9BA6AE",
7"@ c #60727D",
8"# c #B8BFC5",
9"$ c #A9E8F6",
10"% c #12BCE4",
11"& c #57D2EC",
12" ",
13" ",
14" ",
15" .++@@@@++. ",
16" +@@@@@@@@@@@@+ ",
17" #@@@@@@@@@@@@@@@@# ",
18" +@@@@@@@@@@@@@@@@@@+ ",
19" .@@@@@@@@++##+@@@@@@@@@. ",
20" @@@@@@@. .@@@@@@@ ",
21" +@@@@@+ $$$$ #@@@@@+ ",
22" #@@@@@. $%%%%%%%%$ .@@@@@# ",
23" @@@@@. &%%%%%%%%%%& .@@@@@ ",
24" #@@@@+ %%%%%%%%%%%%%% +@@@@# ",
25" @@@@@ &%%%%%%%%%%%%%%& @@@@@ ",
26".@@@@. $%%%%%& $%%%%%& .@@@@.",
27"+@@@@ %%%%% $%%%%%& @@@@+",
28"+@@@+ %%%%$ $%%%%%& $$ +@@@+",
29"@@@@+ $%%%% $%%%%%& $%$ +@@@@",
30"@@@@# &%%%& &%%%%& $%%& #@@@@",
31"@@@@. &%%%& %%%%& $%%%& .@@@@",
32"@@@@# $%%%& &%%& &%%%$ #@@@@",
33"+@@@+ $%%%% %%%%$ +@@@+",
34"+@@@@ %%%%& &%%%% @@@@+",
35"#@@@@ &%%%%& &%%%%& @@@@#",
36" @@@@+ %%%%%%&$$&%%%%%% +@@@@ ",
37" +@@@@. $%%%%%%%%%%%%%%$ .@@@@+ ",
38" .@@@@@ $%%%%%%%%%%%%$ @@@@@. ",
39" #++++. &%%%%%%%%& .++++# ",
40" $&&%%&&$ ",
41" ",
42" ",
43" "};
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
new file mode 100644
index 000000000..ec476f829
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
@@ -0,0 +1,62 @@
1SUMMARY = "Configuration files for kexecboot"
2DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
6PR = "r14"
7
8SRC_URI = "file://icon.xpm"
9
10do_configure_prepend () {
11 install -m 0644 ${WORKDIR}/icon.xpm ${S}
12}
13do_install_prepend () {
14echo '# /boot/boot.cfg - KEXECBOOT configuration file.
15#
16# First kernel stanza.
17# Show this label in kexecboot menu.
18#
19LABEL=${KEXECBOOT_LABEL}
20#
21# Specify full kernel path on target.
22KERNEL=/boot/${KERNEL_IMAGETYPE}
23#
24# Append this tags to the kernel cmdline.
25APPEND=${CMDLINE} ${CMDLINE_DEBUG}
26#
27# Specify optional initrd/initramfs.
28# INITRD=/boot/initramfs.cpio.gz
29#
30# Specify full path for a custom icon for the menu-item.
31# If not set, use device-icons as default (NAND, SD, CF, ...).
32# ICON=/boot/icon.xpm
33#
34# Priority of item in kexecboot menu.
35# Items with highest priority will be shown at top of menu.
36# Default: 0 (lowest, ordered by device ordering)
37# PRIORITY=10
38#
39#
40# Second kernel stanza.
41# LABEL=${KEXECBOOT_LABEL}-test
42# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
43# APPEND=${CMDLINE}
44#' > ${S}/boot.cfg
45}
46do_install () {
47 install -d ${D}/boot
48 install -m 0644 boot.cfg ${D}/boot/boot.cfg
49 install -m 0644 icon.xpm ${D}/boot/icon.xpm
50}
51
52PACKAGE_ARCH = "${MACHINE_ARCH}"
53
54FILES_${PN} += "/boot/*"
55
56CMDLINE ?= ""
57CMDLINE_DEBUG ?= "quiet"
58
59INHIBIT_DEFAULT_DEPS = "1"
60
61# Note: for qvga the label is currently limited to about 24 chars
62KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
new file mode 100644
index 000000000..1fb5f0da5
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
@@ -0,0 +1,66 @@
1###########################
2# Configure options:
3#
4# --enable-static-linking compile kexecboot as static executable [default=no]
5# --enable-fbui support framebuffer menu [default=yes]
6# --enable-fbui-width limit FB UI width to specified value [default=no]
7# --enable-fbui-height limit FB UI height to specified value [default=no]
8# --enable-textui support console text user interface [default=no]
9# --enable-cfgfiles support config files [default=yes]
10# --enable-icons support custom icons (depends on fbui) [default=yes]
11# --enable-zaurus compile Sharp Zaurus specific code [default=no]
12# --enable-zimage compile with zImage support [default=yes]
13# --enable-uimage compile with uImage support [default=no]
14# --enable-machine-kernel look for machine-specific zImage kernel [default=no]
15# --enable-devices-recreating
16# enable devices re-creating [default=yes]
17# --enable-debug enable debug output [default=no]
18# --enable-host-debug allow for non-destructive executing of kexecboot on
19# host system [default=no]
20# --enable-numkeys enable menu item selection by keys [0-9] [default=yes]
21# --enable-bg-buffer enable buffer for pre-drawed FB GUI background
22#
23# --enable-timeout allow to boot 1st kernel after timeout in seconds
24# [default=no]
25# --enable-delay specify delay before device scanning, allowing
26# initialization of old CF/SD cards [default=1]
27# --enable-bpp enable support of specified bpp modes
28# (all,32,24,18,16,4,2,1) [default=all]
29# --enable-evdev-rate change evdev (keyboard/mouse) repeat rate
30# in milliseconds e.g. "1000,250" [default=no]
31# --with-kexec-binary look for kexec binary at path
32# [default="/usr/sbin/kexec"]
33##########################
34SUMMARY = "kexecboot linux-as-bootloader"
35DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
36HOMEPAGE = "http://kexecboot.org"
37LICENSE = "GPLv2"
38LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
39
40S = "${WORKDIR}/kexecboot-${PV}"
41SRC_URI = "https://github.com/kexecboot/kexecboot/archive/v${PV}.tar.gz"
42SRC_URI[md5sum] = "46b7c1a6f20531be56445ebb8669a2b8"
43SRC_URI[sha256sum] = "6b360b8aa59bc5d68a96705349a0dd416f8ed704e931fa0ac7849298258f0f15"
44
45inherit autotools-brokensep
46
47EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250"
48
49do_install () {
50 install -d ${D}${bindir}
51 install -m 0755 kexecboot ${D}${bindir}
52 install -d ${D}/proc
53 install -d ${D}/mnt
54 install -d ${D}/dev
55 install -d ${D}/sys
56}
57
58PACKAGE_ARCH = "${MACHINE_ARCH}"
59
60FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
61
62pkg_postinst_${PN} () {
63 ln -sf ${bindir}/kexecboot $D/init
64}
65
66BBCLASSEXTEND = "klibc"