summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
new file mode 100644
index 000000000..ec476f829
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb
@@ -0,0 +1,62 @@
1SUMMARY = "Configuration files for kexecboot"
2DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
6PR = "r14"
7
8SRC_URI = "file://icon.xpm"
9
10do_configure_prepend () {
11 install -m 0644 ${WORKDIR}/icon.xpm ${S}
12}
13do_install_prepend () {
14echo '# /boot/boot.cfg - KEXECBOOT configuration file.
15#
16# First kernel stanza.
17# Show this label in kexecboot menu.
18#
19LABEL=${KEXECBOOT_LABEL}
20#
21# Specify full kernel path on target.
22KERNEL=/boot/${KERNEL_IMAGETYPE}
23#
24# Append this tags to the kernel cmdline.
25APPEND=${CMDLINE} ${CMDLINE_DEBUG}
26#
27# Specify optional initrd/initramfs.
28# INITRD=/boot/initramfs.cpio.gz
29#
30# Specify full path for a custom icon for the menu-item.
31# If not set, use device-icons as default (NAND, SD, CF, ...).
32# ICON=/boot/icon.xpm
33#
34# Priority of item in kexecboot menu.
35# Items with highest priority will be shown at top of menu.
36# Default: 0 (lowest, ordered by device ordering)
37# PRIORITY=10
38#
39#
40# Second kernel stanza.
41# LABEL=${KEXECBOOT_LABEL}-test
42# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
43# APPEND=${CMDLINE}
44#' > ${S}/boot.cfg
45}
46do_install () {
47 install -d ${D}/boot
48 install -m 0644 boot.cfg ${D}/boot/boot.cfg
49 install -m 0644 icon.xpm ${D}/boot/icon.xpm
50}
51
52PACKAGE_ARCH = "${MACHINE_ARCH}"
53
54FILES_${PN} += "/boot/*"
55
56CMDLINE ?= ""
57CMDLINE_DEBUG ?= "quiet"
58
59INHIBIT_DEFAULT_DEPS = "1"
60
61# Note: for qvga the label is currently limited to about 24 chars
62KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"