summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb')
-rw-r--r--meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
new file mode 100644
index 000000000..35eb245ce
--- /dev/null
+++ b/meta-initramfs/recipes-bsp/images/initramfs-kexecboot-image.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Initramfs image for kexecboot kernel"
2DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
7
8# avoid circular dependencies
9EXTRA_IMAGEDEPENDS = ""
10
11# We really need just kexecboot, kexec and ubiattach
12IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
13
14# Do not pollute the initrd image with rootfs features
15IMAGE_FEATURES = ""
16
17IMAGE_LINGUAS = ""
18
19FEED_DEPLOYDIR_BASE_URI = ""
20LDCONFIGDEPEND = ""
21
22inherit image