summaryrefslogtreecommitdiffstats
path: root/meta-sys940x
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sys940x')
-rw-r--r--meta-sys940x/COPYING.MIT17
-rw-r--r--meta-sys940x/README178
-rw-r--r--meta-sys940x/README.sources17
-rw-r--r--meta-sys940x/binary/.gitignore0
-rw-r--r--meta-sys940x/conf/layer.conf12
-rw-r--r--meta-sys940x/conf/machine/sys940x-noemgd.conf21
-rw-r--r--meta-sys940x/conf/machine/sys940x.conf33
-rw-r--r--meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig3
-rw-r--r--meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig3
-rw-r--r--meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend1
-rw-r--r--meta-sys940x/recipes-bsp/genmac/files/genmac46
-rw-r--r--meta-sys940x/recipes-bsp/genmac/genmac.bb30
-rw-r--r--meta-sys940x/recipes-core/init-ifupdown/files/sys940x-noemgd/interfaces10
-rw-r--r--meta-sys940x/recipes-core/init-ifupdown/files/sys940x/interfaces10
-rw-r--r--meta-sys940x/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend3
-rw-r--r--meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb24
-rw-r--r--meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf43
-rw-r--r--meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend1
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto-dev.bbappend23
-rw-r--r--meta-sys940x/recipes-kernel/linux/linux-yocto_3.10.bbappend21
20 files changed, 0 insertions, 496 deletions
diff --git a/meta-sys940x/COPYING.MIT b/meta-sys940x/COPYING.MIT
deleted file mode 100644
index fb950dc6..00000000
--- a/meta-sys940x/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-sys940x/README b/meta-sys940x/README
deleted file mode 100644
index 57f64f23..00000000
--- a/meta-sys940x/README
+++ /dev/null
@@ -1,178 +0,0 @@
1This README file contains information on building the meta-sys940x BSP
2layer, and booting the images contained in the /binary directory.
3Please see the corresponding sections below for details.
4
5The 'Queens Bay' platform consists of the Intel Atom E6xx
6processor, plus the Intel EG20T Platform Controller Hub (Tunnel Creek
7+ Topcliff).
8
9It also supports the E6xx embedded on-chip graphics via the Intel
10Embedded Media and Graphics Driver (EMGD).
11
12More details available on the product page:
13 http://www.inforcecomputing.com/SYS940X_ECX.html
14
15Information on all IntelĀ® embedded platforms can be found here:
16
17 http://www.intel.com/p/en_US/embedded/hwsw/hardware
18
19
20Yocto Project Compatible
21========================
22
23This BSP is compatible with the Yocto Project as per the requirements
24listed here:
25
26 https://www.yoctoproject.org/webform/yocto-project-compatible-registration
27
28
29Dependencies
30============
31
32This layer depends on:
33
34 URI: git://git.openembedded.org/bitbake
35 branch: master
36
37 URI: git://git.openembedded.org/openembedded-core
38 layers: meta
39 branch: master
40
41 URI: git://git.yoctoproject.org/meta-intel
42 layers: intel
43 branch: master
44
45
46Patches
47=======
48
49Please submit any patches against this BSP to the Yocto mailing list
50(yocto@yoctoproject.org) and cc: the maintainer:
51
52Maintainer: Darren Hart <dvhart@linux.intel.com>
53
54Please see the meta-intel/MAINTAINERS file for more details.
55
56
57Table of Contents
58=================
59
60 I. Building the meta-sys940x BSP layer
61 II. Booting the images in /binary
62
63
64I. Building the meta-sys940x BSP layer
65===================================
66
67In order to build an image with BSP support for a given release, you
68need to download the corresponding BSP tarball from the 'Board Support
69Package (BSP) Downloads' page of the Yocto Project website.
70
71Having done that, and assuming you extracted the BSP tarball contents
72at the top-level of your yocto build tree, you can build an sys940x image
73by adding the location of the meta-sys940x layer to bblayers.conf, along
74with the meta-intel layer itself (to access common metadata shared
75between BSPs) e.g.:
76
77 yocto/meta-intel \
78 yocto/meta-intel/meta-sys940x \
79
80The meta-sys940x layer contains support for two different machine
81configurations. These configurations are identical except for the fact
82that the one prefixed with 'sys940x' makes use of the Intel-proprietary
83EMGD graphics driver, while the one prefixed with 'sys940x-noemgd'
84does not.
85
86If you want to enable the layer that supports EMGD graphics add the
87following to the local.conf file:
88
89 MACHINE ?= "sys940x"
90
91The 'sys940x' machine includes the emgd-driver-bin package, which has a
92proprietary license that must be whitelisted by adding the string
93"license_emgd-driver-bin" to the LICENSE_FLAGS_WHITELIST variable
94in your local.conf. For example:
95
96 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin"
97
98The emgd recipe depends on Xorg's dri and glx modules, which are built
99only when 'opengl' is listed in DISTRO_FEATURES. So if the distro
100doesn't list 'opengl' in the DISTRO_FEATURES you would need this
101additional line to your local.conf:
102
103 DISTRO_FEATURES_append = " opengl"
104
105If you want to enable the layer that does not support EMGD graphics
106add the following to the local.conf file:
107
108 MACHINE ?= "sys940x-noemgd"
109
110You should then be able to build an sys940x image as such:
111
112 $ source oe-init-build-env
113 $ bitbake core-image-sato
114
115At the end of a successful build, you should have a live image that
116you can boot from a USB flash drive (see instructions on how to do
117that below, in the section 'Booting the images from /binary').
118
119NOTE: The 'sys940x' machine will include support for hardware video
120acceleration via gstreamer if and only if the "commercial" string is
121added to the the LICENSE_FLAGS_WHITELIST variable in your local.conf.
122
123For example:
124
125 LICENSE_FLAGS_WHITELIST = "license_emgd-driver-bin commercial"
126
127The reason this is needed is to prevent the image from including
128anything that might violate the license terms of the packages used to
129implement the the video acceleration feature, such as gst-ffmpeg and
130ffmpeg. As always, please consult the licenses included in the
131specific packages for details if you use packages that require
132particular LICENSE_FLAGS.
133
134As an alternative to downloading the BSP tarball, you can also work
135directly from the meta-intel git repository. For each BSP in the
136'meta-intel' repository, there are multiple branches, one
137corresponding to each major release starting with 'laverne' (0.90), in
138addition to the latest code which tracks the current master (note that
139not all BSPs are present in every release). Instead of extracting a
140BSP tarball at the top level of your yocto build tree, you can
141equivalently check out the appropriate branch from the meta-intel
142repository at the same location.
143
144
145II. Booting the images in /binary
146=================================
147
148This BSP contains bootable live images, which can be used to directly
149boot Yocto off of a USB flash drive.
150
151Under Linux, insert a USB flash drive. Assuming the USB flash drive
152takes device /dev/sdf, use dd to copy the live image to it. For
153example:
154
155# dd if=core-image-sato-sys940x.hddimg of=/dev/sdf
156# sync
157# eject /dev/sdf
158
159This should give you a bootable USB flash device. Insert the device
160into a bootable USB socket on the target, and power on. This should
161result in a system booted to the Sato graphical desktop.
162
163If you want a terminal, use the arrows at the top of the UI to move to
164different pages of available applications, one of which is named
165'Terminal'. Clicking that should give you a root terminal.
166
167If you want to ssh into the system, you can use the root terminal to
168ifconfig the IP address and use that to ssh in. The root password is
169empty, so to log in type 'root' for the user name and hit 'Enter' at
170the Password prompt: and you should be in.
171
172----
173
174If you find you're getting corrupt images on the USB (it doesn't show
175the syslinux boot: prompt, or the boot: prompt contains strange
176characters), try doing this first:
177
178# dd if=/dev/zero of=/dev/sdf bs=1M count=512
diff --git a/meta-sys940x/README.sources b/meta-sys940x/README.sources
deleted file mode 100644
index 0d4d849a..00000000
--- a/meta-sys940x/README.sources
+++ /dev/null
@@ -1,17 +0,0 @@
1The sources for the packages comprising the images shipped with this
2BSP can be found at the following location:
3
4http://downloads.yoctoproject.org/mirror/sources/
5
6The metadata used to generate the images shipped with this BSP, in
7addition to the code contained in this BSP, can be found at the
8following location:
9
10http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2
11
12The metadata used to generate the images shipped with this BSP, in
13addition to the code contained in this BSP, can also be found at the
14following locations:
15
16git://git.yoctoproject.org/poky.git
17git://git.yoctoproject.org/meta-intel
diff --git a/meta-sys940x/binary/.gitignore b/meta-sys940x/binary/.gitignore
deleted file mode 100644
index e69de29b..00000000
--- a/meta-sys940x/binary/.gitignore
+++ /dev/null
diff --git a/meta-sys940x/conf/layer.conf b/meta-sys940x/conf/layer.conf
deleted file mode 100644
index b14be6db..00000000
--- a/meta-sys940x/conf/layer.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "sys940x"
9BBFILE_PATTERN_sys940x := "^${LAYERDIR}/"
10BBFILE_PRIORITY_sys940x = "6"
11
12LAYERDEPENDS_sys940x = "intel"
diff --git a/meta-sys940x/conf/machine/sys940x-noemgd.conf b/meta-sys940x/conf/machine/sys940x-noemgd.conf
deleted file mode 100644
index ed6c7f49..00000000
--- a/meta-sys940x/conf/machine/sys940x-noemgd.conf
+++ /dev/null
@@ -1,21 +0,0 @@
1#@TYPE: Machine
2#@NAME: sys940x-noemgd
3
4#@WEBTITLE: Intel Atom E6xx Processor with Intel EG20T Controller Hub Development Kit (Queens Bay) with Open Source VESA Graphics for Inforce SYS940X systems.
5
6#@DESCRIPTION: Machine configuration for Inforce SYS940X systems, without Intel-proprietary graphics bits
7
8require conf/machine/include/intel-core2-32-common.inc
9
10# Add "pcbios" if you have a non-efi version of the firmware
11MACHINE_FEATURES += "efi pcbios"
12
13PREFERRED_VERSION_linux-yocto ?= "3.10%"
14
15XSERVER ?= "${XSERVER_X86_BASE} \
16 ${XSERVER_X86_EXT} \
17 ${XSERVER_X86_VESA} \
18 "
19
20SERIAL_CONSOLE = "115200 ttyS0"
21APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-sys940x/conf/machine/sys940x.conf b/meta-sys940x/conf/machine/sys940x.conf
deleted file mode 100644
index 04e77665..00000000
--- a/meta-sys940x/conf/machine/sys940x.conf
+++ /dev/null
@@ -1,33 +0,0 @@
1#@TYPE: Machine
2#@NAME: sys940x
3
4#@WEBTITLE: Intel Atom E6xx Processor with Intel EG20T Controller Hub Development Kit (Queens Bay) with Proprietary IEMGD Accelerated Graphics
5
6#@DESCRIPTION: Machine configuration for Inforce SYS940x systems
7
8require conf/machine/include/intel-core2-32-common.inc
9require conf/machine/include/meta-intel.inc
10require conf/machine/include/meta-intel-emgd.inc
11
12# Add "pcbios" if you have a non-efi version of the firmware
13MACHINE_FEATURES += "efi pcbios gst-va-mixvideo"
14
15PREFERRED_VERSION_linux-yocto ?= "3.10%"
16
17MACHINE_HWCODECS ?= "va-intel"
18XSERVERCODECS ?= "emgd-driver-video emgd-gst-plugins-va \
19 emgd-gst-plugins-mixvideo gst-va-intel"
20
21XSERVER ?= "${XSERVER_X86_BASE} \
22 ${XSERVER_X86_EXT} \
23 ${XSERVER_X86_EMGD} \
24 "
25
26PREFERRED_VERSION_xserver-xorg ?= "1.9.3"
27PREFERRED_VERSION_xf86-input-synaptics ?= "1.6.3"
28PREFERRED_VERSION_xf86-input-evdev ?= "2.6.0"
29PREFERRED_VERSION_emgd-driver-bin ?= "1.18"
30PREFERRED_VERSION_libva ?= "1.0.16"
31
32SERIAL_CONSOLE = "115200 ttyS0"
33APPEND += "console=ttyS0,115200 console=tty0"
diff --git a/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig b/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x-noemgd/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig b/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig
deleted file mode 100644
index ffce0122..00000000
--- a/meta-sys940x/recipes-bsp/formfactor/formfactor/sys940x/machconfig
+++ /dev/null
@@ -1,3 +0,0 @@
1# Assume a USB mouse and keyboard are connected
2HAVE_TOUCHSCREEN=0
3HAVE_KEYBOARD=1
diff --git a/meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend b/meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-sys940x/recipes-bsp/formfactor/formfactor_0.0.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-sys940x/recipes-bsp/genmac/files/genmac b/meta-sys940x/recipes-bsp/genmac/files/genmac
deleted file mode 100644
index 1899e95f..00000000
--- a/meta-sys940x/recipes-bsp/genmac/files/genmac
+++ /dev/null
@@ -1,46 +0,0 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides: Random MAC address generator
4# Required-Start: $syslog
5# Required-Stop: $syslog
6# Default-Start: 2 3 4 5
7# Default-Stop: 0 1 6
8# Short-Description: Set a random MAC for tagged interfaces
9# Description: Set a random MAC for interfaces with RANDOM_MAC
10### END INIT INFO
11
12# Author: Darren Hart <dvhart@linux.intel.com>
13# Based on /etc/init.d/skeleton
14
15PATH=/sbin:/usr/sbin:/bin:/usr/bin
16DESC="Set a random MAC for tagged interfaces"
17NAME=genmac
18RANPWD=`which ranpwd`
19SCRIPTNAME=/etc/init.d/$NAME
20
21# Exit if ranpwd is not installed
22[ -x "$RANPWD" ] || exit 0
23
24do_start() {
25 # Replace every occurence of RANDOM_MAC with a unique locally
26 # administered, unicast, randomly generated MAC address.
27 while grep -q RANDOM_MAC /etc/network/interfaces; do
28 sed -i "1,/RANDOM_MAC/s/RANDOM_MAC/$($RANPWD -m)/" /etc/network/interfaces
29 done
30}
31
32case "$1" in
33start)
34 echo "$NAME: Setting random MAC addresses"
35 do_start
36 ;;
37stop)
38 ;;
39*)
40 echo "Usage: $SCRIPTNAME {start|stop}" >&2
41 exit 3
42 ;;
43esac
44
45exit 0
46
diff --git a/meta-sys940x/recipes-bsp/genmac/genmac.bb b/meta-sys940x/recipes-bsp/genmac/genmac.bb
deleted file mode 100644
index 29276603..00000000
--- a/meta-sys940x/recipes-bsp/genmac/genmac.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "Provide a basic init script to generate a random MAC"
2DESCRIPTION = "Set the MAC from the config file."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
6
7PR = "r0"
8
9inherit update-rc.d
10
11RDEPENDS_${PN} = "ranpwd"
12
13SRC_URI = "file://genmac"
14
15INITSCRIPT_NAME = "genmac"
16# Run as early as possible to ensure we are before the networking scripts
17INITSCRIPT_PARAMS = "start 39 S ."
18
19do_install() {
20 install -d ${D}${sysconfdir} \
21 ${D}${sysconfdir}/init.d
22 install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d
23 cat ${WORKDIR}/${INITSCRIPT_NAME} | \
24 sed -e 's,/etc,${sysconfdir},g' \
25 -e 's,/usr/sbin,${sbindir},g' \
26 -e 's,/var,${localstatedir},g' \
27 -e 's,/usr/bin,${bindir},g' \
28 -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
29 chmod 755 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
30}
diff --git a/meta-sys940x/recipes-core/init-ifupdown/files/sys940x-noemgd/interfaces b/meta-sys940x/recipes-core/init-ifupdown/files/sys940x-noemgd/interfaces
deleted file mode 100644
index 754a5d9d..00000000
--- a/meta-sys940x/recipes-core/init-ifupdown/files/sys940x-noemgd/interfaces
+++ /dev/null
@@ -1,10 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wired or wireless interfaces
8auto eth0
9iface eth0 inet dhcp
10 hwaddress ether RANDOM_MAC
diff --git a/meta-sys940x/recipes-core/init-ifupdown/files/sys940x/interfaces b/meta-sys940x/recipes-core/init-ifupdown/files/sys940x/interfaces
deleted file mode 100644
index 754a5d9d..00000000
--- a/meta-sys940x/recipes-core/init-ifupdown/files/sys940x/interfaces
+++ /dev/null
@@ -1,10 +0,0 @@
1# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
2
3# The loopback interface
4auto lo
5iface lo inet loopback
6
7# Wired or wireless interfaces
8auto eth0
9iface eth0 inet dhcp
10 hwaddress ether RANDOM_MAC
diff --git a/meta-sys940x/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend b/meta-sys940x/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend
deleted file mode 100644
index 6863e1c5..00000000
--- a/meta-sys940x/recipes-core/init-ifupdown/init-ifupdown_1.0.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2RDEPENDS_${PN}_sys940x_append += "genmac"
3RDEPENDS_${PN}_sys940x-noemgd_append += "genmac"
diff --git a/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb b/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
deleted file mode 100644
index b4e0f549..00000000
--- a/meta-sys940x/recipes-extended/ranpwd/ranpwd_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "Random password generator"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://ranpwd.c;beginline=1;endline=11;md5=0e8585e19117526efedfaeb50c345d7a"
4SECTION = "console/utils"
5PV = "1.2+git${SRCPV}"
6PR = "r0"
7
8inherit autotools
9
10SRC_URI = "git://git.zytor.com/utils/ranpwd.git"
11SRCREV = "b62aab579e288715b82d5575befaa2b8ff210c2b"
12
13S="${WORKDIR}/git"
14
15do_configure_prepend () {
16 if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then
17 cp aclocal.m4 acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}/${bindir}
23 install -m 0755 ${S}/ranpwd ${D}/${bindir}/ranpwd
24}
diff --git a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf
deleted file mode 100644
index 5266117b..00000000
--- a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config/sys940x/xorg.conf
+++ /dev/null
@@ -1,43 +0,0 @@
1##
2## X Config options generated from CED
3## x11 conf skeleton
4## DriverVer=
5##
6
7Section "Screen"
8 Identifier "Screen0"
9 Device "IntelEMGD-0"
10 Monitor "Monitor0"
11 SubSection "Display"
12 EndSubSection
13EndSection
14
15# Primary (First/only) display
16Section "Device"
17 Identifier "IntelEMGD-0"
18 Driver "emgd"
19 VendorName "Intel(R) DEG"
20 BoardName "Embedded Graphics"
21 BusID "0:2:0"
22 Screen 0
23 Option "PcfVersion" "1792"
24 Option "ConfigId" "1"
25 Option "ALL/1/name" "e6xx"
26 Option "ALL/1/General/PortOrder" "32400"
27 Option "ALL/1/General/DisplayConfig" "1"
28 Option "ALL/1/General/DisplayDetect" "1"
29 Option "ALL/1/General/TuningWA" "1"
30 Option "ALL/1/Port/4/General/name" "lvds"
31 Option "ALL/1/Port/4/General/EdidAvail" "3"
32 Option "ALL/1/Port/4/General/EdidNotAvail" "1"
33 Option "ALL/1/Port/4/General/Rotation" "0"
34 Option "ALL/1/Port/4/General/Edid" "0"
35EndSection
36
37Section "ServerLayout"
38 Identifier "Default Layout"
39 Screen 0 "Screen0" 0 0
40 # InputDevice "Mouse0" "CorePointer"
41 # InputDevice "Keyboard0" "CoreKeyboard"
42 # InputDevice "DevInputMice" "SendCoreEvents"
43EndSection
diff --git a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
deleted file mode 100644
index 72d991c7..00000000
--- a/meta-sys940x/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto-dev.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto-dev.bbappend
deleted file mode 100644
index 63fc6042..00000000
--- a/meta-sys940x/recipes-kernel/linux/linux-yocto-dev.bbappend
+++ /dev/null
@@ -1,23 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4KMETA = "meta"
5
6COMPATIBLE_MACHINE_sys940x = "sys940x"
7KMACHINE_sys940x = "sys940x"
8KBRANCH_sys940x = "standard/sys940x"
9KERNEL_FEATURES_sys940x = " features/drm-emgd/drm-emgd-1.16"
10
11COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
12KMACHINE_sys940x-noemgd = "sys940x"
13KBRANCH_sys940x-noemgd = "standard/sys940x"
14KERNEL_FEATURES_sys940x-noemgd = " cfg/vesafb"
15
16SRCREV_machine_sys940x = "60536206ad300ccf5b2be2c2d449f4ab27170238"
17SRCREV_meta_sys940x = "fe20c99783387dab779472ff50a88666da1c6391"
18SRCREV_emgd_sys940x = "17aacd908ed6035213a6d206cfdb2c0c9fa9e0c1"
19
20SRCREV_machine_sys940x-noemgd = "60536206ad300ccf5b2be2c2d449f4ab27170238"
21SRCREV_meta_sys940x-noemgd = "fe20c99783387dab779472ff50a88666da1c6391"
22
23SRC_URI_sys940x = "git://git.yoctoproject.org/linux-yocto-dev.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd"
diff --git a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-sys940x/recipes-kernel/linux/linux-yocto_3.10.bbappend
deleted file mode 100644
index 1b71a773..00000000
--- a/meta-sys940x/recipes-kernel/linux/linux-yocto_3.10.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3
4KMETA = "meta"
5LINUX_VERSION = "3.10.19"
6
7COMPATIBLE_MACHINE_sys940x = "sys940x"
8KMACHINE_sys940x = "sys940x"
9KBRANCH_sys940x = "standard/sys940x"
10KERNEL_FEATURES_sys940x = " features/drm-emgd/drm-emgd-1.18"
11SRCREV_meta_sys940x = "d9cd83c0292bd4e2a6754a96761027252e726a42"
12SRCREV_machine_sys940x = "a9ec82e355130160f9094e670bd5be0022a84194"
13SRCREV_emgd_sys940x = "39c44dd7838bfd228938219cdb21ca30c4d0cbbf"
14SRC_URI_sys940x = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.18;name=machine,meta,emgd"
15
16COMPATIBLE_MACHINE_sys940x-noemgd = "sys940x-noemgd"
17KMACHINE_sys940x-noemgd = "sys940x"
18KBRANCH_sys940x-noemgd = "standard/sys940x"
19KERNEL_FEATURES_sys940x-noemgd = " cfg/vesafb"
20SRCREV_meta_sys940x-noemgd = "d9cd83c0292bd4e2a6754a96761027252e726a42"
21SRCREV_machine_sys940x-noemgd = "a9ec82e355130160f9094e670bd5be0022a84194"