summaryrefslogtreecommitdiffstats
path: root/meta-sys940x/recipes-bsp/genmac/genmac.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-sys940x/recipes-bsp/genmac/genmac.bb')
-rw-r--r--meta-sys940x/recipes-bsp/genmac/genmac.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-sys940x/recipes-bsp/genmac/genmac.bb b/meta-sys940x/recipes-bsp/genmac/genmac.bb
deleted file mode 100644
index 29276603..00000000
--- a/meta-sys940x/recipes-bsp/genmac/genmac.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "Provide a basic init script to generate a random MAC"
2DESCRIPTION = "Set the MAC from the config file."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
6
7PR = "r0"
8
9inherit update-rc.d
10
11RDEPENDS_${PN} = "ranpwd"
12
13SRC_URI = "file://genmac"
14
15INITSCRIPT_NAME = "genmac"
16# Run as early as possible to ensure we are before the networking scripts
17INITSCRIPT_PARAMS = "start 39 S ."
18
19do_install() {
20 install -d ${D}${sysconfdir} \
21 ${D}${sysconfdir}/init.d
22 install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d
23 cat ${WORKDIR}/${INITSCRIPT_NAME} | \
24 sed -e 's,/etc,${sysconfdir},g' \
25 -e 's,/usr/sbin,${sbindir},g' \
26 -e 's,/var,${localstatedir},g' \
27 -e 's,/usr/bin,${bindir},g' \
28 -e 's,/usr,${prefix},g' > ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
29 chmod 755 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
30}