summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch86
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch54
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch172
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch30
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch223
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch45
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch53
8 files changed, 164 insertions, 532 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
new file mode 100644
index 00000000..7f5b46c6
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch
@@ -0,0 +1,86 @@
1From e4edbdae9a2dbfec6fd0706bdfff8abdfe3363fc Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:42:57 +0530
4Subject: [PATCH] cmake: yocto specific tweaks to the build process
5
6* Dont try to detect glibc version as that doesn't work when cross compiling.
7* Dont try to detect CXX11_ABI
8* Install sample binaries as well.
9* Dont try to write triggers for CPack. We package ourselves.
10* Fix the installation path for Python modules when baselib = lib64.
11
12Upstream-Status: Inappropriate
13
14Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
15---
16 cmake/developer_package/packaging/rpm/rpm.cmake | 2 +-
17 cmake/developer_package/target_flags.cmake | 4 ++--
18 samples/cpp/CMakeLists.txt | 6 +++---
19 src/bindings/python/CMakeLists.txt | 2 +-
20 4 files changed, 7 insertions(+), 7 deletions(-)
21
22diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake
23index 99f11730983..1a1f61fcd3d 100644
24--- a/cmake/developer_package/packaging/rpm/rpm.cmake
25+++ b/cmake/developer_package/packaging/rpm/rpm.cmake
26@@ -156,7 +156,7 @@ ov_rpm_specific_settings()
27 # needed to add triggers for packages with libraries
28 set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers")
29 set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n")
30-file(WRITE "${def_triggers}" "${triggers_content}")
31+#file(WRITE "${def_triggers}" "${triggers_content}")
32
33 #
34 # Functions helpful for packaging your modules with RPM cpack
35diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
36index d047a1aebd9..4e8ca68c60f 100644
37--- a/cmake/developer_package/target_flags.cmake
38+++ b/cmake/developer_package/target_flags.cmake
39@@ -149,7 +149,7 @@ function(ov_glibc_version)
40 endif()
41 endfunction()
42
43-ov_glibc_version()
44+#ov_glibc_version()
45
46 #
47 # Detects default value for _GLIBCXX_USE_CXX11_ABI for current compiler
48@@ -160,4 +160,4 @@ macro(ov_get_glibcxx_use_cxx11_abi)
49 endif()
50 endmacro()
51
52-ov_get_glibcxx_use_cxx11_abi()
53+#ov_get_glibcxx_use_cxx11_abi()
54diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
55index 4d33bff944e..3e7f1458578 100644
56--- a/samples/cpp/CMakeLists.txt
57+++ b/samples/cpp/CMakeLists.txt
58@@ -206,9 +206,9 @@ macro(ov_add_sample)
59 target_link_libraries(${SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${SAMPLE_DEPENDENCIES})
60
61 install(TARGETS ${SAMPLE_NAME}
62- RUNTIME DESTINATION samples_bin/
63- COMPONENT samples_bin
64- EXCLUDE_FROM_ALL)
65+ DESTINATION ${CMAKE_INSTALL_BINDIR}
66+ COMPONENT samples_bin)
67+
68
69 # create global target with all samples / demo apps
70 if(NOT TARGET ov_samples)
71diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt
72index 6cf43ec3fed..d539b9d003f 100644
73--- a/src/bindings/python/CMakeLists.txt
74+++ b/src/bindings/python/CMakeLists.txt
75@@ -320,7 +320,7 @@ if(ENABLE_PYTHON_PACKAGING)
76 # install OpenVINO Python API
77
78 set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}")
79- set(install_lib "${python_package_prefix}/lib/${python_versioned_folder}/${ov_site_packages}")
80+ set(install_lib "${python_package_prefix}/${CMAKE_INSTALL_LIBDIR}/${python_versioned_folder}/${ov_site_packages}")
81 set(openvino_meta_info_subdir "openvino-${OpenVINO_VERSION}-py${python_xy}.egg-info")
82 set(openvino_meta_info_file "${install_lib}/${openvino_meta_info_subdir}/PKG-INFO")
83
84--
852.34.1
86
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
deleted file mode 100644
index 2a2c8b87..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From a60710c910e6c995aef9dd36757bf040bf24acf5 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 9 Jun 2020 11:35:59 +0800
4Subject: [PATCH] don't install licenses and version
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 ngraph/CMakeLists.txt | 6 ++----
11 ngraph/test/runtime/CMakeLists.txt | 2 ++
12 2 files changed, 4 insertions(+), 4 deletions(-)
13
14diff --git a/ngraph/CMakeLists.txt b/ngraph/CMakeLists.txt
15index 99f32a6181..b90aa382b9 100644
16--- a/ngraph/CMakeLists.txt
17+++ b/ngraph/CMakeLists.txt
18@@ -490,7 +490,7 @@ if (NGRAPH_EXPORT_TARGETS_ENABLE)
19 install(EXPORT ngraphTargets
20 FILE ngraphTargets.cmake
21 NAMESPACE ngraph::
22- DESTINATION ${NGRAPH_COMPONENT_PREFIX}cmake
23+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
24 COMPONENT ngraph)
25
26 configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/share/ngraphConfig.cmake.in
27@@ -503,7 +503,7 @@ if (NGRAPH_EXPORT_TARGETS_ENABLE)
28
29 install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ngraphConfig.cmake
30 ${CMAKE_CURRENT_BINARY_DIR}/ngraphConfigVersion.cmake
31- DESTINATION ${NGRAPH_COMPONENT_PREFIX}cmake
32+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
33 COMPONENT ngraph)
34 endif()
35
36@@ -518,5 +518,3 @@ add_subdirectory(test)
37 if (NGRAPH_PYTHON_BUILD_ENABLE)
38 add_subdirectory(python)
39 endif()
40-
41-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION DESTINATION "${NGRAPH_COMPONENT_PREFIX}." COMPONENT ngraph)
42diff --git a/ngraph/test/runtime/CMakeLists.txt b/ngraph/test/runtime/CMakeLists.txt
43index d27ea8090c..17a3843f7d 100644
44--- a/ngraph/test/runtime/CMakeLists.txt
45+++ b/ngraph/test/runtime/CMakeLists.txt
46@@ -80,3 +80,5 @@ target_include_directories(ngraph_backend PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
47
48 add_subdirectory(interpreter)
49 add_subdirectory(ie)
50+
51+install(TARGETS ngraph_backend DESTINATION ${NGRAPH_INSTALL_LIB})
52--
532.29.2
54
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
deleted file mode 100644
index 1f64ce21..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-inference-engine-use-system-installed-packages.patch
+++ /dev/null
@@ -1,172 +0,0 @@
1From a8b6a2e251c42a393218174c6737208760d2e1c1 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:43:55 +0800
4Subject: [PATCH] inference-engine: use system installed packages
5
6Use installed versions of ade, protobuf and tbb.
7
8Upstream-Status: Pending
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 cmake/dependencies.cmake | 18 ------------------
13 inference-engine/CMakeLists.txt | 2 +-
14 inference-engine/cmake/ie_parallel.cmake | 7 +------
15 .../src/inference_engine/CMakeLists.txt | 19 -------------------
16 .../common_test_utils/CMakeLists.txt | 4 +---
17 .../unit_test_utils/CMakeLists.txt | 3 +--
18 inference-engine/thirdparty/CMakeLists.txt | 5 ++---
19 7 files changed, 6 insertions(+), 52 deletions(-)
20
21diff --git a/cmake/dependencies.cmake b/cmake/dependencies.cmake
22index 6a44c8769e..a128eb63a1 100644
23--- a/cmake/dependencies.cmake
24+++ b/cmake/dependencies.cmake
25@@ -13,25 +13,7 @@ if(CMAKE_CROSSCOMPILING AND NGRAPH_ONNX_IMPORT_ENABLE)
26
27 set(protoc_version "3.7.1")
28 if(CMAKE_HOST_SYSTEM_NAME MATCHES Linux)
29- RESOLVE_DEPENDENCY(SYSTEM_PROTOC_ROOT
30- ARCHIVE_LIN "protoc-${protoc_version}-linux-x86_64.tar.gz"
31- TARGET_PATH "${TEMP}/protoc-${protoc_version}-linux-x86_64")
32- debug_message(STATUS "host protoc-${protoc_version} root path = " ${SYSTEM_PROTOC_ROOT})
33 else()
34 message(FATAL_ERROR "Unsupported host system (${CMAKE_HOST_SYSTEM_NAME}) and arch (${CMAKE_HOST_SYSTEM_PROCESSOR}) for cross-compilation")
35 endif()
36-
37- reset_deps_cache(SYSTEM_PROTOC)
38-
39- message("${SYSTEM_PROTOC_ROOT}/bin")
40- find_program(
41- SYSTEM_PROTOC
42- NAMES protoc
43- PATHS "${SYSTEM_PROTOC_ROOT}/bin"
44- NO_DEFAULT_PATH)
45- if(NOT SYSTEM_PROTOC)
46- message(FATAL_ERROR "[ONNX IMPORTER] Missing host protoc binary")
47- endif()
48-
49- update_deps_cache(SYSTEM_PROTOC "${SYSTEM_PROTOC}" "Path to host protoc for ONNX Importer")
50 endif()
51diff --git a/inference-engine/CMakeLists.txt b/inference-engine/CMakeLists.txt
52index a3e4f74c40..76b09683dd 100644
53--- a/inference-engine/CMakeLists.txt
54+++ b/inference-engine/CMakeLists.txt
55@@ -56,7 +56,7 @@ function(ie_developer_export)
56 APPEND FILE "${CMAKE_BINARY_DIR}/targets_developer.cmake")
57
58 # Custom target to build only Inference Engine Developer Package targets
59- add_custom_target(ie_dev_targets ALL DEPENDS ${OpenVINODeveloperPackageTargets} ${IEDeveloperPackageTargets} gflags
60+ add_custom_target(ie_dev_targets ALL DEPENDS ${OpenVINODeveloperPackageTargets} ${IEDeveloperPackageTargets}
61 inference_engine_ir_reader inference_engine_ir_v7_reader)
62 endfunction()
63
64diff --git a/inference-engine/cmake/ie_parallel.cmake b/inference-engine/cmake/ie_parallel.cmake
65index f8988aa105..28e79417f4 100644
66--- a/inference-engine/cmake/ie_parallel.cmake
67+++ b/inference-engine/cmake/ie_parallel.cmake
68@@ -67,13 +67,8 @@ function(set_ie_threading_interface_for TARGET_NAME)
69 set(IE_THREAD_DEFINE "IE_THREAD_SEQ")
70
71 if (THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO")
72- if (TBB_FOUND)
73 set(IE_THREAD_DEFINE "IE_THREAD_TBB")
74- ie_target_link_libraries(${TARGET_NAME} ${LINK_TYPE} ${TBB_IMPORTED_TARGETS})
75- else ()
76- ext_message(WARNING "TBB was not found by the configured TBB_DIR path.\
77- SEQ method will be used for ${TARGET_NAME}")
78- endif ()
79+ target_link_libraries(${TARGET_NAME} INTERFACE tbb tbbmalloc)
80 elseif (THREADING STREQUAL "OMP")
81 if (WIN32)
82 set(omp_lib_name libiomp5md)
83diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
84index f012a038a2..3bba22215e 100644
85--- a/inference-engine/src/inference_engine/CMakeLists.txt
86+++ b/inference-engine/src/inference_engine/CMakeLists.txt
87@@ -216,25 +216,6 @@ list(APPEND core_components ngraph)
88 if((THREADING STREQUAL "TBB" OR THREADING STREQUAL "TBB_AUTO") AND TBBROOT MATCHES ${TEMP})
89 ie_cpack_add_component(tbb REQUIRED)
90 list(APPEND core_components tbb)
91-
92- install(DIRECTORY "${TBB}/include"
93- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
94- COMPONENT tbb)
95- install(DIRECTORY "${TBB}/lib"
96- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
97- COMPONENT tbb)
98- if(EXISTS "${TBB}/bin")
99- install(DIRECTORY "${TBB}/bin"
100- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
101- COMPONENT tbb)
102- endif()
103- install(FILES "${TBB}/LICENSE"
104- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb
105- COMPONENT tbb)
106- install(FILES "${TBB}/cmake/TBBConfig.cmake"
107- "${TBB}/cmake/TBBConfigVersion.cmake"
108- DESTINATION ${IE_CPACK_IE_DIR}/external/tbb/cmake
109- COMPONENT tbb)
110 endif()
111
112 ie_cpack_add_component(core REQUIRED DEPENDS ${core_components})
113diff --git a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
114index ca58264bd5..11df150845 100644
115--- a/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
116+++ b/inference-engine/tests/ie_test_utils/common_test_utils/CMakeLists.txt
117@@ -26,7 +26,7 @@ function(add_gtest_libraries)
118 PROPERTIES FOLDER thirdparty)
119 endfunction()
120
121-add_gtest_libraries()
122+#add_gtest_libraries()
123
124 if (MSVC)
125 set(PUGI pugixml_mt)
126@@ -37,8 +37,6 @@ endif ()
127 list(APPEND EXPORT_DEPENDENCIES
128 ${PUGI}
129 ${NGRAPH_LIBRARIES}
130- gtest
131- gtest_main
132 )
133
134 set(TARGET_NAME commonTestUtils)
135diff --git a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
136index 5413d13895..3f2803750f 100644
137--- a/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
138+++ b/inference-engine/tests/ie_test_utils/unit_test_utils/CMakeLists.txt
139@@ -8,8 +8,7 @@ add_subdirectory(mocks/mock_engine)
140
141 list(APPEND EXPORT_DEPENDENCIES
142 commonTestUtils_s
143- inference_engine_s
144- gmock)
145+ inference_engine_s)
146
147 addIeTarget(
148 NAME ${TARGET_NAME}
149diff --git a/inference-engine/thirdparty/CMakeLists.txt b/inference-engine/thirdparty/CMakeLists.txt
150index fa2a4d02d8..67d3b7ad05 100644
151--- a/inference-engine/thirdparty/CMakeLists.txt
152+++ b/inference-engine/thirdparty/CMakeLists.txt
153@@ -62,14 +62,13 @@ else()
154 endif()
155
156 add_subdirectory(stb_lib)
157-add_subdirectory(ade)
158 add_subdirectory(fluid/modules/gapi)
159
160-set_target_properties(ade fluid stb_image PROPERTIES FOLDER thirdparty)
161+set_target_properties(fluid stb_image PROPERTIES FOLDER thirdparty)
162
163 # developer package
164
165-ie_developer_export_targets(ade fluid)
166+ie_developer_export_targets(fluid)
167
168 if (NOT USE_SYSTEM_PUGIXML)
169 set_target_properties(pugixml PROPERTIES FOLDER thirdparty)
170--
1712.29.2
172
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch
deleted file mode 100644
index a4e58b8e..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cldNN-disable-Werror.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 65014a2703a6a3892fdebc86fe1c5a3a589dbf56 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:45:48 +0800
4Subject: [PATCH 2/5] cldNN: disable Werror
5
6Don't treat warnings as errors. This just leads to failures every time
7we upgrade the compiler.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 inference-engine/thirdparty/clDNN/CMakeLists.txt | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/inference-engine/thirdparty/clDNN/CMakeLists.txt b/inference-engine/thirdparty/clDNN/CMakeLists.txt
17index 4b444eca..8610b9b8 100644
18--- a/inference-engine/thirdparty/clDNN/CMakeLists.txt
19+++ b/inference-engine/thirdparty/clDNN/CMakeLists.txt
20@@ -770,7 +770,6 @@ foreach(__CLDNN_CompilerFlagName IN ITEMS "CMAKE_CXX_FLAGS" "CMAKE_C_FLAGS")
21 MultiProcessorCompilation
22 DeadCodeEliminate
23 ExtensionsEnabled
24- TreatWarnAsErrorEnabled
25 WarnLevel4
26 NoFastMath
27 StackProtector
28--
292.25.4
30
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch
new file mode 100644
index 00000000..8a1464d5
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch
@@ -0,0 +1,33 @@
1From 4a909a03b6dd336e7ea76e3f44d7cfb5d7e44798 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:49:35 +0530
4Subject: [PATCH 2/3] cmake: Fix overloaded-virtual error
5
6* Remove -Werror for:
7|git/src/plugins/intel_gpu/src/kernel_selector/jitter.h:129:28: error: 'virtual kernel_selector::JitDefinitions kernel_selector::JitConstant::GetDefinitions() const' was hidden [-Werror=overloaded-virtual=]
8| 129 | virtual JitDefinitions GetDefinitions() const = 0;
9| |
10
11Upstream-Status: Pending
12
13Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
14---
15 src/plugins/intel_gpu/CMakeLists.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt
19index 2f3d9127dde..2fd4f5c1b3c 100644
20--- a/src/plugins/intel_gpu/CMakeLists.txt
21+++ b/src/plugins/intel_gpu/CMakeLists.txt
22@@ -47,7 +47,7 @@ add_subdirectory(thirdparty)
23 include(thirdparty/cmake/rapidjson.cmake)
24
25 if(CMAKE_COMPILER_IS_GNUCXX)
26- ov_add_compiler_flags(-Werror)
27+ #ov_add_compiler_flags(-Werror)
28 endif()
29
30 add_subdirectory(src/runtime)
31--
322.34.1
33
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
deleted file mode 100644
index 52049eb0..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-inference-engine-installation-fixes.patch
+++ /dev/null
@@ -1,223 +0,0 @@
1From cb9a755218ff033c8c42e9dc46a845310a3331fa Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 11 Jun 2020 14:24:04 +0800
4Subject: [PATCH] cmake installation fixes
5
6Make sure that libraries/samples/binaries are installed correctly.
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 CMakeLists.txt | 14 --------------
11 cmake/developer_package.cmake | 10 ++++++----
12 .../samples/common/opencv_c_wraper/CMakeLists.txt | 2 ++
13 inference-engine/samples/CMakeLists.txt | 9 +++------
14 .../samples/common/format_reader/CMakeLists.txt | 2 ++
15 .../src/inference_engine/CMakeLists.txt | 4 ++--
16 .../src/vpu/myriad_plugin/CMakeLists.txt | 2 +-
17 inference-engine/tests/unit/cpu/CMakeLists.txt | 2 ++
18 .../tests/unit/inference_engine/CMakeLists.txt | 2 ++
19 inference-engine/tests/unit/vpu/CMakeLists.txt | 2 ++
20 inference-engine/tools/compile_tool/CMakeLists.txt | 2 +-
21 11 files changed, 23 insertions(+), 28 deletions(-)
22
23diff --git a/CMakeLists.txt b/CMakeLists.txt
24index 5c3585a3e9..2b8c99f862 100644
25--- a/CMakeLists.txt
26+++ b/CMakeLists.txt
27@@ -176,12 +176,8 @@ ie_shellcheck_process(DIRECTORY "${OpenVINO_MAIN_SOURCE_DIR}"
28
29 # install setupvars
30
31-ie_cpack_add_component(setupvars REQUIRED)
32
33 if(UNIX)
34- install(PROGRAMS scripts/setupvars/setupvars.sh
35- DESTINATION bin
36- COMPONENT setupvars)
37 elseif(WIN32)
38 install(PROGRAMS scripts/setupvars/setupvars.bat
39 DESTINATION bin
40@@ -191,22 +187,12 @@ endif()
41 # install install_dependencies
42
43 if(UNIX)
44- ie_cpack_add_component(install_dependencies REQUIRED)
45- install(DIRECTORY scripts/install_dependencies/
46- DESTINATION install_dependencies
47- COMPONENT install_dependencies)
48 endif()
49
50 # install files for demo
51
52-ie_cpack_add_component(demo_scripts REQUIRED DEPENDS core)
53
54 if(UNIX)
55- install(DIRECTORY scripts/demo/
56- DESTINATION deployment_tools/demo
57- COMPONENT demo_scripts
58- USE_SOURCE_PERMISSIONS
59- PATTERN *.bat EXCLUDE)
60 elseif(WIN32)
61 install(DIRECTORY scripts/demo/
62 DESTINATION deployment_tools/demo
63diff --git a/cmake/developer_package.cmake b/cmake/developer_package.cmake
64index cda7afd294..ec51636e96 100644
65--- a/cmake/developer_package.cmake
66+++ b/cmake/developer_package.cmake
67@@ -29,7 +29,9 @@ list(APPEND CMAKE_MODULE_PATH
68 include(CPackComponent)
69 unset(IE_CPACK_COMPONENTS_ALL CACHE)
70
71-set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
72+if (NOT DEFINED IE_CPACK_IE_DIR)
73+ set(IE_CPACK_IE_DIR deployment_tools/inference_engine)
74+endif()
75
76 # Search packages for the host system instead of packages for the target system
77 # in case of cross compilation these macros should be defined by the toolchain file
78@@ -55,8 +57,8 @@ function(ie_cpack_set_library_dir)
79 set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/bin/${ARCH_FOLDER}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
80 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH_FOLDER}/${CMAKE_BUILD_TYPE} PARENT_SCOPE)
81 else()
82- set(IE_CPACK_LIBRARY_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH_FOLDER} PARENT_SCOPE)
83- set(IE_CPACK_RUNTIME_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH_FOLDER} PARENT_SCOPE)
84+ set(IE_CPACK_LIBRARY_PATH ${CMAKE_INSTALL_LIBDIR} PARENT_SCOPE)
85+ set(IE_CPACK_RUNTIME_PATH ${CMAKE_INSTALL_BINDIR} PARENT_SCOPE)
86 set(IE_CPACK_ARCHIVE_PATH ${IE_CPACK_IE_DIR}/lib/${ARCH_FOLDER} PARENT_SCOPE)
87 endif()
88 endfunction()
89@@ -151,7 +153,7 @@ endif()
90
91 # allow to override default OUTPUT_ROOT root
92 if(NOT DEFINED OUTPUT_ROOT)
93- set(OUTPUT_ROOT ${OpenVINO_MAIN_SOURCE_DIR})
94+ set(OUTPUT_ROOT ${CMAKE_CURRENT_BINARY_DIR})
95 endif()
96
97 # Enable postfixes for Debug/Release builds
98diff --git a/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt b/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
99index b8d5ddf622..d086478f6d 100644
100--- a/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
101+++ b/inference-engine/ie_bridges/c/samples/common/opencv_c_wraper/CMakeLists.txt
102@@ -29,3 +29,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES FOLDER c_samples)
103 if(COMMAND add_cpplint_target)
104 add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
105 endif()
106+
107+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
108diff --git a/inference-engine/samples/CMakeLists.txt b/inference-engine/samples/CMakeLists.txt
109index 236c17e6af..22f410d1fd 100644
110--- a/inference-engine/samples/CMakeLists.txt
111+++ b/inference-engine/samples/CMakeLists.txt
112@@ -34,7 +34,7 @@ endif()
113
114 if(IE_MAIN_SOURCE_DIR)
115 # in case if samples are built from IE repo
116- set(IE_MAIN_SAMPLES_DIR ${OpenVINO_MAIN_SOURCE_DIR})
117+ set(IE_MAIN_SAMPLES_DIR ${CMAKE_BINARY_DIR})
118 # hint for find_package(InferenceEngine in the samples folder)
119 set(InferenceEngine_DIR "${CMAKE_BINARY_DIR}")
120 # hint for find_package(ngraph in the samples folder)
121@@ -118,11 +118,6 @@ set (HAVE_INTTYPES_H 1)
122 set (INTTYPES_FORMAT C99)
123 set (BUILD_TESTING OFF)
124
125-if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/thirdparty/gflags")
126- add_subdirectory(thirdparty/gflags)
127- set_target_properties(gflags_nothreads_static PROPERTIES FOLDER thirdparty)
128-endif()
129-
130 if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
131 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
132 endif()
133@@ -245,6 +240,8 @@ macro(ie_add_sample)
134 add_cpplint_target(${IE_SAMPLE_NAME}_cpplint FOR_TARGETS ${IE_SAMPLE_NAME}
135 CUSTOM_FILTERS ${custom_filters})
136 endif()
137+
138+ install(TARGETS ${IE_SAMPLE_NAME} DESTINATION bin)
139 endmacro()
140
141 # collect all samples subdirectories
142diff --git a/inference-engine/samples/common/format_reader/CMakeLists.txt b/inference-engine/samples/common/format_reader/CMakeLists.txt
143index 48dbed9f2b..76532fd047 100644
144--- a/inference-engine/samples/common/format_reader/CMakeLists.txt
145+++ b/inference-engine/samples/common/format_reader/CMakeLists.txt
146@@ -41,3 +41,5 @@ target_include_directories(${TARGET_NAME} PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}"
147
148 set_target_properties(${TARGET_NAME} PROPERTIES COMPILE_PDB_NAME ${TARGET_NAME}
149 FOLDER cpp_samples)
150+
151+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_LIBDIR})
152diff --git a/inference-engine/src/inference_engine/CMakeLists.txt b/inference-engine/src/inference_engine/CMakeLists.txt
153index 3bba22215e..b6f6b7b203 100644
154--- a/inference-engine/src/inference_engine/CMakeLists.txt
155+++ b/inference-engine/src/inference_engine/CMakeLists.txt
156@@ -229,8 +229,8 @@ install(TARGETS ${TARGET_NAME}
157 install(FILES "${OpenVINO_BINARY_DIR}/share/ie_parallel.cmake"
158 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig.cmake"
159 "${OpenVINO_BINARY_DIR}/share/InferenceEngineConfig-version.cmake"
160- DESTINATION ${IE_CPACK_IE_DIR}/share
161+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/InferenceEngine
162 COMPONENT core)
163 install(FILES $<TARGET_FILE_DIR:${TARGET_NAME}>/plugins.xml
164- DESTINATION ${IE_CPACK_RUNTIME_PATH}
165+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
166 COMPONENT core)
167diff --git a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
168index 889f2e6e66..67de9c3a32 100644
169--- a/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
170+++ b/inference-engine/src/vpu/myriad_plugin/CMakeLists.txt
171@@ -50,5 +50,5 @@ set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_REL
172 # install
173
174 install(FILES ${IE_MAIN_SOURCE_DIR}/thirdparty/movidius/mvnc/src/97-myriad-usbboot.rules
175- DESTINATION ${IE_CPACK_IE_DIR}/external
176+ DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d
177 COMPONENT myriad)
178diff --git a/inference-engine/tests/unit/cpu/CMakeLists.txt b/inference-engine/tests/unit/cpu/CMakeLists.txt
179index c9a92b4857..2b4fcc4d01 100644
180--- a/inference-engine/tests/unit/cpu/CMakeLists.txt
181+++ b/inference-engine/tests/unit/cpu/CMakeLists.txt
182@@ -25,3 +25,5 @@ addIeTargetTest(
183 ie_faster_build(${TARGET_NAME}
184 UNITY
185 )
186+
187+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
188diff --git a/inference-engine/tests/unit/inference_engine/CMakeLists.txt b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
189index 76cc67cca1..04ff11cc05 100644
190--- a/inference-engine/tests/unit/inference_engine/CMakeLists.txt
191+++ b/inference-engine/tests/unit/inference_engine/CMakeLists.txt
192@@ -26,3 +26,5 @@ addIeTargetTest(
193 LABELS
194 IE
195 )
196+
197+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
198diff --git a/inference-engine/tests/unit/vpu/CMakeLists.txt b/inference-engine/tests/unit/vpu/CMakeLists.txt
199index 215562f2af..215ec9f4fb 100644
200--- a/inference-engine/tests/unit/vpu/CMakeLists.txt
201+++ b/inference-engine/tests/unit/vpu/CMakeLists.txt
202@@ -35,3 +35,5 @@ addIeTargetTest(
203 VPU
204 MYRIAD
205 )
206+
207+install(TARGETS ${TARGET_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
208diff --git a/inference-engine/tools/compile_tool/CMakeLists.txt b/inference-engine/tools/compile_tool/CMakeLists.txt
209index 58614d3ced..9dfa068e4d 100644
210--- a/inference-engine/tools/compile_tool/CMakeLists.txt
211+++ b/inference-engine/tools/compile_tool/CMakeLists.txt
212@@ -49,7 +49,7 @@ add_cpplint_target(${TARGET_NAME}_cpplint FOR_TARGETS ${TARGET_NAME})
213 # install
214
215 install(TARGETS compile_tool
216- RUNTIME DESTINATION deployment_tools/tools/compile_tool
217+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
218 COMPONENT core)
219
220 install(FILES README.md
221--
2222.29.2
223
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch
new file mode 100644
index 00000000..bbdeaa2a
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch
@@ -0,0 +1,45 @@
1From 450d94b475460d1af32b207d0ced495794863f0d Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 29 Nov 2023 12:55:19 +0530
4Subject: [PATCH 3/3] protobuf: allow target protoc to be built
5
6We can run target binaries using a qemu wrapper so allow these to be
7built and run.
8
9Upstream-Status: Inappropriate
10
11Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
12---
13 cmake/developer_package/frontends/frontends.cmake | 2 +-
14 thirdparty/protobuf/CMakeLists.txt | 2 +-
15 2 files changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake
18index f3b5520d6d2..7579f638c5a 100644
19--- a/cmake/developer_package/frontends/frontends.cmake
20+++ b/cmake/developer_package/frontends/frontends.cmake
21@@ -163,7 +163,7 @@ macro(ov_add_frontend)
22 set(OUTPUT_PB_HEADER ${CMAKE_CURRENT_BINARY_DIR}/${relative_path}/${FILE_WE}.pb.h)
23 add_custom_command(
24 OUTPUT "${OUTPUT_PB_SRC}" "${OUTPUT_PB_HEADER}"
25- COMMAND ${PROTOC_EXECUTABLE} ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${protofiles_root_dir} ${proto_file}
26+ COMMAND protoc ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${protofiles_root_dir} ${proto_file}
27 DEPENDS ${PROTOC_DEPENDENCY} ${proto_file}
28 COMMENT "Running C++ protocol buffer compiler (${PROTOC_EXECUTABLE}) on ${proto_file_relative}"
29 VERBATIM
30diff --git a/thirdparty/protobuf/CMakeLists.txt b/thirdparty/protobuf/CMakeLists.txt
31index 15f32601f23..36853caf7dc 100644
32--- a/thirdparty/protobuf/CMakeLists.txt
33+++ b/thirdparty/protobuf/CMakeLists.txt
34@@ -31,7 +31,7 @@ unset(HAVE_ZLIB CACHE)
35 if(CMAKE_CROSSCOMPILING OR
36 (APPLE AND (HOST_X86_64 AND AARCH64)) OR
37 (MSVC AND (HOST_X86_64 AND (AARCH64 OR ARM))))
38- set(protobuf_BUILD_PROTOC_BINARIES OFF CACHE BOOL "Build protoc binaries" FORCE)
39+ set(protobuf_BUILD_PROTOC_BINARIES ON CACHE BOOL "Build protoc binaries" FORCE)
40 else()
41 set(protobuf_BUILD_PROTOC_BINARIES ON CACHE BOOL "Build protoc binaries" FORCE)
42 endif()
43--
442.34.1
45
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
deleted file mode 100644
index d4819077..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From aa515686548d74a68456b9ba7a295b6ae4be343a Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH] cldnn: fix inclusion of headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9
10---
11 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +-
12 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 +
13 .../thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
14 3 files changed, 3 insertions(+), 2 deletions(-)
15
16diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
17index 68ccf3217..c5b0ce6be 100644
18--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
20@@ -39,7 +39,7 @@
21 # pragma GCC system_header
22 #endif
23
24-#include <CL/cl2.hpp>
25+#include <cl2.hpp>
26
27 #ifdef __GNUC__
28 # pragma GCC diagnostic pop
29diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
30index 7e15abbed..46d43e0e5 100644
31--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
32+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
33@@ -31,6 +31,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
34 ${CMAKE_CURRENT_SOURCE_DIR}
35 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
36 ${CLDNN__IOCL_ICD_INCDIRS}
37+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
38 ${CLDNN_TOP_FOLDER})
39
40 set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_RELEASE ${ENABLE_LTO})
41diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
42index 97608c30a..3a04096c0 100644
43--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
44+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
45@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
46 typedef cl_va_api_device_source_intel cl_device_source_intel;
47 typedef cl_va_api_device_set_intel cl_device_set_intel;
48 #endif
49-#include <CL/cl_intel_planar_yuv.h>
50+#include <CL/cl_ext_intel.h>
51 #include "cl_intel_usm_defs.h"
52
53 #include <memory>