summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
deleted file mode 100644
index 2a2c8b87..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-dont-install-licenses-and-version-file.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1From a60710c910e6c995aef9dd36757bf040bf24acf5 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 9 Jun 2020 11:35:59 +0800
4Subject: [PATCH] don't install licenses and version
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 ngraph/CMakeLists.txt | 6 ++----
11 ngraph/test/runtime/CMakeLists.txt | 2 ++
12 2 files changed, 4 insertions(+), 4 deletions(-)
13
14diff --git a/ngraph/CMakeLists.txt b/ngraph/CMakeLists.txt
15index 99f32a6181..b90aa382b9 100644
16--- a/ngraph/CMakeLists.txt
17+++ b/ngraph/CMakeLists.txt
18@@ -490,7 +490,7 @@ if (NGRAPH_EXPORT_TARGETS_ENABLE)
19 install(EXPORT ngraphTargets
20 FILE ngraphTargets.cmake
21 NAMESPACE ngraph::
22- DESTINATION ${NGRAPH_COMPONENT_PREFIX}cmake
23+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
24 COMPONENT ngraph)
25
26 configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/cmake/share/ngraphConfig.cmake.in
27@@ -503,7 +503,7 @@ if (NGRAPH_EXPORT_TARGETS_ENABLE)
28
29 install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ngraphConfig.cmake
30 ${CMAKE_CURRENT_BINARY_DIR}/ngraphConfigVersion.cmake
31- DESTINATION ${NGRAPH_COMPONENT_PREFIX}cmake
32+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/ngraph
33 COMPONENT ngraph)
34 endif()
35
36@@ -518,5 +518,3 @@ add_subdirectory(test)
37 if (NGRAPH_PYTHON_BUILD_ENABLE)
38 add_subdirectory(python)
39 endif()
40-
41-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION DESTINATION "${NGRAPH_COMPONENT_PREFIX}." COMPONENT ngraph)
42diff --git a/ngraph/test/runtime/CMakeLists.txt b/ngraph/test/runtime/CMakeLists.txt
43index d27ea8090c..17a3843f7d 100644
44--- a/ngraph/test/runtime/CMakeLists.txt
45+++ b/ngraph/test/runtime/CMakeLists.txt
46@@ -80,3 +80,5 @@ target_include_directories(ngraph_backend PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
47
48 add_subdirectory(interpreter)
49 add_subdirectory(ie)
50+
51+install(TARGETS ngraph_backend DESTINATION ${NGRAPH_INSTALL_LIB})
52--
532.29.2
54