summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
deleted file mode 100644
index d4819077..00000000
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0005-cldnn-fix-inclusion-of-headers.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From aa515686548d74a68456b9ba7a295b6ae4be343a Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Wed, 10 Jun 2020 09:50:19 +0800
4Subject: [PATCH] cldnn: fix inclusion of headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9
10---
11 inference-engine/include/gpu/gpu_ocl_wrapper.hpp | 2 +-
12 inference-engine/src/cldnn_engine/CMakeLists.txt | 1 +
13 .../thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp | 2 +-
14 3 files changed, 3 insertions(+), 2 deletions(-)
15
16diff --git a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
17index 68ccf3217..c5b0ce6be 100644
18--- a/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
19+++ b/inference-engine/include/gpu/gpu_ocl_wrapper.hpp
20@@ -39,7 +39,7 @@
21 # pragma GCC system_header
22 #endif
23
24-#include <CL/cl2.hpp>
25+#include <cl2.hpp>
26
27 #ifdef __GNUC__
28 # pragma GCC diagnostic pop
29diff --git a/inference-engine/src/cldnn_engine/CMakeLists.txt b/inference-engine/src/cldnn_engine/CMakeLists.txt
30index 7e15abbed..46d43e0e5 100644
31--- a/inference-engine/src/cldnn_engine/CMakeLists.txt
32+++ b/inference-engine/src/cldnn_engine/CMakeLists.txt
33@@ -31,6 +31,7 @@ target_include_directories(${TARGET_NAME} PRIVATE
34 ${CMAKE_CURRENT_SOURCE_DIR}
35 $<TARGET_PROPERTY:inference_engine_transformations,INTERFACE_INCLUDE_DIRECTORIES>
36 ${CLDNN__IOCL_ICD_INCDIRS}
37+ ${CLDNN_TOP_FOLDER}/common/khronos_ocl_clhpp
38 ${CLDNN_TOP_FOLDER})
39
40 set_target_properties(${TARGET_NAME} PROPERTIES INTERPROCEDURAL_OPTIMIZATION_RELEASE ${ENABLE_LTO})
41diff --git a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
42index 97608c30a..3a04096c0 100644
43--- a/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
44+++ b/inference-engine/thirdparty/clDNN/common/khronos_ocl_clhpp/cl2_ext.hpp
45@@ -29,7 +29,7 @@ typedef cl_d3d11_device_set_khr cl_device_set_intel;
46 typedef cl_va_api_device_source_intel cl_device_source_intel;
47 typedef cl_va_api_device_set_intel cl_device_set_intel;
48 #endif
49-#include <CL/cl_intel_planar_yuv.h>
50+#include <CL/cl_ext_intel.h>
51 #include "cl_intel_usm_defs.h"
52
53 #include <memory>