summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-07-04 20:46:52 +0530
committerNaveen Saini <naveen.kumar.saini@intel.com>2023-07-13 09:38:58 +0800
commit7515d740e630eff194fc727a0d794200f6f337cf (patch)
treed49353df71d3f5c65b8abe95a031f7d16395e588 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parent1bf139602b0b338421aa52a66e9e87f89273139f (diff)
downloadmeta-intel-7515d740e630eff194fc727a0d794200f6f337cf.tar.gz
openvino-inference-engine: upgrade 2023.0.0 -> 2023.0.1
* Refresh patches. * Drop Protobuf change which disabled use of static protobuf libs from system. This is not needed anymore as we are now building Protobuf as bundled dependency. Release Notes: https://github.com/openvinotoolkit/openvino/releases/tag/2023.0.1 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch33
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch35
2 files changed, 21 insertions, 47 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
index 4157c846..9e1aa93c 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
@@ -28,12 +28,11 @@ https://gcc.gnu.org/gcc-13/porting_to.html
28 28
29Upstream-Status: Pending 29Upstream-Status: Pending
30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31
31--- 32---
32 src/inference/include/ie/ie_precision.hpp | 2 +- 33 src/inference/include/ie/ie_precision.hpp | 2 +-
33 src/plugins/intel_gpu/CMakeLists.txt | 6 +++--- 34 src/plugins/intel_gpu/CMakeLists.txt | 6 +++---
34 .../include/intel_gpu/graph/serialization/helpers.hpp | 1 + 35 2 files changed, 4 insertions(+), 4 deletions(-)
35 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 +
36 4 files changed, 6 insertions(+), 4 deletions(-)
37 36
38diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp 37diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp
39index 48bdd945b13..96c29b73159 100644 38index 48bdd945b13..96c29b73159 100644
@@ -65,30 +64,6 @@ index 948aecfcfec..a1b9783068b 100644
65 64
66 add_subdirectory(src/runtime) 65 add_subdirectory(src/runtime)
67 add_subdirectory(src/kernel_selector) 66 add_subdirectory(src/kernel_selector)
68diff --git a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
69index 391629baba2..40efe7011c6 100644
70--- a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
71+++ b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
72@@ -5,6 +5,7 @@
73 #pragma once
74 #include <utility>
75 #include <type_traits>
76+#include <cstdint>
77
78 namespace cldnn {
79 template <typename T>
80diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
81index 387a319cbe1..e2a7b1fc0fa 100644
82--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
83+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
84@@ -4,6 +4,7 @@
85
86 #pragma once
87
88+#include <cstdint>
89 #include <string>
90 #include <vector>
91 #include <tuple>
92-- 67--
932.34.1 682.34.1
94 69
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 4e3a4b02..8481dadc 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -1,27 +1,32 @@
1Yocto specific tweaks to the build process: 1Yocto specific tweaks to the build process:
2 2
3* Dont try to detect glibc version as that doesn't work when cross compiling. 3* Dont try to detect glibc version as that doesn't work when cross compiling.
4* Use shared protobuf and gflags libs. 4* Use shared protobuf and gflags libs.
5* Install sample binaries as well. 5* Install sample binaries as well.
6 6
7Upstream-Status: Inappropriate 7Upstream-Status: Inappropriate
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 cmake/developer_package/target_flags.cmake | 2 +-
11 samples/cpp/CMakeLists.txt | 6 +++---
12 thirdparty/CMakeLists.txt | 8 ++++----
13 3 files changed, 8 insertions(+), 8 deletions(-)
9 14
10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 15diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
11index 0a37c910ae8..44444970ce1 100644 16index ced8d519da3..505c1fa5b14 100644
12--- a/cmake/developer_package/target_flags.cmake 17--- a/cmake/developer_package/target_flags.cmake
13+++ b/cmake/developer_package/target_flags.cmake 18+++ b/cmake/developer_package/target_flags.cmake
14@@ -136,4 +136,4 @@ function(ov_glibc_version) 19@@ -145,4 +145,4 @@ function(ov_glibc_version)
15 endif() 20 endif()
16 endfunction() 21 endfunction()
17 22
18-ov_glibc_version() 23-ov_glibc_version()
19+#ov_glibc_version() 24+#ov_glibc_version()
20diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 25diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
21index d2a65618071..80133c4aeb6 100644 26index 37eb0250112..35ec6a3368a 100644
22--- a/samples/cpp/CMakeLists.txt 27--- a/samples/cpp/CMakeLists.txt
23+++ b/samples/cpp/CMakeLists.txt 28+++ b/samples/cpp/CMakeLists.txt
24@@ -221,9 +221,9 @@ macro(ie_add_sample) 29@@ -219,9 +219,9 @@ macro(ie_add_sample)
25 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 30 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
26 31
27 install(TARGETS ${IE_SAMPLE_NAME} 32 install(TARGETS ${IE_SAMPLE_NAME}
@@ -35,10 +40,10 @@ index d2a65618071..80133c4aeb6 100644
35 # create global target with all samples / demo apps 40 # create global target with all samples / demo apps
36 if(NOT TARGET ie_samples) 41 if(NOT TARGET ie_samples)
37diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 42diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
38index edbcb824f4b..9d24dcec560 100644 43index 95d80a6fbd4..963c9a5d60a 100644
39--- a/thirdparty/CMakeLists.txt 44--- a/thirdparty/CMakeLists.txt
40+++ b/thirdparty/CMakeLists.txt 45+++ b/thirdparty/CMakeLists.txt
41@@ -291,11 +291,11 @@ endif() 46@@ -353,11 +353,11 @@ endif()
42 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 47 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
43 # on Windows and macOS we don't use gflags, because will be dynamically linked 48 # on Windows and macOS we don't use gflags, because will be dynamically linked
44 if(CMAKE_HOST_LINUX AND LINUX) 49 if(CMAKE_HOST_LINUX AND LINUX)
@@ -52,14 +57,8 @@ index edbcb824f4b..9d24dcec560 100644
52+ #set(gflag_component nothreads_static) 57+ #set(gflag_component nothreads_static)
53+ #endif() 58+ #endif()
54 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 59 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
55 endif() 60 else()
56 61 # conan case
57@@ -352,7 +352,7 @@ endif() 62--
58 632.34.1
59 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND) 64
60 if(ENABLE_SYSTEM_PROTOBUF)
61- set(Protobuf_USE_STATIC_LIBS ON)
62+ #set(Protobuf_USE_STATIC_LIBS ON)
63 if(CMAKE_VERBOSE_MAKEFILE)
64 set(Protobuf_DEBUG ON)
65 endif()