summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch35
1 files changed, 17 insertions, 18 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 4e3a4b02..8481dadc 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -1,27 +1,32 @@
1Yocto specific tweaks to the build process: 1Yocto specific tweaks to the build process:
2 2
3* Dont try to detect glibc version as that doesn't work when cross compiling. 3* Dont try to detect glibc version as that doesn't work when cross compiling.
4* Use shared protobuf and gflags libs. 4* Use shared protobuf and gflags libs.
5* Install sample binaries as well. 5* Install sample binaries as well.
6 6
7Upstream-Status: Inappropriate 7Upstream-Status: Inappropriate
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9---
10 cmake/developer_package/target_flags.cmake | 2 +-
11 samples/cpp/CMakeLists.txt | 6 +++---
12 thirdparty/CMakeLists.txt | 8 ++++----
13 3 files changed, 8 insertions(+), 8 deletions(-)
9 14
10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 15diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
11index 0a37c910ae8..44444970ce1 100644 16index ced8d519da3..505c1fa5b14 100644
12--- a/cmake/developer_package/target_flags.cmake 17--- a/cmake/developer_package/target_flags.cmake
13+++ b/cmake/developer_package/target_flags.cmake 18+++ b/cmake/developer_package/target_flags.cmake
14@@ -136,4 +136,4 @@ function(ov_glibc_version) 19@@ -145,4 +145,4 @@ function(ov_glibc_version)
15 endif() 20 endif()
16 endfunction() 21 endfunction()
17 22
18-ov_glibc_version() 23-ov_glibc_version()
19+#ov_glibc_version() 24+#ov_glibc_version()
20diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 25diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
21index d2a65618071..80133c4aeb6 100644 26index 37eb0250112..35ec6a3368a 100644
22--- a/samples/cpp/CMakeLists.txt 27--- a/samples/cpp/CMakeLists.txt
23+++ b/samples/cpp/CMakeLists.txt 28+++ b/samples/cpp/CMakeLists.txt
24@@ -221,9 +221,9 @@ macro(ie_add_sample) 29@@ -219,9 +219,9 @@ macro(ie_add_sample)
25 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 30 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
26 31
27 install(TARGETS ${IE_SAMPLE_NAME} 32 install(TARGETS ${IE_SAMPLE_NAME}
@@ -35,10 +40,10 @@ index d2a65618071..80133c4aeb6 100644
35 # create global target with all samples / demo apps 40 # create global target with all samples / demo apps
36 if(NOT TARGET ie_samples) 41 if(NOT TARGET ie_samples)
37diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 42diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
38index edbcb824f4b..9d24dcec560 100644 43index 95d80a6fbd4..963c9a5d60a 100644
39--- a/thirdparty/CMakeLists.txt 44--- a/thirdparty/CMakeLists.txt
40+++ b/thirdparty/CMakeLists.txt 45+++ b/thirdparty/CMakeLists.txt
41@@ -291,11 +291,11 @@ endif() 46@@ -353,11 +353,11 @@ endif()
42 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 47 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
43 # on Windows and macOS we don't use gflags, because will be dynamically linked 48 # on Windows and macOS we don't use gflags, because will be dynamically linked
44 if(CMAKE_HOST_LINUX AND LINUX) 49 if(CMAKE_HOST_LINUX AND LINUX)
@@ -52,14 +57,8 @@ index edbcb824f4b..9d24dcec560 100644
52+ #set(gflag_component nothreads_static) 57+ #set(gflag_component nothreads_static)
53+ #endif() 58+ #endif()
54 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 59 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
55 endif() 60 else()
56 61 # conan case
57@@ -352,7 +352,7 @@ endif() 62--
58 632.34.1
59 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND) 64
60 if(ENABLE_SYSTEM_PROTOBUF)
61- set(Protobuf_USE_STATIC_LIBS ON)
62+ #set(Protobuf_USE_STATIC_LIBS ON)
63 if(CMAKE_VERBOSE_MAKEFILE)
64 set(Protobuf_DEBUG ON)
65 endif()