summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch33
1 files changed, 4 insertions, 29 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
index 4157c846..9e1aa93c 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
@@ -28,12 +28,11 @@ https://gcc.gnu.org/gcc-13/porting_to.html
28 28
29Upstream-Status: Pending 29Upstream-Status: Pending
30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31
31--- 32---
32 src/inference/include/ie/ie_precision.hpp | 2 +- 33 src/inference/include/ie/ie_precision.hpp | 2 +-
33 src/plugins/intel_gpu/CMakeLists.txt | 6 +++--- 34 src/plugins/intel_gpu/CMakeLists.txt | 6 +++---
34 .../include/intel_gpu/graph/serialization/helpers.hpp | 1 + 35 2 files changed, 4 insertions(+), 4 deletions(-)
35 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 +
36 4 files changed, 6 insertions(+), 4 deletions(-)
37 36
38diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp 37diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp
39index 48bdd945b13..96c29b73159 100644 38index 48bdd945b13..96c29b73159 100644
@@ -65,30 +64,6 @@ index 948aecfcfec..a1b9783068b 100644
65 64
66 add_subdirectory(src/runtime) 65 add_subdirectory(src/runtime)
67 add_subdirectory(src/kernel_selector) 66 add_subdirectory(src/kernel_selector)
68diff --git a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
69index 391629baba2..40efe7011c6 100644
70--- a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
71+++ b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
72@@ -5,6 +5,7 @@
73 #pragma once
74 #include <utility>
75 #include <type_traits>
76+#include <cstdint>
77
78 namespace cldnn {
79 template <typename T>
80diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
81index 387a319cbe1..e2a7b1fc0fa 100644
82--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
83+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
84@@ -4,6 +4,7 @@
85
86 #pragma once
87
88+#include <cstdint>
89 #include <string>
90 #include <vector>
91 #include <tuple>
92-- 67--
932.34.1 682.34.1
94 69