summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-06-08 12:28:23 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2023-06-09 10:52:17 +0800
commit348511101c7095fef20aa46e21104e98bdaf44ba (patch)
tree29d72d9e924c310db1338ee6f0d2815de2fb48f9 /dynamic-layers/openembedded-layer/recipes-support/opencv/files
parenteb696e99ff8c5be4f9b181da9f134499d96760e4 (diff)
downloadmeta-intel-348511101c7095fef20aa46e21104e98bdaf44ba.tar.gz
openvino-inference-engine: upgrade 2022.3.0 -> 2023.0.0
* OpenVINO no longer supports vpu so remove the vpu PACKAGECONFIG and references. * Now allows snappy compression to be used for TF frontend so allow system installed snappy. * Flatbuffers is now needed for TF Lite frontend. * Refresh patches. Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch64
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch46
2 files changed, 31 insertions, 79 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
index 7089bc9c..4157c846 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
@@ -1,4 +1,4 @@
1From aac55921864fa91fe8e394a25fc565f28ae5fc64 Mon Sep 17 00:00:00 2001 1From f8ad3f859aadc6c81ccc667eee1439cc2e6113cf Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:31:09 +0800 3Date: Tue, 30 May 2023 09:31:09 +0800
4Subject: [PATCH] fix build with gcc13 4Subject: [PATCH] fix build with gcc13
@@ -29,50 +29,12 @@ https://gcc.gnu.org/gcc-13/porting_to.html
29Upstream-Status: Pending 29Upstream-Status: Pending
30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31--- 31---
32 src/common/itt/include/openvino/itt.hpp | 1 +
33 src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | 1 +
34 src/common/util/include/openvino/util/file_util.hpp | 1 +
35 src/inference/include/ie/ie_precision.hpp | 2 +- 32 src/inference/include/ie/ie_precision.hpp | 2 +-
36 src/plugins/intel_gpu/CMakeLists.txt | 6 +++--- 33 src/plugins/intel_gpu/CMakeLists.txt | 6 +++---
34 .../include/intel_gpu/graph/serialization/helpers.hpp | 1 +
37 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 + 35 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 +
38 6 files changed, 8 insertions(+), 4 deletions(-) 36 4 files changed, 6 insertions(+), 4 deletions(-)
39 37
40diff --git a/src/common/itt/include/openvino/itt.hpp b/src/common/itt/include/openvino/itt.hpp
41index c978ca1b138..f01d59a652a 100644
42--- a/src/common/itt/include/openvino/itt.hpp
43+++ b/src/common/itt/include/openvino/itt.hpp
44@@ -8,6 +8,7 @@
45 */
46
47 #pragma once
48+#include <cstdint>
49 #include <openvino/function_name.hpp>
50 #include <openvino/util/pp.hpp>
51 #include <string>
52diff --git a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
53index dfbb182b7a0..0887cc60e34 100644
54--- a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
55+++ b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
56@@ -8,6 +8,7 @@
57 # error non standalone GAPI
58 # endif
59
60+#include <cstdint>
61 #include <tuple>
62
63 #include <opencv2/gapi/opencv_includes.hpp>
64diff --git a/src/common/util/include/openvino/util/file_util.hpp b/src/common/util/include/openvino/util/file_util.hpp
65index d2f2e00ff60..88e641526ab 100644
66--- a/src/common/util/include/openvino/util/file_util.hpp
67+++ b/src/common/util/include/openvino/util/file_util.hpp
68@@ -4,6 +4,7 @@
69
70 #pragma once
71
72+#include <cstdint>
73 #include <fstream>
74 #include <functional>
75 #include <string>
76diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp 38diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp
77index 48bdd945b13..96c29b73159 100644 39index 48bdd945b13..96c29b73159 100644
78--- a/src/inference/include/ie/ie_precision.hpp 40--- a/src/inference/include/ie/ie_precision.hpp
@@ -87,10 +49,10 @@ index 48bdd945b13..96c29b73159 100644
87 } 49 }
88 50
89diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt 51diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt
90index ab4d7618c30..4c93024eb3c 100644 52index 948aecfcfec..a1b9783068b 100644
91--- a/src/plugins/intel_gpu/CMakeLists.txt 53--- a/src/plugins/intel_gpu/CMakeLists.txt
92+++ b/src/plugins/intel_gpu/CMakeLists.txt 54+++ b/src/plugins/intel_gpu/CMakeLists.txt
93@@ -34,9 +34,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include") 55@@ -36,9 +36,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
94 56
95 add_subdirectory(thirdparty) 57 add_subdirectory(thirdparty)
96 58
@@ -103,8 +65,20 @@ index ab4d7618c30..4c93024eb3c 100644
103 65
104 add_subdirectory(src/runtime) 66 add_subdirectory(src/runtime)
105 add_subdirectory(src/kernel_selector) 67 add_subdirectory(src/kernel_selector)
68diff --git a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
69index 391629baba2..40efe7011c6 100644
70--- a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
71+++ b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
72@@ -5,6 +5,7 @@
73 #pragma once
74 #include <utility>
75 #include <type_traits>
76+#include <cstdint>
77
78 namespace cldnn {
79 template <typename T>
106diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp 80diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
107index 0c5a7177d30..7119417185c 100644 81index 387a319cbe1..e2a7b1fc0fa 100644
108--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp 82--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
109+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp 83+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
110@@ -4,6 +4,7 @@ 84@@ -4,6 +4,7 @@
@@ -116,5 +90,5 @@ index 0c5a7177d30..7119417185c 100644
116 #include <vector> 90 #include <vector>
117 #include <tuple> 91 #include <tuple>
118-- 92--
1192.37.3 932.34.1
120 94
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 86ed2a96..4e3a4b02 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -8,31 +8,20 @@ Upstream-Status: Inappropriate
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9 9
10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
11index e6c72540288..fec9996db14 100644 11index 0a37c910ae8..44444970ce1 100644
12--- a/cmake/developer_package/target_flags.cmake 12--- a/cmake/developer_package/target_flags.cmake
13+++ b/cmake/developer_package/target_flags.cmake 13+++ b/cmake/developer_package/target_flags.cmake
14@@ -123,4 +123,4 @@ function(ov_glibc_version) 14@@ -136,4 +136,4 @@ function(ov_glibc_version)
15 endif() 15 endif()
16 endfunction() 16 endfunction()
17 17
18-ov_glibc_version() 18-ov_glibc_version()
19+#ov_glibc_version() 19+#ov_glibc_version()
20diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
21index 40c29d3c297..f6800592de9 100644
22--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
23+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
24@@ -32,5 +32,4 @@ endif()
25 install(
26 TARGETS ${TARGET_NAME}
27 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
28- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
29-)
30+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin)
31diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 20diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
32index 1fe54c602e8..01c86d418d9 100644 21index d2a65618071..80133c4aeb6 100644
33--- a/samples/cpp/CMakeLists.txt 22--- a/samples/cpp/CMakeLists.txt
34+++ b/samples/cpp/CMakeLists.txt 23+++ b/samples/cpp/CMakeLists.txt
35@@ -230,9 +230,8 @@ macro(ie_add_sample) 24@@ -221,9 +221,9 @@ macro(ie_add_sample)
36 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 25 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
37 26
38 install(TARGETS ${IE_SAMPLE_NAME} 27 install(TARGETS ${IE_SAMPLE_NAME}
@@ -41,42 +30,31 @@ index 1fe54c602e8..01c86d418d9 100644
41- EXCLUDE_FROM_ALL) 30- EXCLUDE_FROM_ALL)
42+ DESTINATION ${CMAKE_INSTALL_BINDIR} 31+ DESTINATION ${CMAKE_INSTALL_BINDIR}
43+ COMPONENT samples_bin) 32+ COMPONENT samples_bin)
33+
44 34
45 # create global target with all samples / demo apps 35 # create global target with all samples / demo apps
46 if(NOT TARGET ie_samples) 36 if(NOT TARGET ie_samples)
47diff --git a/samples/cpp/common/format_reader/CMakeLists.txt b/samples/cpp/common/format_reader/CMakeLists.txt
48index 7c07bf07dbb..4cd566749e5 100644
49--- a/samples/cpp/common/format_reader/CMakeLists.txt
50+++ b/samples/cpp/common/format_reader/CMakeLists.txt
51@@ -44,5 +44,5 @@ endif()
52 install(
53 TARGETS ${TARGET_NAME}
54 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
55- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
56+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin
57 )
58diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 37diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
59index cf2863438c7..3ec5c5ed86b 100644 38index edbcb824f4b..9d24dcec560 100644
60--- a/thirdparty/CMakeLists.txt 39--- a/thirdparty/CMakeLists.txt
61+++ b/thirdparty/CMakeLists.txt 40+++ b/thirdparty/CMakeLists.txt
62@@ -268,11 +268,11 @@ endif() 41@@ -291,11 +291,11 @@ endif()
63
64 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 42 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
65 if(LINUX) 43 # on Windows and macOS we don't use gflags, because will be dynamically linked
44 if(CMAKE_HOST_LINUX AND LINUX)
66- if(OV_OS_RHEL) 45- if(OV_OS_RHEL)
67- set(gflag_component nothreads_shared) 46+ #if(OV_OS_RHEL)
47 set(gflag_component nothreads_shared)
68- elseif(OV_OS_DEBIAN) 48- elseif(OV_OS_DEBIAN)
69- set(gflag_component nothreads_static) 49- set(gflag_component nothreads_static)
70- endif() 50- endif()
71+ #if(OV_OS_RHEL)
72+ set(gflag_component nothreads_shared)
73+ #elseif(OV_OS_DEBIAN) 51+ #elseif(OV_OS_DEBIAN)
74+ #set(gflag_component nothreads_static) 52+ #set(gflag_component nothreads_static)
75+ #endif() 53+ #endif()
76 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 54 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
77 endif() 55 endif()
78 56
79@@ -329,7 +329,7 @@ endif() 57@@ -352,7 +352,7 @@ endif()
80 58
81 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND) 59 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND)
82 if(ENABLE_SYSTEM_PROTOBUF) 60 if(ENABLE_SYSTEM_PROTOBUF)