summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch46
1 files changed, 12 insertions, 34 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 86ed2a96..4e3a4b02 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -8,31 +8,20 @@ Upstream-Status: Inappropriate
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9 9
10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
11index e6c72540288..fec9996db14 100644 11index 0a37c910ae8..44444970ce1 100644
12--- a/cmake/developer_package/target_flags.cmake 12--- a/cmake/developer_package/target_flags.cmake
13+++ b/cmake/developer_package/target_flags.cmake 13+++ b/cmake/developer_package/target_flags.cmake
14@@ -123,4 +123,4 @@ function(ov_glibc_version) 14@@ -136,4 +136,4 @@ function(ov_glibc_version)
15 endif() 15 endif()
16 endfunction() 16 endfunction()
17 17
18-ov_glibc_version() 18-ov_glibc_version()
19+#ov_glibc_version() 19+#ov_glibc_version()
20diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
21index 40c29d3c297..f6800592de9 100644
22--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
23+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
24@@ -32,5 +32,4 @@ endif()
25 install(
26 TARGETS ${TARGET_NAME}
27 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
28- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
29-)
30+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin)
31diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 20diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
32index 1fe54c602e8..01c86d418d9 100644 21index d2a65618071..80133c4aeb6 100644
33--- a/samples/cpp/CMakeLists.txt 22--- a/samples/cpp/CMakeLists.txt
34+++ b/samples/cpp/CMakeLists.txt 23+++ b/samples/cpp/CMakeLists.txt
35@@ -230,9 +230,8 @@ macro(ie_add_sample) 24@@ -221,9 +221,9 @@ macro(ie_add_sample)
36 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 25 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
37 26
38 install(TARGETS ${IE_SAMPLE_NAME} 27 install(TARGETS ${IE_SAMPLE_NAME}
@@ -41,42 +30,31 @@ index 1fe54c602e8..01c86d418d9 100644
41- EXCLUDE_FROM_ALL) 30- EXCLUDE_FROM_ALL)
42+ DESTINATION ${CMAKE_INSTALL_BINDIR} 31+ DESTINATION ${CMAKE_INSTALL_BINDIR}
43+ COMPONENT samples_bin) 32+ COMPONENT samples_bin)
33+
44 34
45 # create global target with all samples / demo apps 35 # create global target with all samples / demo apps
46 if(NOT TARGET ie_samples) 36 if(NOT TARGET ie_samples)
47diff --git a/samples/cpp/common/format_reader/CMakeLists.txt b/samples/cpp/common/format_reader/CMakeLists.txt
48index 7c07bf07dbb..4cd566749e5 100644
49--- a/samples/cpp/common/format_reader/CMakeLists.txt
50+++ b/samples/cpp/common/format_reader/CMakeLists.txt
51@@ -44,5 +44,5 @@ endif()
52 install(
53 TARGETS ${TARGET_NAME}
54 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
55- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
56+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin
57 )
58diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 37diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
59index cf2863438c7..3ec5c5ed86b 100644 38index edbcb824f4b..9d24dcec560 100644
60--- a/thirdparty/CMakeLists.txt 39--- a/thirdparty/CMakeLists.txt
61+++ b/thirdparty/CMakeLists.txt 40+++ b/thirdparty/CMakeLists.txt
62@@ -268,11 +268,11 @@ endif() 41@@ -291,11 +291,11 @@ endif()
63
64 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 42 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
65 if(LINUX) 43 # on Windows and macOS we don't use gflags, because will be dynamically linked
44 if(CMAKE_HOST_LINUX AND LINUX)
66- if(OV_OS_RHEL) 45- if(OV_OS_RHEL)
67- set(gflag_component nothreads_shared) 46+ #if(OV_OS_RHEL)
47 set(gflag_component nothreads_shared)
68- elseif(OV_OS_DEBIAN) 48- elseif(OV_OS_DEBIAN)
69- set(gflag_component nothreads_static) 49- set(gflag_component nothreads_static)
70- endif() 50- endif()
71+ #if(OV_OS_RHEL)
72+ set(gflag_component nothreads_shared)
73+ #elseif(OV_OS_DEBIAN) 51+ #elseif(OV_OS_DEBIAN)
74+ #set(gflag_component nothreads_static) 52+ #set(gflag_component nothreads_static)
75+ #endif() 53+ #endif()
76 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 54 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
77 endif() 55 endif()
78 56
79@@ -329,7 +329,7 @@ endif() 57@@ -352,7 +352,7 @@ endif()
80 58
81 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND) 59 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND)
82 if(ENABLE_SYSTEM_PROTOBUF) 60 if(ENABLE_SYSTEM_PROTOBUF)