summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2023-06-08 12:28:23 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2023-06-09 10:52:17 +0800
commit348511101c7095fef20aa46e21104e98bdaf44ba (patch)
tree29d72d9e924c310db1338ee6f0d2815de2fb48f9 /dynamic-layers
parenteb696e99ff8c5be4f9b181da9f134499d96760e4 (diff)
downloadmeta-intel-348511101c7095fef20aa46e21104e98bdaf44ba.tar.gz
openvino-inference-engine: upgrade 2022.3.0 -> 2023.0.0
* OpenVINO no longer supports vpu so remove the vpu PACKAGECONFIG and references. * Now allows snappy compression to be used for TF frontend so allow system installed snappy. * Flatbuffers is now needed for TF Lite frontend. * Refresh patches. Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch64
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch46
-rw-r--r--dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.0.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb)30
3 files changed, 44 insertions, 96 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
index 7089bc9c..4157c846 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch
@@ -1,4 +1,4 @@
1From aac55921864fa91fe8e394a25fc565f28ae5fc64 Mon Sep 17 00:00:00 2001 1From f8ad3f859aadc6c81ccc667eee1439cc2e6113cf Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com> 2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:31:09 +0800 3Date: Tue, 30 May 2023 09:31:09 +0800
4Subject: [PATCH] fix build with gcc13 4Subject: [PATCH] fix build with gcc13
@@ -29,50 +29,12 @@ https://gcc.gnu.org/gcc-13/porting_to.html
29Upstream-Status: Pending 29Upstream-Status: Pending
30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 30Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
31--- 31---
32 src/common/itt/include/openvino/itt.hpp | 1 +
33 src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | 1 +
34 src/common/util/include/openvino/util/file_util.hpp | 1 +
35 src/inference/include/ie/ie_precision.hpp | 2 +- 32 src/inference/include/ie/ie_precision.hpp | 2 +-
36 src/plugins/intel_gpu/CMakeLists.txt | 6 +++--- 33 src/plugins/intel_gpu/CMakeLists.txt | 6 +++---
34 .../include/intel_gpu/graph/serialization/helpers.hpp | 1 +
37 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 + 35 .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 +
38 6 files changed, 8 insertions(+), 4 deletions(-) 36 4 files changed, 6 insertions(+), 4 deletions(-)
39 37
40diff --git a/src/common/itt/include/openvino/itt.hpp b/src/common/itt/include/openvino/itt.hpp
41index c978ca1b138..f01d59a652a 100644
42--- a/src/common/itt/include/openvino/itt.hpp
43+++ b/src/common/itt/include/openvino/itt.hpp
44@@ -8,6 +8,7 @@
45 */
46
47 #pragma once
48+#include <cstdint>
49 #include <openvino/function_name.hpp>
50 #include <openvino/util/pp.hpp>
51 #include <string>
52diff --git a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
53index dfbb182b7a0..0887cc60e34 100644
54--- a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
55+++ b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp
56@@ -8,6 +8,7 @@
57 # error non standalone GAPI
58 # endif
59
60+#include <cstdint>
61 #include <tuple>
62
63 #include <opencv2/gapi/opencv_includes.hpp>
64diff --git a/src/common/util/include/openvino/util/file_util.hpp b/src/common/util/include/openvino/util/file_util.hpp
65index d2f2e00ff60..88e641526ab 100644
66--- a/src/common/util/include/openvino/util/file_util.hpp
67+++ b/src/common/util/include/openvino/util/file_util.hpp
68@@ -4,6 +4,7 @@
69
70 #pragma once
71
72+#include <cstdint>
73 #include <fstream>
74 #include <functional>
75 #include <string>
76diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp 38diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp
77index 48bdd945b13..96c29b73159 100644 39index 48bdd945b13..96c29b73159 100644
78--- a/src/inference/include/ie/ie_precision.hpp 40--- a/src/inference/include/ie/ie_precision.hpp
@@ -87,10 +49,10 @@ index 48bdd945b13..96c29b73159 100644
87 } 49 }
88 50
89diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt 51diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt
90index ab4d7618c30..4c93024eb3c 100644 52index 948aecfcfec..a1b9783068b 100644
91--- a/src/plugins/intel_gpu/CMakeLists.txt 53--- a/src/plugins/intel_gpu/CMakeLists.txt
92+++ b/src/plugins/intel_gpu/CMakeLists.txt 54+++ b/src/plugins/intel_gpu/CMakeLists.txt
93@@ -34,9 +34,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include") 55@@ -36,9 +36,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
94 56
95 add_subdirectory(thirdparty) 57 add_subdirectory(thirdparty)
96 58
@@ -103,8 +65,20 @@ index ab4d7618c30..4c93024eb3c 100644
103 65
104 add_subdirectory(src/runtime) 66 add_subdirectory(src/runtime)
105 add_subdirectory(src/kernel_selector) 67 add_subdirectory(src/kernel_selector)
68diff --git a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
69index 391629baba2..40efe7011c6 100644
70--- a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
71+++ b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp
72@@ -5,6 +5,7 @@
73 #pragma once
74 #include <utility>
75 #include <type_traits>
76+#include <cstdint>
77
78 namespace cldnn {
79 template <typename T>
106diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp 80diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
107index 0c5a7177d30..7119417185c 100644 81index 387a319cbe1..e2a7b1fc0fa 100644
108--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp 82--- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
109+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp 83+++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp
110@@ -4,6 +4,7 @@ 84@@ -4,6 +4,7 @@
@@ -116,5 +90,5 @@ index 0c5a7177d30..7119417185c 100644
116 #include <vector> 90 #include <vector>
117 #include <tuple> 91 #include <tuple>
118-- 92--
1192.37.3 932.34.1
120 94
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
index 86ed2a96..4e3a4b02 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build.patch
@@ -8,31 +8,20 @@ Upstream-Status: Inappropriate
8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> 8Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
9 9
10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake 10diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake
11index e6c72540288..fec9996db14 100644 11index 0a37c910ae8..44444970ce1 100644
12--- a/cmake/developer_package/target_flags.cmake 12--- a/cmake/developer_package/target_flags.cmake
13+++ b/cmake/developer_package/target_flags.cmake 13+++ b/cmake/developer_package/target_flags.cmake
14@@ -123,4 +123,4 @@ function(ov_glibc_version) 14@@ -136,4 +136,4 @@ function(ov_glibc_version)
15 endif() 15 endif()
16 endfunction() 16 endfunction()
17 17
18-ov_glibc_version() 18-ov_glibc_version()
19+#ov_glibc_version() 19+#ov_glibc_version()
20diff --git a/samples/c/common/opencv_c_wrapper/CMakeLists.txt b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
21index 40c29d3c297..f6800592de9 100644
22--- a/samples/c/common/opencv_c_wrapper/CMakeLists.txt
23+++ b/samples/c/common/opencv_c_wrapper/CMakeLists.txt
24@@ -32,5 +32,4 @@ endif()
25 install(
26 TARGETS ${TARGET_NAME}
27 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
28- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
29-)
30+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin)
31diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt 20diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt
32index 1fe54c602e8..01c86d418d9 100644 21index d2a65618071..80133c4aeb6 100644
33--- a/samples/cpp/CMakeLists.txt 22--- a/samples/cpp/CMakeLists.txt
34+++ b/samples/cpp/CMakeLists.txt 23+++ b/samples/cpp/CMakeLists.txt
35@@ -230,9 +230,8 @@ macro(ie_add_sample) 24@@ -221,9 +221,9 @@ macro(ie_add_sample)
36 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES}) 25 target_link_libraries(${IE_SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${IE_SAMPLE_DEPENDENCIES})
37 26
38 install(TARGETS ${IE_SAMPLE_NAME} 27 install(TARGETS ${IE_SAMPLE_NAME}
@@ -41,42 +30,31 @@ index 1fe54c602e8..01c86d418d9 100644
41- EXCLUDE_FROM_ALL) 30- EXCLUDE_FROM_ALL)
42+ DESTINATION ${CMAKE_INSTALL_BINDIR} 31+ DESTINATION ${CMAKE_INSTALL_BINDIR}
43+ COMPONENT samples_bin) 32+ COMPONENT samples_bin)
33+
44 34
45 # create global target with all samples / demo apps 35 # create global target with all samples / demo apps
46 if(NOT TARGET ie_samples) 36 if(NOT TARGET ie_samples)
47diff --git a/samples/cpp/common/format_reader/CMakeLists.txt b/samples/cpp/common/format_reader/CMakeLists.txt
48index 7c07bf07dbb..4cd566749e5 100644
49--- a/samples/cpp/common/format_reader/CMakeLists.txt
50+++ b/samples/cpp/common/format_reader/CMakeLists.txt
51@@ -44,5 +44,5 @@ endif()
52 install(
53 TARGETS ${TARGET_NAME}
54 RUNTIME DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
55- LIBRARY DESTINATION samples_bin/ COMPONENT samples_bin EXCLUDE_FROM_ALL
56+ LIBRARY DESTINATION ${IE_CPACK_LIBRARY_PATH} COMPONENT samples_bin
57 )
58diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt 37diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
59index cf2863438c7..3ec5c5ed86b 100644 38index edbcb824f4b..9d24dcec560 100644
60--- a/thirdparty/CMakeLists.txt 39--- a/thirdparty/CMakeLists.txt
61+++ b/thirdparty/CMakeLists.txt 40+++ b/thirdparty/CMakeLists.txt
62@@ -268,11 +268,11 @@ endif() 41@@ -291,11 +291,11 @@ endif()
63
64 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS) 42 if(ENABLE_SAMPLES OR ENABLE_COMPILE_TOOL OR ENABLE_TESTS)
65 if(LINUX) 43 # on Windows and macOS we don't use gflags, because will be dynamically linked
44 if(CMAKE_HOST_LINUX AND LINUX)
66- if(OV_OS_RHEL) 45- if(OV_OS_RHEL)
67- set(gflag_component nothreads_shared) 46+ #if(OV_OS_RHEL)
47 set(gflag_component nothreads_shared)
68- elseif(OV_OS_DEBIAN) 48- elseif(OV_OS_DEBIAN)
69- set(gflag_component nothreads_static) 49- set(gflag_component nothreads_static)
70- endif() 50- endif()
71+ #if(OV_OS_RHEL)
72+ set(gflag_component nothreads_shared)
73+ #elseif(OV_OS_DEBIAN) 51+ #elseif(OV_OS_DEBIAN)
74+ #set(gflag_component nothreads_static) 52+ #set(gflag_component nothreads_static)
75+ #endif() 53+ #endif()
76 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component}) 54 find_package(gflags QUIET OPTIONAL_COMPONENTS ${gflag_component})
77 endif() 55 endif()
78 56
79@@ -329,7 +329,7 @@ endif() 57@@ -352,7 +352,7 @@ endif()
80 58
81 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND) 59 if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND)
82 if(ENABLE_SYSTEM_PROTOBUF) 60 if(ENABLE_SYSTEM_PROTOBUF)
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.0.0.bb
index 87af47ee..193e33a1 100644
--- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2022.3.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.0.0.bb
@@ -4,9 +4,7 @@ DESCRIPTION = "This toolkit allows developers to deploy pre-trained \
4deep learning models through a high-level C++ Inference Engine API \ 4deep learning models through a high-level C++ Inference Engine API \
5integrated with application logic." 5integrated with application logic."
6 6
7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2022/3;lfs=0 \ 7SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=releases/2023/0;lfs=0 \
8 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_usb-ma2x8x_20230121_38.zip;name=usb_ma2x8x \
9 https://storage.openvinotoolkit.org/dependencies/myriad/firmware_pcie-ma2x8x_20230121_38.zip;name=pcie_ma2x8x \
10 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \ 8 git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \
11 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \ 9 git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \
12 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \ 10 git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \
@@ -19,16 +17,13 @@ SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;branch=r
19 file://onednn-fix-build-with-gcc13.patch;patchdir=src/plugins/intel_gpu/thirdparty/onednn_gpu \ 17 file://onednn-fix-build-with-gcc13.patch;patchdir=src/plugins/intel_gpu/thirdparty/onednn_gpu \
20 " 18 "
21 19
22SRCREV = "0a5ca5375265f0f12cdaee68574030408dd1c352" 20SRCREV = "b4452d5630442e91cf84db5acd3d991f3d1f34c2"
23SRCREV_mkl = "44de3c3698b687c26e487fc8f0213fa487e8fe2c" 21SRCREV_mkl = "1c7bfabf1b26e6fb95fea1613e1d3d2bef1f6b54"
24SRCREV_onednn = "fbec3e25a559ee252022ae066817b204e106a6ba" 22SRCREV_onednn = "f27dedbfc093f51032a4580198bb80579440dc15"
25SRCREV_xbyak = "f8ea5c28dfcdc98585881d0ca9e499580ca077ae" 23SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2"
26SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d" 24SRCREV_json = "bc889afb4c5bf1c0d8ee29ef35eaaf4c8bef8a5d"
27SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9" 25SRCREV_ade = "58b2595a1a95cc807be8bf6222f266a9a1f393a9"
28 26
29SRC_URI[usb_ma2x8x.sha256sum] = "f7351b2e26f25d652a0539f6ace5797d7700735d52479c3e6ef354c236abbd3a"
30SRC_URI[pcie_ma2x8x.sha256sum] = "439219aeac010f8b85f19838420e9a247f2cdf23a6d00e7727cf92d96dbdaeeb"
31
32LICENSE = "Apache-2.0 & MIT & BSD-3-Clause" 27LICENSE = "Apache-2.0 & MIT & BSD-3-Clause"
33LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ 28LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \
34 file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \ 29 file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \
@@ -58,17 +53,20 @@ EXTRA_OECMAKE += " \
58 -DENABLE_FUZZING=OFF \ 53 -DENABLE_FUZZING=OFF \
59 -DENABLE_TBBBIND_2_5=OFF \ 54 -DENABLE_TBBBIND_2_5=OFF \
60 -DCPACK_GENERATOR=RPM \ 55 -DCPACK_GENERATOR=RPM \
56 -DENABLE_SYSTEM_FLATBUFFERS=ON \
57 -DENABLE_SYSTEM_SNAPPY=ON \
61 " 58 "
62 59
63 60
64DEPENDS += "\ 61DEPENDS += "\
62 flatbuffers-native \
65 gflags \ 63 gflags \
66 libusb1 \
67 protobuf \ 64 protobuf \
68 protobuf-native \ 65 protobuf-native \
69 protobuf-c \ 66 protobuf-c \
70 pugixml \ 67 pugixml \
71 python3-pybind11 \ 68 python3-pybind11 \
69 snappy \
72 tbb \ 70 tbb \
73 zlib \ 71 zlib \
74 " 72 "
@@ -76,11 +74,10 @@ DEPENDS += "\
76COMPATIBLE_HOST = '(x86_64).*-linux' 74COMPATIBLE_HOST = '(x86_64).*-linux'
77COMPATIBLE_HOST:libc-musl = "null" 75COMPATIBLE_HOST:libc-musl = "null"
78 76
79PACKAGECONFIG ?= "vpu opencl samples" 77PACKAGECONFIG ?= "opencl samples"
80PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp," 78PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp,"
81PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-progress python3-cython" 79PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR}, -DENABLE_PYTHON=OFF, python3-cython-native patchelf-native, python3 python3-numpy python3-progress python3-cython"
82PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv" 80PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv"
83PACKAGECONFIG[vpu] = "-DENABLE_INTEL_MYRIAD=ON -DVPU_FIRMWARE_USB-MA2X8X_FILE=../usb-ma2x8x.mvcmd -DVPU_FIRMWARE_PCIE-MA2X8X_FILE=../pcie-ma2x8x.mvcmd,-DENABLE_INTEL_MYRIAD=OFF,,${PN}-vpu-firmware"
84PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" 81PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0"
85 82
86do_configure:prepend() { 83do_configure:prepend() {
@@ -106,14 +103,13 @@ FILES:${PN} += "\
106 " 103 "
107 104
108# Move inference engine samples into a separate package 105# Move inference engine samples into a separate package
109PACKAGES =+ "${PN}-samples ${PN}-vpu-firmware" 106PACKAGES =+ "${PN}-samples"
110 107
111FILES:${PN}-samples = "${datadir}/openvino \ 108FILES:${PN}-samples = "${datadir}/openvino \
112 ${bindir} \ 109 ${bindir} \
113 ${libdir}/libformat_reader.so \ 110 ${libdir}/libformat_reader.a \
114 ${libdir}/libopencv_c_wrapper.so \ 111 ${libdir}/libopencv_c_wrapper.a \
115 " 112 "
116FILES:${PN}-vpu-firmware += "${libdir}/openvino-${PV}/*.mvcmd"
117 113
118# Package for inference engine python API 114# Package for inference engine python API
119PACKAGES =+ "${PN}-${PYTHON_PN}" 115PACKAGES =+ "${PN}-${PYTHON_PN}"