summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-07-31 17:47:03 +0800
commit0584f638797a816b29b909d4611d5a099df7bbc1 (patch)
tree1ec4bdacf824c304290b5086fd54bba9b84158e2 /dynamic-layers/clang-layer/recipes-opencl
parent7a5e47b6a594eb29dfe84e47f043a49974bc0402 (diff)
downloadmeta-intel-0584f638797a816b29b909d4611d5a099df7bbc1.tar.gz
Convert to new override syntax
Use the convert-overrides.py to convert to new syntax and manually fix some additional changes. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb16
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6646.bb8
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb8
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb8
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb6
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb2
6 files changed, 24 insertions, 24 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb
index d0078f3a..73a98732 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_21.04.18912.bb
@@ -10,21 +10,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae27f47fd6755510247c19e547e4c804 \
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https \
12 " 12 "
13SRC_URI_append_class-target = " file://allow-to-find-cpp-generation-tool.patch" 13SRC_URI:append:class-target = " file://allow-to-find-cpp-generation-tool.patch"
14 14
15SRCREV = "5a05d7643c4d8cc14e281b686c78101a7a01e8e1" 15SRCREV = "5a05d7643c4d8cc14e281b686c78101a7a01e8e1"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19DEPENDS += " intel-graphics-compiler gmmlib" 19DEPENDS += " intel-graphics-compiler gmmlib"
20DEPENDS_append_class-target = " intel-compute-runtime-native libva" 20DEPENDS:append:class-target = " intel-compute-runtime-native libva"
21 21
22RDEPENDS_${PN} += " intel-graphics-compiler gmmlib" 22RDEPENDS:${PN} += " intel-graphics-compiler gmmlib"
23 23
24inherit cmake pkgconfig 24inherit cmake pkgconfig
25 25
26COMPATIBLE_HOST = '(x86_64).*-linux' 26COMPATIBLE_HOST = '(x86_64).*-linux'
27COMPATIBLE_HOST_libc-musl = "null" 27COMPATIBLE_HOST:libc-musl = "null"
28 28
29EXTRA_OECMAKE = " \ 29EXTRA_OECMAKE = " \
30 -DIGC_DIR=${STAGING_INCDIR}/igc \ 30 -DIGC_DIR=${STAGING_INCDIR}/igc \
@@ -32,24 +32,24 @@ EXTRA_OECMAKE = " \
32 -DSKIP_UNIT_TESTS=1 \ 32 -DSKIP_UNIT_TESTS=1 \
33 -DCCACHE_ALLOWED=FALSE \ 33 -DCCACHE_ALLOWED=FALSE \
34 " 34 "
35EXTRA_OECMAKE_append_class-target = " \ 35EXTRA_OECMAKE:append:class-target = " \
36 -Dcloc_cmd_prefix=ocloc \ 36 -Dcloc_cmd_prefix=ocloc \
37 " 37 "
38 38
39PACKAGECONFIG ??= "" 39PACKAGECONFIG ??= ""
40PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero" 40PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero"
41 41
42do_install_append_class-native() { 42do_install:append:class-native() {
43 install -d ${D}${bindir} 43 install -d ${D}${bindir}
44 install ${B}/bin/cpp_generate_tool ${D}${bindir}/ 44 install ${B}/bin/cpp_generate_tool ${D}${bindir}/
45} 45}
46 46
47FILES_${PN} += " \ 47FILES:${PN} += " \
48 ${libdir}/intel-opencl/libigdrcl.so \ 48 ${libdir}/intel-opencl/libigdrcl.so \
49 ${libdir}/libocloc.so \ 49 ${libdir}/libocloc.so \
50 " 50 "
51 51
52FILES_${PN}-dev = "${includedir}" 52FILES:${PN}-dev = "${includedir}"
53 53
54BBCLASSEXTEND = "native nativesdk" 54BBCLASSEXTEND = "native nativesdk"
55 55
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6646.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6646.bb
index 582db553..d546dc22 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6646.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.6646.bb
@@ -27,12 +27,12 @@ S = "${WORKDIR}/git"
27inherit cmake 27inherit cmake
28 28
29COMPATIBLE_HOST = '(x86_64).*-linux' 29COMPATIBLE_HOST = '(x86_64).*-linux'
30COMPATIBLE_HOST_libc-musl = "null" 30COMPATIBLE_HOST:libc-musl = "null"
31 31
32DEPENDS += " flex-native bison-native clang opencl-clang vc-intrinsics" 32DEPENDS += " flex-native bison-native clang opencl-clang vc-intrinsics"
33DEPENDS_append_class-target = " clang-cross-x86_64" 33DEPENDS:append:class-target = " clang-cross-x86_64"
34 34
35RDEPENDS_${PN} += "opencl-clang" 35RDEPENDS:${PN} += "opencl-clang"
36 36
37EXTRA_OECMAKE = "-DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DIGC_BUILD__VC_ENABLED=OFF -DIGC_BUILD__USE_KHRONOS_SPIRV_TRANSLATOR=ON" 37EXTRA_OECMAKE = "-DIGC_OPTION__LLVM_PREFERRED_VERSION=${LLVMVERSION} -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 -DIGC_BUILD__VC_ENABLED=OFF -DIGC_BUILD__USE_KHRONOS_SPIRV_TRANSLATOR=ON"
38 38
@@ -40,6 +40,6 @@ BBCLASSEXTEND = "native nativesdk"
40 40
41UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$" 41UPSTREAM_CHECK_GITTAGREGEX = "^igc-(?P<pver>(?!19\..*)\d+(\.\d+)+)$"
42 42
43FILES_${PN} += " \ 43FILES:${PN} += " \
44 ${libdir}/igc/NOTICES.txt \ 44 ${libdir}/igc/NOTICES.txt \
45 " 45 "
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
index 4928eb22..c870b90b 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol=
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ 9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \ 10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \
11 " 11 "
12SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 12SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
13 13
14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0" 14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0"
15 15
@@ -17,17 +17,17 @@ S = "${WORKDIR}/git"
17 17
18inherit cmake 18inherit cmake
19DEPENDS += "clang" 19DEPENDS += "clang"
20DEPENDS_append_class-target = " opencl-clang-native" 20DEPENDS:append:class-target = " opencl-clang-native"
21 21
22COMPATIBLE_HOST = '(x86_64).*-linux' 22COMPATIBLE_HOST = '(x86_64).*-linux'
23COMPATIBLE_HOST_libc-musl = "null" 23COMPATIBLE_HOST:libc-musl = "null"
24 24
25EXTRA_OECMAKE += "\ 25EXTRA_OECMAKE += "\
26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
27 -DCMAKE_SKIP_RPATH=TRUE \ 27 -DCMAKE_SKIP_RPATH=TRUE \
28 " 28 "
29 29
30do_install_append_class-native() { 30do_install:append:class-native() {
31 install -d ${D}${bindir} 31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33} 33}
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
index 0c5d0508..e0b12d1f 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_11.0.0.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \ 8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-110;protocol=https \
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ 9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 " 10 "
11SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 11SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
12 12
13SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321" 13SRCREV = "c67648d41df00ea8ee9d701d17299b86f86f0321"
14 14
@@ -16,10 +16,10 @@ S = "${WORKDIR}/git"
16 16
17inherit cmake 17inherit cmake
18DEPENDS += "clang" 18DEPENDS += "clang"
19DEPENDS_append_class-target = " opencl-clang-native" 19DEPENDS:append:class-target = " opencl-clang-native"
20 20
21COMPATIBLE_HOST = '(x86_64).*-linux' 21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null" 22COMPATIBLE_HOST:libc-musl = "null"
23 23
24EXTRA_OECMAKE += "\ 24EXTRA_OECMAKE += "\
25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 25 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
@@ -27,7 +27,7 @@ EXTRA_OECMAKE += "\
27 -DPREFERRED_LLVM_VERSION="11.1.0" \ 27 -DPREFERRED_LLVM_VERSION="11.1.0" \
28 " 28 "
29 29
30do_install_append_class-native() { 30do_install:append:class-native() {
31 install -d ${D}${bindir} 31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33} 33}
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
index 06dc44da..544f7e33 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_12.0.0.bb
@@ -13,17 +13,17 @@ S = "${WORKDIR}/git"
13 13
14inherit cmake 14inherit cmake
15DEPENDS += " clang spirv-llvm-translator" 15DEPENDS += " clang spirv-llvm-translator"
16DEPENDS_append_class-target = " opencl-clang-native" 16DEPENDS:append:class-target = " opencl-clang-native"
17 17
18COMPATIBLE_HOST = '(x86_64).*-linux' 18COMPATIBLE_HOST = '(x86_64).*-linux'
19COMPATIBLE_HOST_libc-musl = "null" 19COMPATIBLE_HOST:libc-musl = "null"
20 20
21EXTRA_OECMAKE += "\ 21EXTRA_OECMAKE += "\
22 -DCMAKE_SKIP_RPATH=TRUE \ 22 -DCMAKE_SKIP_RPATH=TRUE \
23 -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \ 23 -DPREFERRED_LLVM_VERSION=${LLVMVERSION} \
24 " 24 "
25 25
26do_install_append_class-native() { 26do_install:append:class-native() {
27 install -d ${D}${bindir} 27 install -d ${D}${bindir}
28 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 28 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
29} 29}
diff --git a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
index 3c0cc26c..3ac2c8c0 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/vc-intrinsics/vc-intrinsics_1.0.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
15inherit cmake 15inherit cmake
16 16
17COMPATIBLE_HOST = '(x86_64).*-linux' 17COMPATIBLE_HOST = '(x86_64).*-linux'
18COMPATIBLE_HOST_libc-musl = "null" 18COMPATIBLE_HOST:libc-musl = "null"
19 19
20DEPENDS += " clang" 20DEPENDS += " clang"
21 21