summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
index 4928eb22..c870b90b 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/opencl-clang/opencl-clang_10.0.0.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-100;protocol=
9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \ 9 file://0001-don-t-redefine-LLVM_TABLEGEN_EXE.patch \
10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \ 10 file://0001-Building-in-tree-with-LLVM-10.0-with-the-LLVM_LINK_L.patch \
11 " 11 "
12SRC_URI_append_class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch" 12SRC_URI:append:class-native = " file://0002-make-sure-only-static-libraries-linked-for-native-bu.patch"
13 13
14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0" 14SRCREV = "c8cd72e32b6abc18ce6da71c357ea45ba78b52f0"
15 15
@@ -17,17 +17,17 @@ S = "${WORKDIR}/git"
17 17
18inherit cmake 18inherit cmake
19DEPENDS += "clang" 19DEPENDS += "clang"
20DEPENDS_append_class-target = " opencl-clang-native" 20DEPENDS:append:class-target = " opencl-clang-native"
21 21
22COMPATIBLE_HOST = '(x86_64).*-linux' 22COMPATIBLE_HOST = '(x86_64).*-linux'
23COMPATIBLE_HOST_libc-musl = "null" 23COMPATIBLE_HOST:libc-musl = "null"
24 24
25EXTRA_OECMAKE += "\ 25EXTRA_OECMAKE += "\
26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \ 26 -DLLVM_TABLEGEN_EXE=${STAGING_BINDIR_NATIVE}/llvm-tblgen \
27 -DCMAKE_SKIP_RPATH=TRUE \ 27 -DCMAKE_SKIP_RPATH=TRUE \
28 " 28 "
29 29
30do_install_append_class-native() { 30do_install:append:class-native() {
31 install -d ${D}${bindir} 31 install -d ${D}${bindir}
32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/ 32 install -m 0755 ${B}/linux_linker/linux_resource_linker ${D}${bindir}/
33} 33}