summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch60
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch36
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch45
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch43
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch61
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch49
6 files changed, 233 insertions, 61 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
new file mode 100644
index 00000000..088976d8
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
@@ -0,0 +1,60 @@
1From e637d9f6bb961afcecb74faa6dff38562f6ce796 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Sun, 26 Jan 2020 10:45:28 +0000
4Subject: [PATCH] ext/wayland: fix meson build in nxp fork
5
6- Add Wayland protocols, which are not enabled in upstream
7- Add missing compilation unit, which in NXP-specific
8
9Upstream-Status: Pending
10
11Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
12---
13 ext/wayland/meson.build | 24 ++++++++++++++++++++++++
14 1 file changed, 24 insertions(+)
15
16diff --git a/ext/wayland/meson.build b/ext/wayland/meson.build
17index fa6fbf42f..eb425b14f 100644
18--- a/ext/wayland/meson.build
19+++ b/ext/wayland/meson.build
20@@ -8,6 +8,11 @@ wl_sources = [
21 'wllinuxdmabuf.c'
22 ]
23
24+imx_wl_sources = [
25+ 'wlutils.c',
26+]
27+wl_sources += imx_wl_sources
28+
29 if use_wayland
30 protocols_datadir = wl_protocol_dep.get_pkgconfig_variable('pkgdatadir')
31
32@@ -19,6 +24,25 @@ if use_wayland
33 'fullscreen-shell-unstable-v1-protocol.c', 'fullscreen-shell-unstable-v1-client-protocol.h'],
34 ['/stable/xdg-shell/xdg-shell.xml', 'xdg-shell-protocol.c', 'xdg-shell-client-protocol.h'],
35 ]
36+
37+ imx_protocol_defs = [
38+ [
39+ '/unstable/alpha-compositing/alpha-compositing-unstable-v1.xml',
40+ 'alpha-compositing-unstable-v1-protocol.c',
41+ 'alpha-compositing-unstable-v1-client-protocol.h'
42+ ],
43+ ['/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml',
44+ 'hdr10-metadata-unstable-v1-protocol.c',
45+ 'hdr10-metadata-unstable-v1-client-protocol.h'
46+ ],
47+ [
48+ '/unstable/linux-explicit-synchronization/linux-explicit-synchronization-unstable-v1.xml',
49+ 'linux-explicit-synchronization-unstable-v1-protocol.c',
50+ 'linux-explicit-synchronization-unstable-v1-client-protocol.h'
51+ ],
52+ ]
53+ protocol_defs += imx_protocol_defs
54+
55 protocols_files = []
56
57 foreach protodef: protocol_defs
58--
592.17.1
60
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch
new file mode 100644
index 00000000..13218520
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch
@@ -0,0 +1,36 @@
1From 97a4d0cd7de8cfbf983acc7e37ba2f8fb73c3e19 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
3Date: Fri, 18 Oct 2019 00:39:12 +0100
4Subject: [PATCH 1/2] meson: build gir even when cross-compiling if
5 introspection was enabled explicitly
6
7This can be made to work in certain circumstances when
8cross-compiling, so default to not building g-i stuff
9when cross-compiling, but allow it if introspection was
10enabled explicitly via -Dintrospection=enabled.
11
12See gstreamer/gstreamer#454 and gstreamer/gstreamer#381.
13
14Upstream-Status: Backport [97a4d0cd7de8cfbf983acc7e37ba2f8fb73c3e19]
15
16Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
17---
18 meson.build | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/meson.build b/meson.build
22index 67aeeb4d0..7b3314bd9 100644
23--- a/meson.build
24+++ b/meson.build
25@@ -411,7 +411,7 @@ python3 = import('python').find_installation()
26
27 gir = find_program('g-ir-scanner', required : get_option('introspection'))
28 gnome = import('gnome')
29-build_gir = gir.found() and not meson.is_cross_build()
30+build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled())
31 gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' + \
32 'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \
33 'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
34--
352.17.1
36
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch
new file mode 100644
index 00000000..874b8abc
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch
@@ -0,0 +1,45 @@
1From f41f356aebee916910453031c06c111000f2f261 Mon Sep 17 00:00:00 2001
2From: Christoph Reiter <reiter.christoph@gmail.com>
3Date: Sun, 5 May 2019 22:11:16 +0200
4Subject: [PATCH] meson: fix build with opencv=enabled and opencv4. Fixes #964
5
6Having the opencv feature enabled would lead to the opencv3 dependency
7being required which failed with only opencv4 being available.
8
9Instead don't require anything and error out at the end if the feature was enabled
10but no dependency was found.
11
12Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/commit/22c6a4085f8792d8af0cdabfe1664d55ca2dee11]
13
14(cherry picked from commit 22c6a4085f8792d8af0cdabfe1664d55ca2dee11)
15Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
16---
17 gst-libs/gst/opencv/meson.build | 6 ++++--
18 1 file changed, 4 insertions(+), 2 deletions(-)
19
20diff --git a/gst-libs/gst/opencv/meson.build b/gst-libs/gst/opencv/meson.build
21index 3fd472fda..8dc2ad99b 100644
22--- a/gst-libs/gst/opencv/meson.build
23+++ b/gst-libs/gst/opencv/meson.build
24@@ -9,9 +9,9 @@ opencv_headers = [
25 'gstopencvvideofilter.h',
26 ]
27
28-opencv_dep = dependency('opencv', version : '>= 3.0.0', required : get_option('opencv'))
29+opencv_dep = dependency('opencv', version : '>= 3.0.0', required : false)
30 if not opencv_dep.found()
31- opencv_dep = dependency('opencv4', version : '>= 4.0.0', required : get_option('opencv'))
32+ opencv_dep = dependency('opencv4', version : '>= 4.0.0', required : false)
33 endif
34 if opencv_dep.found()
35 gstopencv = library('gstopencv-' + api_version,
36@@ -30,4 +30,6 @@ if opencv_dep.found()
37 dependencies : [gstvideo_dep, opencv_dep])
38
39 install_headers(opencv_headers, subdir : 'gstreamer-1.0/gst/opencv')
40+elif get_option('opencv').enabled()
41+ error('OpenCV support enabled but required dependencies were not found.')
42 endif
43--
442.17.1
45
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
new file mode 100644
index 00000000..62705dd4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
@@ -0,0 +1,43 @@
1From eb404fd917fa3ab7ffa9433c9975ee49cfc9c41f Mon Sep 17 00:00:00 2001
2From: Nicola Murino <nicola.murino@gmail.com>
3Date: Tue, 23 Apr 2019 09:06:13 +0200
4Subject: [PATCH 1/2] opencv: allow compilation against 4.1.x
5
6Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/commit/49a2baebf58d9288f75964fc40a547fde510a840]
7
8(cherry picked from commit 49a2baebf58d9288f75964fc40a547fde510a840)
9Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
10---
11 configure.ac | 2 +-
12 ext/opencv/meson.build | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 26f72eb0d..9e12d39a0 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -1852,7 +1852,7 @@ AG_GST_CHECK_FEATURE(OPENCV, [opencv plugins], opencv, [
20 HAVE_OPENCV="yes"
21 fi
22 ], [
23- PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.1.0] , [
24+ PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.2.0] , [
25 AC_PROG_CXX
26 AC_LANG([C++])
27 OLD_CPPFLAGS=$CPPFLAGS
28diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
29index d0ce1d3ee..f38b55dfe 100644
30--- a/ext/opencv/meson.build
31+++ b/ext/opencv/meson.build
32@@ -65,7 +65,7 @@ if opencv_found
33 endif
34 endforeach
35 else
36- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.1.0'], required : false)
37+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false)
38 opencv_found = opencv_dep.found()
39 if opencv_found
40 foreach h : libopencv4_headers
41--
422.17.1
43
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch
deleted file mode 100644
index 25861b6b..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1From f59c5269f92d59a5296cbfeeb682d42095cd88ad Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Thu, 18 Sep 2014 02:24:07 -0400
4Subject: [PATCH] gstreamer1.0-plugins-bad: allow to disable libssh2
5
6libssh2 is automatically linked to if present, this undetermined
7dependency may cause build errors like:
8
9 .../x86_64-poky-linux/4.9.0/ld: cannot find -lssh2
10
11libssh2 isn't an oe-core recipe, so allow to disable it from
12configure.
13
14Upstream-Status: Pending
15
16Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
17---
18 configure.ac | 23 +++++++++++++++++------
19 1 file changed, 17 insertions(+), 6 deletions(-)
20
21Index: gst-plugins-bad-1.12.3/configure.ac
22===================================================================
23--- gst-plugins-bad-1.12.3.orig/configure.ac
24+++ gst-plugins-bad-1.12.3/configure.ac
25@@ -1202,6 +1202,15 @@ AG_GST_CHECK_FEATURE(CHROMAPRINT, [chrom
26 ])
27
28 dnl *** Curl ***
29+AC_ARG_ENABLE([libssh2],
30+ [ --enable-libssh2 enable LIBSSH2 support @<:@default=auto@:>@],
31+ [case "${enableval}" in
32+ yes) NEED_SSH2=yes ;;
33+ no) NEED_SSH2=no ;;
34+ auto) NEED_SSH2=auto ;;
35+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-libssh2]) ;;
36+ esac],[NEED_SSH2=auto])
37+
38 translit(dnm, m, l) AM_CONDITIONAL(USE_CURL, true)
39 AG_GST_CHECK_FEATURE(CURL, [Curl plugin], curl, [
40 PKG_CHECK_MODULES(CURL, libcurl >= 7.35.0, [
41@@ -1224,12 +1233,14 @@ AG_GST_CHECK_FEATURE(CURL, [Curl plugin]
42 ])
43 AC_SUBST(CURL_CFLAGS)
44 AC_SUBST(CURL_LIBS)
45- PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [
46- HAVE_SSH2="yes"
47- AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available])
48- ], [
49- HAVE_SSH2="no"
50- ])
51+ if test "x$NEED_SSH2" != "xno"; then
52+ PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [
53+ HAVE_SSH2="yes"
54+ AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available])
55+ ], [
56+ HAVE_SSH2="no"
57+ ])
58+ fi
59 AM_CONDITIONAL(USE_SSH2, test "x$HAVE_SSH2" = "xyes")
60 AC_SUBST(SSH2_CFLAGS)
61 AC_SUBST(SSH2_LIBS)
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch
new file mode 100644
index 00000000..3fe3f649
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch
@@ -0,0 +1,49 @@
1From 5830de9b1c8965683025082aeed7ccaf1dd85969 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Sun, 26 Jan 2020 19:55:06 +0000
4Subject: [PATCH 2/2] opencv: resolve missing opencv data dir in yocto build
5
6When Yocto build is performed, opencv searches for data dir using simple
7test command, and this fails because pkg-config provides an absolute
8path on the target which needs to be prepended by PKG_CONFIG_SYSROOT_DIR
9in order for the 'test' utility to pick up the absolute path.
10
11Upstream-Status: Inappropriate [OE-specific]
12
13Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
14---
15 ext/opencv/meson.build | 7 ++++---
16 1 file changed, 4 insertions(+), 3 deletions(-)
17
18diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
19index f38b55dfe..a26403482 100644
20--- a/ext/opencv/meson.build
21+++ b/ext/opencv/meson.build
22@@ -78,20 +78,21 @@ else
23 endif
24
25 if opencv_found
26+ pkgconf_sysroot = run_command(python3, '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip()
27 opencv_prefix = opencv_dep.get_pkgconfig_variable('prefix')
28 gstopencv_cargs += ['-DOPENCV_PREFIX="' + opencv_prefix + '"']
29
30 # Check the data dir used by opencv for its xml data files
31 # Use prefix from pkg-config to be compatible with cross-compilation
32- r = run_command('test', '-d', opencv_prefix + '/share/opencv')
33+ r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/opencv')
34 if r.returncode() == 0
35 gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv"'
36 else
37- r = run_command('test', '-d', opencv_prefix + '/share/OpenCV')
38+ r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/OpenCV')
39 if r.returncode() == 0
40 gstopencv_cargs += '-DOPENCV_PATH_NAME="OpenCV"'
41 else
42- r = run_command('test', '-d', opencv_prefix + '/share/opencv4')
43+ r = run_command('test', '-d', pkgconf_sysroot + opencv_prefix + '/share/opencv4')
44 if r.returncode() == 0
45 gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv4"'
46 else
47--
482.17.1
49