summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
new file mode 100644
index 00000000..088976d8
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch
@@ -0,0 +1,60 @@
1From e637d9f6bb961afcecb74faa6dff38562f6ce796 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Sun, 26 Jan 2020 10:45:28 +0000
4Subject: [PATCH] ext/wayland: fix meson build in nxp fork
5
6- Add Wayland protocols, which are not enabled in upstream
7- Add missing compilation unit, which in NXP-specific
8
9Upstream-Status: Pending
10
11Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
12---
13 ext/wayland/meson.build | 24 ++++++++++++++++++++++++
14 1 file changed, 24 insertions(+)
15
16diff --git a/ext/wayland/meson.build b/ext/wayland/meson.build
17index fa6fbf42f..eb425b14f 100644
18--- a/ext/wayland/meson.build
19+++ b/ext/wayland/meson.build
20@@ -8,6 +8,11 @@ wl_sources = [
21 'wllinuxdmabuf.c'
22 ]
23
24+imx_wl_sources = [
25+ 'wlutils.c',
26+]
27+wl_sources += imx_wl_sources
28+
29 if use_wayland
30 protocols_datadir = wl_protocol_dep.get_pkgconfig_variable('pkgdatadir')
31
32@@ -19,6 +24,25 @@ if use_wayland
33 'fullscreen-shell-unstable-v1-protocol.c', 'fullscreen-shell-unstable-v1-client-protocol.h'],
34 ['/stable/xdg-shell/xdg-shell.xml', 'xdg-shell-protocol.c', 'xdg-shell-client-protocol.h'],
35 ]
36+
37+ imx_protocol_defs = [
38+ [
39+ '/unstable/alpha-compositing/alpha-compositing-unstable-v1.xml',
40+ 'alpha-compositing-unstable-v1-protocol.c',
41+ 'alpha-compositing-unstable-v1-client-protocol.h'
42+ ],
43+ ['/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml',
44+ 'hdr10-metadata-unstable-v1-protocol.c',
45+ 'hdr10-metadata-unstable-v1-client-protocol.h'
46+ ],
47+ [
48+ '/unstable/linux-explicit-synchronization/linux-explicit-synchronization-unstable-v1.xml',
49+ 'linux-explicit-synchronization-unstable-v1-protocol.c',
50+ 'linux-explicit-synchronization-unstable-v1-client-protocol.h'
51+ ],
52+ ]
53+ protocol_defs += imx_protocol_defs
54+
55 protocols_files = []
56
57 foreach protodef: protocol_defs
58--
592.17.1
60