summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
new file mode 100644
index 00000000..62705dd4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
@@ -0,0 +1,43 @@
1From eb404fd917fa3ab7ffa9433c9975ee49cfc9c41f Mon Sep 17 00:00:00 2001
2From: Nicola Murino <nicola.murino@gmail.com>
3Date: Tue, 23 Apr 2019 09:06:13 +0200
4Subject: [PATCH 1/2] opencv: allow compilation against 4.1.x
5
6Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/commit/49a2baebf58d9288f75964fc40a547fde510a840]
7
8(cherry picked from commit 49a2baebf58d9288f75964fc40a547fde510a840)
9Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
10---
11 configure.ac | 2 +-
12 ext/opencv/meson.build | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 26f72eb0d..9e12d39a0 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -1852,7 +1852,7 @@ AG_GST_CHECK_FEATURE(OPENCV, [opencv plugins], opencv, [
20 HAVE_OPENCV="yes"
21 fi
22 ], [
23- PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.1.0] , [
24+ PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.2.0] , [
25 AC_PROG_CXX
26 AC_LANG([C++])
27 OLD_CPPFLAGS=$CPPFLAGS
28diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
29index d0ce1d3ee..f38b55dfe 100644
30--- a/ext/opencv/meson.build
31+++ b/ext/opencv/meson.build
32@@ -65,7 +65,7 @@ if opencv_found
33 endif
34 endforeach
35 else
36- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.1.0'], required : false)
37+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false)
38 opencv_found = opencv_dep.found()
39 if opencv_found
40 foreach h : libopencv4_headers
41--
422.17.1
43