summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-07-10 09:35:08 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-11 16:55:07 -0300
commit02fc6a68ecc9d76cdaeca483b70dc37180e2e7f8 (patch)
treef12638a2caae68aeb4c14a641e9484c012f6d977 /recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb
parent791a4e765cc27d53aab05f7733b599b8c990c1df (diff)
downloadmeta-freescale-02fc6a68ecc9d76cdaeca483b70dc37180e2e7f8.tar.gz
u-boot-fslc: Update to 2018.07-based fork
This updates the fork on top of current 2018.07 release and also adds a much improved support to pico-imx7d and pico-imx6ul. The list of commits included are: bc558729a7 warp7: update defconfig to support the generic loading interface e5a6138278 mx25pdk: Change root to use a single partition layout f9d1e13cf5 mx6sabre_common: Dynamically change the video output 865268ce8a mx6sabresd: Enable video interfaces in bootargs 7db6f3d8c5 mx6sabresd: Use LDO dtb file until LDO bypass support is added 84fc5b0de1 mx6slevk: Use LDO dtb file until LDO bypass support is added ccf16e75e7 pico-imx6ul: Convert to distro config 06eecc42a2 configs/imx: Remove 'mmcautodect' variable 12c65ae7a9 pico-imx7d: Add new pico-pi config fe4fd4e1ea pico-imx7d: README: Drop old instructions about secure mode a076cc293b pico-imx7d: README: Use dfu-util to flash U-Boot 24f9fcde47 pico-imx7d: Enable auxiliary code support 78fead0843 pico-imx7d: Allow default fdtfile to be overridden by defconfig 04d0d8894f pico-imx7d: Do not override addrmap5 e5833f48e6 pico-imx7d: Enable CONFIG_ARMV7_BOOT_SEC_DEFAULT ceb9087434 pico-imx7d: Add Falcon mode support 8800626580 pico-imx7d: Add bootmenu to choose the baseboard f2c33216e7 pico-imx7d: Add support for update SPL using DFU 6cc975154d pico-imx7d: Add SPL support 349985a0f2 pico-imx7d: Add fastboot support 76a4da5eb1 pico-imx7d: Add default DFU targets c6c4a0e0d8 pico-imx7d: Add GPT partitioning support 9ac7204c7a pico-imx7d: Fix common distro configuration behavior 62523103a0 pico-imx7d: Convert to distro config Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb
new file mode 100644
index 00000000..abcb5013
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb
@@ -0,0 +1,45 @@
1require u-boot-fslc-common_${PV}.inc
2
3SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
4DEPENDS = "mtd-utils"
5
6INSANE_SKIP_${PN} = "already-stripped"
7EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
8EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
9
10inherit uboot-config
11
12do_compile () {
13 oe_runmake ${UBOOT_MACHINE}
14 oe_runmake envtools
15}
16
17do_install () {
18 install -d ${D}${base_sbindir}
19 install -d ${D}${sysconfdir}
20 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
21 install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
22
23 if [ -e ${WORKDIR}/fw_env.config ]; then
24 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
25 else
26 install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
27 fi
28}
29
30do_install_class-cross () {
31 install -d ${D}${bindir_cross}
32 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
33 install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
34}
35
36SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
37uboot_fw_utils_cross() {
38 sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
39}
40
41PROVIDES += "u-boot-fw-utils"
42RPROVIDES_${PN} += "u-boot-fw-utils"
43
44PACKAGE_ARCH = "${MACHINE_ARCH}"
45BBCLASSEXTEND = "cross"