summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-07-10 09:35:08 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-11 16:55:07 -0300
commit02fc6a68ecc9d76cdaeca483b70dc37180e2e7f8 (patch)
treef12638a2caae68aeb4c14a641e9484c012f6d977
parent791a4e765cc27d53aab05f7733b599b8c990c1df (diff)
downloadmeta-freescale-02fc6a68ecc9d76cdaeca483b70dc37180e2e7f8.tar.gz
u-boot-fslc: Update to 2018.07-based fork
This updates the fork on top of current 2018.07 release and also adds a much improved support to pico-imx7d and pico-imx6ul. The list of commits included are: bc558729a7 warp7: update defconfig to support the generic loading interface e5a6138278 mx25pdk: Change root to use a single partition layout f9d1e13cf5 mx6sabre_common: Dynamically change the video output 865268ce8a mx6sabresd: Enable video interfaces in bootargs 7db6f3d8c5 mx6sabresd: Use LDO dtb file until LDO bypass support is added 84fc5b0de1 mx6slevk: Use LDO dtb file until LDO bypass support is added ccf16e75e7 pico-imx6ul: Convert to distro config 06eecc42a2 configs/imx: Remove 'mmcautodect' variable 12c65ae7a9 pico-imx7d: Add new pico-pi config fe4fd4e1ea pico-imx7d: README: Drop old instructions about secure mode a076cc293b pico-imx7d: README: Use dfu-util to flash U-Boot 24f9fcde47 pico-imx7d: Enable auxiliary code support 78fead0843 pico-imx7d: Allow default fdtfile to be overridden by defconfig 04d0d8894f pico-imx7d: Do not override addrmap5 e5833f48e6 pico-imx7d: Enable CONFIG_ARMV7_BOOT_SEC_DEFAULT ceb9087434 pico-imx7d: Add Falcon mode support 8800626580 pico-imx7d: Add bootmenu to choose the baseboard f2c33216e7 pico-imx7d: Add support for update SPL using DFU 6cc975154d pico-imx7d: Add SPL support 349985a0f2 pico-imx7d: Add fastboot support 76a4da5eb1 pico-imx7d: Add default DFU targets c6c4a0e0d8 pico-imx7d: Add GPT partitioning support 9ac7204c7a pico-imx7d: Fix common distro configuration behavior 62523103a0 pico-imx7d: Convert to distro config Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2018.05.inc16
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2018.07.inc16
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.05.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.05.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2018.07.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2018.05.bb)0
5 files changed, 16 insertions, 16 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2018.05.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2018.05.inc
deleted file mode 100644
index f6ff307e..00000000
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2018.05.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1# Copyright (C) 2012-2017 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4inherit fsl-u-boot-localversion
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
8
9SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
10
11SRCREV = "a092fb15045c575663a6c5000c274a55ffd52166"
12SRCBRANCH = "2018.05+fslc"
13
14PV = "v2018.05+git${SRCPV}"
15
16S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2018.07.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2018.07.inc
new file mode 100644
index 00000000..ff54e15b
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2018.07.inc
@@ -0,0 +1,16 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4inherit fsl-u-boot-localversion
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
8
9SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
10
11SRCREV = "bc558729a723f2d2c91b74d9c96716666550d528"
12SRCBRANCH = "2018.07+fslc"
13
14PV = "v2018.07+git${SRCPV}"
15
16S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.05.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb
index abcb5013..abcb5013 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.05.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2018.07.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.05.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.07.bb
index ed32a274..ed32a274 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.05.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2018.07.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2018.05.bb b/recipes-bsp/u-boot/u-boot-fslc_2018.07.bb
index 5659e16c..5659e16c 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2018.05.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2018.07.bb