summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test/imx-test_git.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-01-12 22:46:10 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-01 11:24:43 -0300
commite8fb1c9fed1981494134e945bf7978113583dba6 (patch)
tree1d246ec4407e6ad7a3e1ff3a0969b368efc1bd76 /recipes-bsp/imx-test/imx-test_git.bb
parent5bef551cd1a1711cbe56b769576577b460ef3797 (diff)
downloadmeta-freescale-e8fb1c9fed1981494134e945bf7978113583dba6.tar.gz
imx-test: upgrade to release 5.4.70_2.3.0
Upgrade recipe to match with release 5.4.70_2.3.0 from NXP. Drop patch from the layer that is applied upstream, it is covered by the commit (35881dd "MLK-24751 pxp_test: fix build break with GCC 9.2") Add new package config option to include SW PDM. Following commits are included in this update: ---- 90fd716 MLK-25007: mxc_audio_monitor: use double type to improve the precision 9e3378e MLK-24989: mxc_audio_monitor: Add support for 8MP f98b5a8 MLK-24896 mxc_v4l2_vpu_test: integrate VSI unit-test parser 838ea7f MLK-24829:mxc_v4l2_vpu_test: encoder: fix crop setting doesn't take effect 8939e71 MLK-24797: mx8_v4l2_cap_drm.c: fix camera preview not working when run six sensors af1091d MLK-24692: camera: mx8_v4l2_cap_drm.c support sixteen camera channels 35881dd MLK-24751 pxp_test: fix build break with GCC 9.2 709656b MLK-24736 mxc_v4l2_vpu_test: add parser for JPEG format 7169666 MLK-24533:mxc_v4l2_vpu_test: encoder: align the max buffer count to the v4l2 max buffer count 2ae964b MLK-24499: [8QM_MEK/8QXP_MEK]mxc:vpu_windsor: set low latency mode through set bframe 5ea9607 set hevc profile and level 527092b MLK-24466-2 mxc_v4l2_vpu_test: encoder: refine parser ---- Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-bsp/imx-test/imx-test_git.bb')
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index b9c12e18..da488bd3 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -16,13 +16,12 @@ DEPENDS_append_imxvpu = " virtual/imxvpu"
16PE = "1" 16PE = "1"
17PV = "7.0+${SRCPV}" 17PV = "7.0+${SRCPV}"
18 18
19SRCBRANCH = "imx_5.4.47_2.2.0" 19SRCBRANCH = "imx_5.4.70_2.3.0"
20SRC_URI = " \ 20SRC_URI = " \
21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
22 file://0001-pxp-test-Fix-format-security-error.patch \
23 file://memtool_profile \ 22 file://memtool_profile \
24" 23"
25SRCREV = "31623a4972bf6f2f4239b4667aeb33baba07a3c8" 24SRCREV = "90fd7168fe5f15de9b2b1992a719024fc73a185a"
26S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
27 26
28inherit module-base use-imx-headers 27inherit module-base use-imx-headers
@@ -48,6 +47,7 @@ PACKAGECONFIG_append_imxvpu = " vpu"
48 47
49PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" 48PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
50PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" 49PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu"
50PACKAGECONFIG[swpdm] = "HAS_IMX_SW_PDM=true,HAS_IMX_SW_PDM=false,imx-sw-pdm"
51 51
52do_compile() { 52do_compile() {
53 CFLAGS="${TOOLCHAIN_OPTIONS}" 53 CFLAGS="${TOOLCHAIN_OPTIONS}"