summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch32
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb6
2 files changed, 3 insertions, 35 deletions
diff --git a/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch b/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch
deleted file mode 100644
index 1fe997d7..00000000
--- a/recipes-bsp/imx-test/imx-test/0001-pxp-test-Fix-format-security-error.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 97a55fe4b1e02b9a4992517234a8b24f8f9f0009 Mon Sep 17 00:00:00 2001
2From: "i.MX Yocto Project Build" <imx.build@nxp.com>
3Date: Mon, 27 Jan 2020 13:43:47 -0600
4Subject: [PATCH] pxp test: Fix format-security error
5
6| pxp_lib_test/pxp_test.c: In function 'main':
7| pxp_lib_test/pxp_test.c:541:2: error: format not a string literal and no format arguments [-Werror=format-security]
8| 541 | printf(usage);
9| | ^~~~~~
10
11Upstream-Status: Pending
12
13Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
14---
15 test/pxp_lib_test/pxp_test.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/test/pxp_lib_test/pxp_test.c b/test/pxp_lib_test/pxp_test.c
19index 107198f..72c984d 100644
20--- a/test/pxp_lib_test/pxp_test.c
21+++ b/test/pxp_lib_test/pxp_test.c
22@@ -538,6 +538,6 @@ int main(int argc, char *argv[])
23
24 return 0;
25 usage:
26- printf(usage);
27+ printf("%s", usage);
28 return -1;
29 }
30--
312.17.1
32
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index b9c12e18..da488bd3 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -16,13 +16,12 @@ DEPENDS_append_imxvpu = " virtual/imxvpu"
16PE = "1" 16PE = "1"
17PV = "7.0+${SRCPV}" 17PV = "7.0+${SRCPV}"
18 18
19SRCBRANCH = "imx_5.4.47_2.2.0" 19SRCBRANCH = "imx_5.4.70_2.3.0"
20SRC_URI = " \ 20SRC_URI = " \
21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
22 file://0001-pxp-test-Fix-format-security-error.patch \
23 file://memtool_profile \ 22 file://memtool_profile \
24" 23"
25SRCREV = "31623a4972bf6f2f4239b4667aeb33baba07a3c8" 24SRCREV = "90fd7168fe5f15de9b2b1992a719024fc73a185a"
26S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
27 26
28inherit module-base use-imx-headers 27inherit module-base use-imx-headers
@@ -48,6 +47,7 @@ PACKAGECONFIG_append_imxvpu = " vpu"
48 47
49PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" 48PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
50PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" 49PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu"
50PACKAGECONFIG[swpdm] = "HAS_IMX_SW_PDM=true,HAS_IMX_SW_PDM=false,imx-sw-pdm"
51 51
52do_compile() { 52do_compile() {
53 CFLAGS="${TOOLCHAIN_OPTIONS}" 53 CFLAGS="${TOOLCHAIN_OPTIONS}"