summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-07-21 14:01:24 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-24 13:12:13 -0400
commitcfac7d03941f6ae0b1b55f91bff6b217e8f798f7 (patch)
tree575ca0e1909d5feeaf6b45b039707044ca89148c /meta-openstack
parent5d6ffffc95af466f68777b22d6bd48e1d1b9d3c6 (diff)
downloadmeta-cloud-services-cfac7d03941f6ae0b1b55f91bff6b217e8f798f7.tar.gz
python3-oslo.concurrency: Change python to python3
Version updated to 3.21.2 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb (renamed from meta-openstack/recipes-devtools/python/python-oslo.concurrency_git.bb)25
1 files changed, 12 insertions, 13 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.concurrency_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb
index 567606c..8b2043b 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.concurrency_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb
@@ -4,8 +4,8 @@ SECTION = "devel/python"
4LICENSE = "Apache-2" 4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6 6
7PV = "3.21.1+git${SRCPV}" 7PV = "3.21.2+git${SRCPV}"
8SRCREV = "8adf9b1f0d69dca7372b967ef4f894487f1a9d64" 8SRCREV = "1b25351d1c63e573068fff3d16faca440bbdcabf"
9 9
10SRCNAME = "oslo.concurrency" 10SRCNAME = "oslo.concurrency"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike" 11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
@@ -14,25 +14,24 @@ S = "${WORKDIR}/git"
14 14
15inherit setuptools3 15inherit setuptools3
16 16
17# DEPENDS_default: python-pip 17# DEPENDS_default: python3-pip
18 18
19DEPENDS += " \ 19DEPENDS += " \
20 python-pip \ 20 python3-pip \
21 python-pbr \ 21 python3-pbr \
22 " 22 "
23 23
24# Satisfy setup.py 'setup_requires' 24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \ 25DEPENDS += " \
26 python-pbr-native \ 26 python3-pbr-native \
27 " 27 "
28 28
29# RDEPENDS_default: 29# RDEPENDS_default:
30RDEPENDS_${PN} += " \ 30RDEPENDS_${PN} += " \
31 python-pbr \ 31 python3-pbr \
32 python-fasteners \ 32 python3-fasteners \
33 python-oslo.config \ 33 python3-oslo.config \
34 python-oslo.i18n \ 34 python3-oslo.i18n \
35 python-oslo.utils \ 35 python3-oslo.utils \
36 python-six \ 36 python3-six \
37 python-enum34 \
38 " 37 "