summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb
new file mode 100644
index 0000000..8b2043b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.concurrency_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "oslo.concurrency library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "3.21.2+git${SRCPV}"
8SRCREV = "1b25351d1c63e573068fff3d16faca440bbdcabf"
9
10SRCNAME = "oslo.concurrency"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17# DEPENDS_default: python3-pip
18
19DEPENDS += " \
20 python3-pip \
21 python3-pbr \
22 "
23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 python3-pbr-native \
27 "
28
29# RDEPENDS_default:
30RDEPENDS_${PN} += " \
31 python3-pbr \
32 python3-fasteners \
33 python3-oslo.config \
34 python3-oslo.i18n \
35 python3-oslo.utils \
36 python3-six \
37 "