summaryrefslogtreecommitdiffstats
path: root/meta-openstack
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-07-21 14:01:32 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-24 13:12:13 -0400
commit5d6ffffc95af466f68777b22d6bd48e1d1b9d3c6 (patch)
tree0dd8299797720282071ac44b7fb9f46b55724d4b /meta-openstack
parentf6ef8ed5ab81f21575b158f8c0a2f3654a0363a4 (diff)
downloadmeta-cloud-services-5d6ffffc95af466f68777b22d6bd48e1d1b9d3c6.tar.gz
python3-oslo.service: Change python to python3
Version updated to 1.25.2 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.service_git.bb43
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.service_git.bb44
2 files changed, 44 insertions, 43 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb
deleted file mode 100644
index 392270d..0000000
--- a/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1DESCRIPTION = "oslo.service library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "1.25.0"
8SRCREV = "0020bef6a503905aca5cdb70aee54e1c5f2ff472"
9
10SRCNAME = "oslo.service"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
27RDEPENDS_${PN} += " \
28 python-pbr \
29 python-webob \
30 python-eventlet \
31 python-greenlet \
32 python-monotonic \
33 python-oslo.utils \
34 python-oslo.concurrency \
35 python-oslo.config \
36 python-oslo.log \
37 python-six \
38 python-oslo.i18n \
39 python-pastedeploy \
40 python-paste \
41 python-routes \
42 "
43
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.service_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.service_git.bb
new file mode 100644
index 0000000..3598ea0
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.service_git.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "oslo.service library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "1.25.2"
8SRCREV = "8481ce67951aa1b44203c03639b79e06f65bd8bc"
9
10SRCNAME = "oslo.service"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python3-pip \
19 python3-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python3-pbr-native \
25 "
26
27RDEPENDS_${PN} += " \
28 python3-pbr \
29 python3-webob \
30 python3-eventlet \
31 python3-greenlet \
32 python3-monotonic \
33 python3-oslo.utils \
34 python3-oslo.concurrency \
35 python3-oslo.config \
36 python3-oslo.log \
37 python3-six \
38 python3-oslo.i18n \
39 python3-pastedeploy \
40 python3-paste \
41 python3-routes \
42 python3-dnspython \
43 "
44