summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-29 22:58:45 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-01 23:10:36 -0400
commitb7133e477c13e4bf54b5d1fb0e5e940879c0a1e7 (patch)
treedea617b618687fd861580e364a1239c482f80c6f
parent72e4a4bedd7b6a16c0fca578ba92f7583df31bd2 (diff)
downloadmeta-cloud-services-b7133e477c13e4bf54b5d1fb0e5e940879c0a1e7.tar.gz
python3-oslo.i18n: upgrade 3.23.1 -> 5.0.1
Consolidate inc and bb files into a single bb file. Since python2 is no longer maintained, the recipe of python2 is removed. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.i18n.inc32
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.i18n_3.23.1.bb33
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb34
3 files changed, 33 insertions, 66 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.i18n.inc b/meta-openstack/recipes-devtools/python/python-oslo.i18n.inc
deleted file mode 100644
index 3c0e74c..0000000
--- a/meta-openstack/recipes-devtools/python/python-oslo.i18n.inc
+++ /dev/null
@@ -1,32 +0,0 @@
1DESCRIPTION = "oslo.i18n library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "3.17.0+git${SRCPV}"
8SRCREV = "f2729cd36f8694a6ec53a0e700599ddf4427440d"
9
10SRCNAME = "oslo.i18n"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
12
13S = "${WORKDIR}/git"
14
15# DEPENDS_default: python-pip
16
17DEPENDS += " \
18 ${PYTHON_PN}-pip \
19 ${PYTHON_PN}-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 ${PYTHON_PN}-pbr-native \
25 "
26
27# RDEPENDS_default:
28RDEPENDS_${PN} += " \
29 ${PYTHON_PN}-babel \
30 ${PYTHON_PN}-pbr \
31 ${PYTHON_PN}-six \
32 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.i18n_3.23.1.bb b/meta-openstack/recipes-devtools/python/python-oslo.i18n_3.23.1.bb
deleted file mode 100644
index 1dedfa2..0000000
--- a/meta-openstack/recipes-devtools/python/python-oslo.i18n_3.23.1.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "oslo.i18n library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRCREV = "20bbee510b9714075b7f48f7c3968d7e2bd21a8a"
8
9SRCNAME = "oslo.i18n"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master"
11
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python-pip \
20 python-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 python-babel \
31 python-pbr \
32 python-six \
33 "
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
index 5a06622..6cfd374 100644
--- a/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
@@ -1,2 +1,34 @@
1DESCRIPTION = "oslo.i18n library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "5.0.1+git${SRCPV}"
8SRCREV = "73187bd86903fc87665a829c9a0c714db6aa3022"
9
10SRCNAME = "oslo.i18n"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
1inherit setuptools3 13inherit setuptools3
2require python-oslo.i18n.inc 14
15S = "${WORKDIR}/git"
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 ${PYTHON_PN}-pip \
21 ${PYTHON_PN}-pbr \
22 "
23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 ${PYTHON_PN}-pbr-native \
27 "
28
29# RDEPENDS_default:
30RDEPENDS_${PN} += " \
31 ${PYTHON_PN}-babel \
32 ${PYTHON_PN}-pbr \
33 ${PYTHON_PN}-six \
34 "