summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb34
1 files changed, 33 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
index 5a06622..6cfd374 100644
--- a/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.i18n_git.bb
@@ -1,2 +1,34 @@
1DESCRIPTION = "oslo.i18n library"
2HOMEPAGE = "http://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "5.0.1+git${SRCPV}"
8SRCREV = "73187bd86903fc87665a829c9a0c714db6aa3022"
9
10SRCNAME = "oslo.i18n"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
1inherit setuptools3 13inherit setuptools3
2require python-oslo.i18n.inc 14
15S = "${WORKDIR}/git"
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 ${PYTHON_PN}-pip \
21 ${PYTHON_PN}-pbr \
22 "
23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 ${PYTHON_PN}-pbr-native \
27 "
28
29# RDEPENDS_default:
30RDEPENDS_${PN} += " \
31 ${PYTHON_PN}-babel \
32 ${PYTHON_PN}-pbr \
33 ${PYTHON_PN}-six \
34 "