summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-29 22:59:02 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-01 23:10:36 -0400
commit72e4a4bedd7b6a16c0fca578ba92f7583df31bd2 (patch)
tree7c3bd4f2a332d6be83780a503d5f1acf0a0cc977
parent4fab3ee14231aac8d03b1da861c11dd53b645397 (diff)
downloadmeta-cloud-services-72e4a4bedd7b6a16c0fca578ba92f7583df31bd2.tar.gz
python3-oslo.messaging: change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb52
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb51
2 files changed, 51 insertions, 52 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
deleted file mode 100644
index 28404e3..0000000
--- a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1DESCRIPTION = "Oslo Messaging API"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6
7SRCNAME = "oslo.messaging"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9
10PV = "5.30.1+git${SRCPV}"
11SRCREV = "a07d852b237d229a0f4dd55fd83379c0581e44e9"
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python-pip \
20 python-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 bash \
31 python-pbr \
32 python-cachetools \
33 python-futurist \
34 python-oslo.log \
35 python-oslo.utils \
36 python-oslo.serialization \
37 python-oslo.middleware \
38 python-oslo.service \
39 python-oslo.i18n \
40 python-stevedore \
41 python-debtcollector \
42 python-monotonic \
43 python-six \
44 python-webob \
45 python-pyyaml \
46 python-amqp \
47 python-kombu \
48 python-pika \
49 python-pika-pool \
50 python-futures \
51 python-tenacity \
52 "
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb
new file mode 100644
index 0000000..9582c6b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb
@@ -0,0 +1,51 @@
1DESCRIPTION = "Oslo Messaging API"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6
7SRCNAME = "oslo.messaging"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
9
10PV = "12.5.0+git${SRCPV}"
11SRCREV = "62e104bdb57714a0754f788795d1b4faf8ebb74d"
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python3-pip \
20 python3-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python3-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 bash \
31 python3-pbr \
32 python3-cachetools \
33 python3-futurist \
34 python3-oslo.log \
35 python3-oslo.utils \
36 python3-oslo.serialization \
37 python3-oslo.middleware \
38 python3-oslo.service \
39 python3-oslo.i18n \
40 python3-stevedore \
41 python3-debtcollector \
42 python3-monotonic \
43 python3-six \
44 python3-webob \
45 python3-pyyaml \
46 python3-amqp \
47 python3-kombu \
48 python3-pika \
49 python3-pika-pool \
50 python3-tenacity \
51 "