summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-08 10:42:59 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-13 22:24:34 -0400
commit89fde7936386dcb530e6b28455d37f0dacd8b2ce (patch)
treeeb501367607481b26ebf5f3a16a4daa370ef3f49
parent09cf2a078e720dc1e3252359f574594cc449aa0a (diff)
downloadmeta-cloud-services-89fde7936386dcb530e6b28455d37f0dacd8b2ce.tar.gz
python3-rtslib-fb: upgrade 2.1.51 -> 2.1.74
Since python2 is no longer maintained, the recipe of python2 is removed. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-rtslib-fb.inc20
-rw-r--r--meta-openstack/recipes-devtools/python/python-rtslib-fb_2.1.51.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.51.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb25
4 files changed, 25 insertions, 24 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-rtslib-fb.inc b/meta-openstack/recipes-devtools/python/python-rtslib-fb.inc
deleted file mode 100644
index e14f33d..0000000
--- a/meta-openstack/recipes-devtools/python/python-rtslib-fb.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "API for Linux kernel SCSI target (aka LIO)"
2HOMEPAGE = "http://github.com/agrover/rtslib-fb"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=867c358d5dbac2602d0c0f850f731e62"
6
7SRC_URI[md5sum] = "4ec7575eb90b7c5a91bbea2962f0e036"
8SRC_URI[sha256sum] = "1902c581d6e04b7813f3cd1b11e2abc796205f646c39571cbbb809229fd5553e"
9
10inherit pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 "
diff --git a/meta-openstack/recipes-devtools/python/python-rtslib-fb_2.1.51.bb b/meta-openstack/recipes-devtools/python/python-rtslib-fb_2.1.51.bb
deleted file mode 100644
index 571b68c..0000000
--- a/meta-openstack/recipes-devtools/python/python-rtslib-fb_2.1.51.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-rtslib-fb.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.51.bb b/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.51.bb
deleted file mode 100644
index 571b68c..0000000
--- a/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.51.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require python-rtslib-fb.inc
2inherit setuptools3
diff --git a/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb b/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb
new file mode 100644
index 0000000..e1eef6b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "API for Linux kernel SCSI target (aka LIO)"
2HOMEPAGE = "http://github.com/agrover/rtslib-fb"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=cf391b108961d84a581f45259ec47c52"
6
7SRC_URI[md5sum] = "85ab011e3a98fb585d8a0fb337c5dab4"
8SRC_URI[sha256sum] = "6f15bc30b55e0d35f29edde4f35880965b2f1e9acee1424e6e9820f32b0a925c"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-shell \
22 ${PYTHON_PN}-six \
23 ${PYTHON_PN}-pyudev \
24 ${PYTHON_PN}-resource \
25 "