summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb b/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb
new file mode 100644
index 0000000..e1eef6b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-rtslib-fb_2.1.74.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "API for Linux kernel SCSI target (aka LIO)"
2HOMEPAGE = "http://github.com/agrover/rtslib-fb"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=cf391b108961d84a581f45259ec47c52"
6
7SRC_URI[md5sum] = "85ab011e3a98fb585d8a0fb337c5dab4"
8SRC_URI[sha256sum] = "6f15bc30b55e0d35f29edde4f35880965b2f1e9acee1424e6e9820f32b0a925c"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-shell \
22 ${PYTHON_PN}-six \
23 ${PYTHON_PN}-pyudev \
24 ${PYTHON_PN}-resource \
25 "