summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-09 01:21:39 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-13 22:22:20 -0400
commit51d39a66b83c48e77faefa09ea3eadea55de7f06 (patch)
treedbc664bb968ff9c8da4b07b1b2488dfc16e32bae
parent60afb647237e7518334c0c98e661e21eab173356 (diff)
downloadmeta-cloud-services-51d39a66b83c48e77faefa09ea3eadea55de7f06.tar.gz
python3-happybase: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-happybase.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb20
2 files changed, 18 insertions, 20 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-happybase.inc b/meta-openstack/recipes-devtools/python/python-happybase.inc
deleted file mode 100644
index 325b2d1..0000000
--- a/meta-openstack/recipes-devtools/python/python-happybase.inc
+++ /dev/null
@@ -1,18 +0,0 @@
1DESCRIPTION = "Python library to interact with Apache HBase"
2HOMEPAGE = "https://pypi.python.org/pypi/happybase/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
6
7SRC_URI[md5sum] = "96cb7ea8163f531907fabd0dddc8b87e"
8SRC_URI[sha256sum] = "850b4ee651128588a57e1e152dd1252e5ec39776a5d3d14ee892b8bac0fa9e1a"
9
10inherit pypi
11
12do_install_append() {
13 perm_files=$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt")
14 perm_files="$perm_files "$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "PKG-INFO")
15 for f in $perm_files; do
16 chmod 644 "${f}"
17 done
18}
diff --git a/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb b/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
index 8b5571b..56b6c79 100644
--- a/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
@@ -1,2 +1,18 @@
1inherit setuptools3 1DESCRIPTION = "Python library to interact with Apache HBase"
2require python-happybase.inc 2HOMEPAGE = "https://pypi.python.org/pypi/happybase/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
6
7SRC_URI[md5sum] = "96cb7ea8163f531907fabd0dddc8b87e"
8SRC_URI[sha256sum] = "850b4ee651128588a57e1e152dd1252e5ec39776a5d3d14ee892b8bac0fa9e1a"
9
10inherit setuptools3 pypi
11
12do_install_append() {
13 perm_files=$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt")
14 perm_files="$perm_files "$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "PKG-INFO")
15 for f in $perm_files; do
16 chmod 644 "${f}"
17 done
18}