summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb b/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
index 8b5571b..56b6c79 100644
--- a/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-happybase_1.2.0.bb
@@ -1,2 +1,18 @@
1inherit setuptools3 1DESCRIPTION = "Python library to interact with Apache HBase"
2require python-happybase.inc 2HOMEPAGE = "https://pypi.python.org/pypi/happybase/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=41f55ae3d7000e4323e84c468d8b42ee"
6
7SRC_URI[md5sum] = "96cb7ea8163f531907fabd0dddc8b87e"
8SRC_URI[sha256sum] = "850b4ee651128588a57e1e152dd1252e5ec39776a5d3d14ee892b8bac0fa9e1a"
9
10inherit setuptools3 pypi
11
12do_install_append() {
13 perm_files=$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt")
14 perm_files="$perm_files "$(find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "PKG-INFO")
15 for f in $perm_files; do
16 chmod 644 "${f}"
17 done
18}